aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-02-26 11:42:57 +0800
committeryuri <yuri@FreeBSD.org>2018-02-26 11:42:57 +0800
commit296658dd4098a346a6763c27306b7c3074bc2271 (patch)
treef01cbf876bbd9767bfd80bc534fe0f3aaafaee58 /math
parent0f92bdb2c77f92df464c2e2ff1560a25de50d277 (diff)
downloadfreebsd-ports-gnome-296658dd4098a346a6763c27306b7c3074bc2271.tar.gz
freebsd-ports-gnome-296658dd4098a346a6763c27306b7c3074bc2271.tar.zst
freebsd-ports-gnome-296658dd4098a346a6763c27306b7c3074bc2271.zip
math/mosesdecoder: Unbroke the port.
Port changes: * Added USES=python (used in scripts) * Added SHEBANG_FILES for pythin scripts * Added python_OLD_CMD * Added stripping * Added command silencing Approved by: tcberner (mentor, implicit)
Diffstat (limited to 'math')
-rw-r--r--math/mosesdecoder/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/math/mosesdecoder/Makefile b/math/mosesdecoder/Makefile
index e71fb253ba85..e29786f231ee 100644
--- a/math/mosesdecoder/Makefile
+++ b/math/mosesdecoder/Makefile
@@ -4,11 +4,11 @@
PORTNAME= mosesdecoder
PORTVERSION= 2.1.1
DISTVERSIONPREFIX= RELEASE-
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= math
MAINTAINER= demon@FreeBSD.org
-COMMENT= A statistical machine translation system
+COMMENT= Statistical machine translation system
BUILD_DEPENDS= bash:shells/bash \
bjam:devel/boost-jam
@@ -17,11 +17,16 @@ LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
libirstlm.so:textproc/irstlm
RUN_DEPENDS= lmplz:textproc/kenlm
+USES= compiler:c++11-lang python shebangfix
USE_GITHUB= yes
GH_ACCOUNT= moses-smt
-
-USES= compiler:c++11-lang shebangfix
SHEBANG_REGEX= ./scripts/.*\.(sh|pl|perl|cgi)
+SHEBANG_FILES= scripts/analysis/extract-target-trees.py \
+ scripts/ems/support/mml-filter.py \
+ scripts/training/flexibility_score.py \
+ scripts/training/filter-rule-table.py \
+ scripts/training/create_count_tables.py
+python_OLD_CMD= "/usr/bin/env python"
MAKE_ENV+= BOOST_BUILD_PATH=${WRKSRC}/jam-files/boost-build
@@ -29,8 +34,11 @@ do-build:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} bjam --with-boost=${LOCALBASE} --with-irstlm=${LOCALBASE} --with-randlm=${LOCALBASE} --without-tcmalloc --notrace --toolset=${CHOSEN_COMPILER_TYPE} debug-symbols=off ${_MAKE_JOBS}
do-install:
- ${MKDIR} ${STAGEDIR}${DATADIR}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} bjam --with-boost=${LOCALBASE} --with-irstlm=${LOCALBASE} --with-randlm=${LOCALBASE} --without-tcmalloc --notrace --prefix=${STAGEDIR}${PREFIX} --install-scripts=${STAGEDIR}${DATADIR} --toolset=${CHOSEN_COMPILER_TYPE} debug-symbols=off ${_MAKE_JOBS} release
cd ${STAGEDIR}${PREFIX}/bin && ${RM} build_binary filter fragment lmplz query
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/*
+
.include <bsd.port.mk>