aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2006-06-06 04:02:33 +0800
committerthierry <thierry@FreeBSD.org>2006-06-06 04:02:33 +0800
commit3186d31a58dda2ada09dbd61b416a1424b016de5 (patch)
tree013f1a36c81d7ba5459c4e54c761c85dca851276 /math
parent0c09c557141dbb9d0c99fd133ec2a4cf10880c25 (diff)
downloadfreebsd-ports-gnome-3186d31a58dda2ada09dbd61b416a1424b016de5.tar.gz
freebsd-ports-gnome-3186d31a58dda2ada09dbd61b416a1424b016de5.tar.zst
freebsd-ports-gnome-3186d31a58dda2ada09dbd61b416a1424b016de5.zip
Add preliminary support for a WITH_MPI knob and fixes a minor issue by
properly sending FFLAGS to configure. PR: ports/98109 Submitted by: Pedro F. Giffuni <giffunip (at) asme.org> (maintainer)
Diffstat (limited to 'math')
-rw-r--r--math/elmer-mathlibs/Makefile26
1 files changed, 18 insertions, 8 deletions
diff --git a/math/elmer-mathlibs/Makefile b/math/elmer-mathlibs/Makefile
index 22d63105722d..b13824e6bfe4 100644
--- a/math/elmer-mathlibs/Makefile
+++ b/math/elmer-mathlibs/Makefile
@@ -15,25 +15,35 @@ MAINTAINER= giffunip@asme.org
COMMENT= Math libraries build with F90 for used in ELMER FEM
BUILD_DEPENDS= ${FC}:${PORTSDIR}/lang/gfortran
+.ifdef WITH_MPI
+BUILD_DEPENDS+= ${LOCALBASE}/mpich/include/mpif.h:${PORTSDIR}/net/mpich
+.endif
-CONFLICTS= atlas-[0-9]* blas-[0-9]* arpack-[0-9]* lapack-[0-9]* scalapack-[0-9]*
+CONFLICTS= atlas-[0-9]* blas-[0-9]* arpack-[0-9]* lapack-[0-9]*
+.ifdef WITH_MPI
+CONFLICTS+= scalapack-[0-9]*
+.endif
USE_GCC= 4.1+
WITH_FORTRAN= yes
FC= ${LOCALBASE}/bin/gfortran41
F77= ${FC}
-CONFIGURE_ENV+= F77=${FC}
+.ifdef WITH_OPTIMIZED_FLAGS
+FFLAGS+= -O3 -ffast-math -funroll-loops
+.endif
+CONFIGURE_ENV+= F77=${FC} FFLAGS="${FFLAGS}"
GNU_CONFIGURE= yes
+.ifdef WITH_MPI
+CONFIGURE_ARGS+= --with-mpi=yes --with-mpi-dir=${LOCALBASE}/mpich
+.endif
+
ALL_TARGET=
PLIST_FILES= lib/libarpack.a lib/libblas.a lib/liblapack.a
-
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
-FFLAGS+= -fPIC
+.ifdef WITH_MPI
+PLIST_FILES+= lib/libparpack.a
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>