aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-11-07 00:15:53 +0800
committerpav <pav@FreeBSD.org>2004-11-07 00:15:53 +0800
commit47500c7eff8cf19ddcd8389bb36e079d3737e79b (patch)
treeebe64a77657f3ceae0e2414d8f59c47e6030f892 /math
parentb5eb06b9dd79338a946ce32ee89ec2e94f48cbb7 (diff)
downloadfreebsd-ports-gnome-47500c7eff8cf19ddcd8389bb36e079d3737e79b.tar.gz
freebsd-ports-gnome-47500c7eff8cf19ddcd8389bb36e079d3737e79b.tar.zst
freebsd-ports-gnome-47500c7eff8cf19ddcd8389bb36e079d3737e79b.zip
- Fix build on FreeBSD 5.3
PR: ports/73607 Submitted by: TAOKA Fumiyoshi <fmysh@iijmio-mail.jp>
Diffstat (limited to 'math')
-rw-r--r--math/vtk/Makefile3
-rw-r--r--math/vtk/files/patch-IO-vtkBMPReader.cxx16
-rw-r--r--math/vtk/files/patch-IO-vtkImageReader.cxx30
-rw-r--r--math/vtk43/Makefile3
-rw-r--r--math/vtk43/files/patch-IO-vtkBMPReader.cxx16
-rw-r--r--math/vtk43/files/patch-IO-vtkImageReader.cxx30
-rw-r--r--math/vtk5/Makefile3
-rw-r--r--math/vtk5/files/patch-IO-vtkBMPReader.cxx16
-rw-r--r--math/vtk5/files/patch-IO-vtkImageReader.cxx30
9 files changed, 144 insertions, 3 deletions
diff --git a/math/vtk/Makefile b/math/vtk/Makefile
index 662e90885ad4..fa2768748f59 100644
--- a/math/vtk/Makefile
+++ b/math/vtk/Makefile
@@ -43,6 +43,7 @@ PLIST_SUB+= LIBVER=${LIBVER} PKGNAME=${PKGNAME}
.if defined(WRAP) || !defined(PKGNAMESUFFIX) || ${PKGNAMESUFFIX}=="-headers"
+PATCH_WRKSRC= ${WRKDIR}/VTK
WRKSRC= ${WRKDIR}/${PORTNAME}${PKGNAMESUFFIX}-build
BUILD_DEPENDS+= ${CMAKE}:${PORTSDIR}/devel/cmake
@@ -131,7 +132,7 @@ pre-everything::
@${ECHO_MSG} "-------------------------------------------------------------"
.endif
-do-patch: patch-common
+post-patch: patch-common
do-install: install-cnotice install-binaries install-libs
diff --git a/math/vtk/files/patch-IO-vtkBMPReader.cxx b/math/vtk/files/patch-IO-vtkBMPReader.cxx
new file mode 100644
index 000000000000..f82deeb825e5
--- /dev/null
+++ b/math/vtk/files/patch-IO-vtkBMPReader.cxx
@@ -0,0 +1,16 @@
+diff -u -r1.44 -r1.45
+--- IO/vtkBMPReader.cxx 2003/09/10 19:41:56 1.44
++++ IO/vtkBMPReader.cxx 2003/10/19 14:38:03 1.45
+@@ -504,11 +504,11 @@
+ outPtr0 += outIncr[0];
+ }
+ // move to the next row in the file and data
+- self->GetFile()->seekg(self->GetFile()->tellg() + streamSkip0, ios::beg);
++ self->GetFile()->seekg(static_cast<long>(self->GetFile()->tellg()) + streamSkip0, ios::beg);
+ outPtr1 += outIncr[1];
+ }
+ // move to the next image in the file and data
+- self->GetFile()->seekg(self->GetFile()->tellg() + streamSkip1, ios::beg);
++ self->GetFile()->seekg(static_cast<long>(self->GetFile()->tellg()) + streamSkip1, ios::beg);
+ outPtr2 += outIncr[2];
+ }
diff --git a/math/vtk/files/patch-IO-vtkImageReader.cxx b/math/vtk/files/patch-IO-vtkImageReader.cxx
new file mode 100644
index 000000000000..3e302e72af59
--- /dev/null
+++ b/math/vtk/files/patch-IO-vtkImageReader.cxx
@@ -0,0 +1,30 @@
+diff -u -r1.109 -r1.110
+--- IO/vtkImageReader.cxx 2002/12/26 18:18:50 1.109
++++ IO/vtkImageReader.cxx 2003/10/19 14:38:03 1.110
+@@ -166,7 +166,7 @@
+ streamStart += this->GetHeaderSize(idx);
+
+ // error checking
+- this->File->seekg((long)streamStart, ios::beg);
++ this->File->seekg(static_cast<long>(streamStart), ios::beg);
+ if (this->File->fail())
+ {
+ vtkErrorMacro(<< "File operation failed: " << streamStart << ", ext: "
+@@ -366,7 +366,7 @@
+ // if that happens, store the value in correction and apply later
+ if (filePos + streamSkip0 >= 0)
+ {
+- self->GetFile()->seekg(self->GetFile()->tellg() + streamSkip0, ios::beg);
++ self->GetFile()->seekg(static_cast<long>(self->GetFile()->tellg()) + streamSkip0, ios::beg);
+ correction = 0;
+ }
+ else
+@@ -376,7 +376,7 @@
+ outPtr1 += outIncr[1];
+ }
+ // move to the next image in the file and data
+- self->GetFile()->seekg(self->GetFile()->tellg() + streamSkip1 + correction,
++ self->GetFile()->seekg(static_cast<long>(self->GetFile()->tellg()) + streamSkip1 + correction,
+ ios::beg);
+ outPtr2 += outIncr[2];
+ }
diff --git a/math/vtk43/Makefile b/math/vtk43/Makefile
index 662e90885ad4..fa2768748f59 100644
--- a/math/vtk43/Makefile
+++ b/math/vtk43/Makefile
@@ -43,6 +43,7 @@ PLIST_SUB+= LIBVER=${LIBVER} PKGNAME=${PKGNAME}
.if defined(WRAP) || !defined(PKGNAMESUFFIX) || ${PKGNAMESUFFIX}=="-headers"
+PATCH_WRKSRC= ${WRKDIR}/VTK
WRKSRC= ${WRKDIR}/${PORTNAME}${PKGNAMESUFFIX}-build
BUILD_DEPENDS+= ${CMAKE}:${PORTSDIR}/devel/cmake
@@ -131,7 +132,7 @@ pre-everything::
@${ECHO_MSG} "-------------------------------------------------------------"
.endif
-do-patch: patch-common
+post-patch: patch-common
do-install: install-cnotice install-binaries install-libs
diff --git a/math/vtk43/files/patch-IO-vtkBMPReader.cxx b/math/vtk43/files/patch-IO-vtkBMPReader.cxx
new file mode 100644
index 000000000000..f82deeb825e5
--- /dev/null
+++ b/math/vtk43/files/patch-IO-vtkBMPReader.cxx
@@ -0,0 +1,16 @@
+diff -u -r1.44 -r1.45
+--- IO/vtkBMPReader.cxx 2003/09/10 19:41:56 1.44
++++ IO/vtkBMPReader.cxx 2003/10/19 14:38:03 1.45
+@@ -504,11 +504,11 @@
+ outPtr0 += outIncr[0];
+ }
+ // move to the next row in the file and data
+- self->GetFile()->seekg(self->GetFile()->tellg() + streamSkip0, ios::beg);
++ self->GetFile()->seekg(static_cast<long>(self->GetFile()->tellg()) + streamSkip0, ios::beg);
+ outPtr1 += outIncr[1];
+ }
+ // move to the next image in the file and data
+- self->GetFile()->seekg(self->GetFile()->tellg() + streamSkip1, ios::beg);
++ self->GetFile()->seekg(static_cast<long>(self->GetFile()->tellg()) + streamSkip1, ios::beg);
+ outPtr2 += outIncr[2];
+ }
diff --git a/math/vtk43/files/patch-IO-vtkImageReader.cxx b/math/vtk43/files/patch-IO-vtkImageReader.cxx
new file mode 100644
index 000000000000..3e302e72af59
--- /dev/null
+++ b/math/vtk43/files/patch-IO-vtkImageReader.cxx
@@ -0,0 +1,30 @@
+diff -u -r1.109 -r1.110
+--- IO/vtkImageReader.cxx 2002/12/26 18:18:50 1.109
++++ IO/vtkImageReader.cxx 2003/10/19 14:38:03 1.110
+@@ -166,7 +166,7 @@
+ streamStart += this->GetHeaderSize(idx);
+
+ // error checking
+- this->File->seekg((long)streamStart, ios::beg);
++ this->File->seekg(static_cast<long>(streamStart), ios::beg);
+ if (this->File->fail())
+ {
+ vtkErrorMacro(<< "File operation failed: " << streamStart << ", ext: "
+@@ -366,7 +366,7 @@
+ // if that happens, store the value in correction and apply later
+ if (filePos + streamSkip0 >= 0)
+ {
+- self->GetFile()->seekg(self->GetFile()->tellg() + streamSkip0, ios::beg);
++ self->GetFile()->seekg(static_cast<long>(self->GetFile()->tellg()) + streamSkip0, ios::beg);
+ correction = 0;
+ }
+ else
+@@ -376,7 +376,7 @@
+ outPtr1 += outIncr[1];
+ }
+ // move to the next image in the file and data
+- self->GetFile()->seekg(self->GetFile()->tellg() + streamSkip1 + correction,
++ self->GetFile()->seekg(static_cast<long>(self->GetFile()->tellg()) + streamSkip1 + correction,
+ ios::beg);
+ outPtr2 += outIncr[2];
+ }
diff --git a/math/vtk5/Makefile b/math/vtk5/Makefile
index 662e90885ad4..fa2768748f59 100644
--- a/math/vtk5/Makefile
+++ b/math/vtk5/Makefile
@@ -43,6 +43,7 @@ PLIST_SUB+= LIBVER=${LIBVER} PKGNAME=${PKGNAME}
.if defined(WRAP) || !defined(PKGNAMESUFFIX) || ${PKGNAMESUFFIX}=="-headers"
+PATCH_WRKSRC= ${WRKDIR}/VTK
WRKSRC= ${WRKDIR}/${PORTNAME}${PKGNAMESUFFIX}-build
BUILD_DEPENDS+= ${CMAKE}:${PORTSDIR}/devel/cmake
@@ -131,7 +132,7 @@ pre-everything::
@${ECHO_MSG} "-------------------------------------------------------------"
.endif
-do-patch: patch-common
+post-patch: patch-common
do-install: install-cnotice install-binaries install-libs
diff --git a/math/vtk5/files/patch-IO-vtkBMPReader.cxx b/math/vtk5/files/patch-IO-vtkBMPReader.cxx
new file mode 100644
index 000000000000..f82deeb825e5
--- /dev/null
+++ b/math/vtk5/files/patch-IO-vtkBMPReader.cxx
@@ -0,0 +1,16 @@
+diff -u -r1.44 -r1.45
+--- IO/vtkBMPReader.cxx 2003/09/10 19:41:56 1.44
++++ IO/vtkBMPReader.cxx 2003/10/19 14:38:03 1.45
+@@ -504,11 +504,11 @@
+ outPtr0 += outIncr[0];
+ }
+ // move to the next row in the file and data
+- self->GetFile()->seekg(self->GetFile()->tellg() + streamSkip0, ios::beg);
++ self->GetFile()->seekg(static_cast<long>(self->GetFile()->tellg()) + streamSkip0, ios::beg);
+ outPtr1 += outIncr[1];
+ }
+ // move to the next image in the file and data
+- self->GetFile()->seekg(self->GetFile()->tellg() + streamSkip1, ios::beg);
++ self->GetFile()->seekg(static_cast<long>(self->GetFile()->tellg()) + streamSkip1, ios::beg);
+ outPtr2 += outIncr[2];
+ }
diff --git a/math/vtk5/files/patch-IO-vtkImageReader.cxx b/math/vtk5/files/patch-IO-vtkImageReader.cxx
new file mode 100644
index 000000000000..3e302e72af59
--- /dev/null
+++ b/math/vtk5/files/patch-IO-vtkImageReader.cxx
@@ -0,0 +1,30 @@
+diff -u -r1.109 -r1.110
+--- IO/vtkImageReader.cxx 2002/12/26 18:18:50 1.109
++++ IO/vtkImageReader.cxx 2003/10/19 14:38:03 1.110
+@@ -166,7 +166,7 @@
+ streamStart += this->GetHeaderSize(idx);
+
+ // error checking
+- this->File->seekg((long)streamStart, ios::beg);
++ this->File->seekg(static_cast<long>(streamStart), ios::beg);
+ if (this->File->fail())
+ {
+ vtkErrorMacro(<< "File operation failed: " << streamStart << ", ext: "
+@@ -366,7 +366,7 @@
+ // if that happens, store the value in correction and apply later
+ if (filePos + streamSkip0 >= 0)
+ {
+- self->GetFile()->seekg(self->GetFile()->tellg() + streamSkip0, ios::beg);
++ self->GetFile()->seekg(static_cast<long>(self->GetFile()->tellg()) + streamSkip0, ios::beg);
+ correction = 0;
+ }
+ else
+@@ -376,7 +376,7 @@
+ outPtr1 += outIncr[1];
+ }
+ // move to the next image in the file and data
+- self->GetFile()->seekg(self->GetFile()->tellg() + streamSkip1 + correction,
++ self->GetFile()->seekg(static_cast<long>(self->GetFile()->tellg()) + streamSkip1 + correction,
+ ios::beg);
+ outPtr2 += outIncr[2];
+ }