aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-01-31 11:40:46 +0800
committerlinimon <linimon@FreeBSD.org>2017-01-31 11:40:46 +0800
commit5f8cfeecdfe3b38a23300470e9b836ada7916daa (patch)
tree0d0809d74c7183324fd4c40d2cc1f8c9c36af021 /math
parent59a089f597ea0dba8f7962c3c2153b0d9444e15a (diff)
downloadfreebsd-ports-gnome-5f8cfeecdfe3b38a23300470e9b836ada7916daa.tar.gz
freebsd-ports-gnome-5f8cfeecdfe3b38a23300470e9b836ada7916daa.tar.zst
freebsd-ports-gnome-5f8cfeecdfe3b38a23300470e9b836ada7916daa.zip
Mark various ports broken on aarch64 and armv6.
Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'math')
-rw-r--r--math/amath/Makefile3
-rw-r--r--math/asir2000/Makefile2
-rw-r--r--math/stp/Makefile2
3 files changed, 7 insertions, 0 deletions
diff --git a/math/amath/Makefile b/math/amath/Makefile
index 38ef590abd9a..71e06704dd53 100644
--- a/math/amath/Makefile
+++ b/math/amath/Makefile
@@ -23,4 +23,7 @@ do-install:
do-test:
${WRKSRC}/${PORTNAME} test
+BROKEN_aarch64= Fails to compile: must define endianness
+BROKEN_armv6= Fails to configure: what cpu is this ?!
+
.include <bsd.port.mk>
diff --git a/math/asir2000/Makefile b/math/asir2000/Makefile
index df5febf13122..8ed76a77eb8d 100644
--- a/math/asir2000/Makefile
+++ b/math/asir2000/Makefile
@@ -35,6 +35,8 @@ ASIR_DOC= asirdoc-${ASIR_DOC_VERSION}${EXTRACT_SUFX}
GC_SRC= gc-${GC_VERSION}.tar.gz
WRKSRC= ${WRKDIR}/asir2000
+BROKEN_aarch64= Fails to compile: the collector has not been ported to this machine/OS combination
+
LIB_DATA= alpi bfct bgk const cyclic defs.h dfff dmul dmul102 fctrdata \
fctrtest fff glib gr ifplot katsura launch mat nf num primdec \
primdec_lex primdec_mod ratint robot solve sp sturm sym weight xm
diff --git a/math/stp/Makefile b/math/stp/Makefile
index 1cd015245801..b012dd4f1fb4 100644
--- a/math/stp/Makefile
+++ b/math/stp/Makefile
@@ -19,4 +19,6 @@ USES= bison:build cmake perl5 tar:xz
USE_PERL5= build
CMAKE_ARGS= -DFL_LIBRARY=/usr/lib/libfl.a
+BROKEN_aarch64= Fails to compile: undefined reference to sbrk
+
.include <bsd.port.mk>