aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorstephen <stephen@FreeBSD.org>2014-12-15 06:06:49 +0800
committerstephen <stephen@FreeBSD.org>2014-12-15 06:06:49 +0800
commit62ce2694464611079c1a94622cd27c0cb6ed8f57 (patch)
tree9e287f420b054f62dd2055eee709cd207d174f1b /math
parent03db34f052bf4f42c87200377fe68470b0c174ad (diff)
downloadfreebsd-ports-gnome-62ce2694464611079c1a94622cd27c0cb6ed8f57.tar.gz
freebsd-ports-gnome-62ce2694464611079c1a94622cd27c0cb6ed8f57.tar.zst
freebsd-ports-gnome-62ce2694464611079c1a94622cd27c0cb6ed8f57.zip
- New port math/octave-forge-optics.
The octave-forge package is the result of The GNU Octave Repositry project, which is intended to be a central location for custom scripts, functions and extensions for GNU Octave. contains the source for all the functions plus build and install scripts. This is optics.
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/octave-forge-optics/Makefile28
-rw-r--r--math/octave-forge-optics/distinfo2
-rw-r--r--math/octave-forge-optics/pkg-descr10
-rw-r--r--math/octave-forge-optics/pkg-plist1
5 files changed, 42 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 87bd2d3a6bb5..c29bdb0a193f 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -329,6 +329,7 @@
SUBDIR += octave-forge-octproj
SUBDIR += octave-forge-odebvp
SUBDIR += octave-forge-odepkg
+ SUBDIR += octave-forge-optics
SUBDIR += octave-forge-optim
SUBDIR += octave-forge-optiminterp
SUBDIR += octave-forge-outliers
diff --git a/math/octave-forge-optics/Makefile b/math/octave-forge-optics/Makefile
new file mode 100644
index 000000000000..b84eff9e2ee9
--- /dev/null
+++ b/math/octave-forge-optics/Makefile
@@ -0,0 +1,28 @@
+# Created by: Stephen Montgomery-Smith <stephen@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= octave-forge-optics
+PORTVERSION= 0.1.1
+CATEGORIES= math
+
+MAINTAINER= stephen@FreeBSD.org
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+LICENSE= GPLv2
+
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= octave-${OCTAVE_PKGNAME}
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
+
+.include "${.CURDIR}/../../Mk/bsd.octave.mk"
+
+do-build:
+ @${DO_NADA}
+
+post-build:
+ ${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
+
+.include <bsd.port.mk>
diff --git a/math/octave-forge-optics/distinfo b/math/octave-forge-optics/distinfo
new file mode 100644
index 000000000000..7fdacef49124
--- /dev/null
+++ b/math/octave-forge-optics/distinfo
@@ -0,0 +1,2 @@
+SHA256 (octave-forge/optics-0.1.1.tar.gz) = b660aa4ba5b340952ac8bc6ffcfa23982368c9444b3787e2139233a2dda51a6a
+SIZE (octave-forge/optics-0.1.1.tar.gz) = 33481
diff --git a/math/octave-forge-optics/pkg-descr b/math/octave-forge-optics/pkg-descr
new file mode 100644
index 000000000000..bb13a8c66021
--- /dev/null
+++ b/math/octave-forge-optics/pkg-descr
@@ -0,0 +1,10 @@
+The octave-forge package is the result of The GNU Octave Repositry project,
+which is intended to be a central location for custom scripts, functions and
+extensions for GNU Octave. contains the source for all the functions plus
+build and install scripts.
+
+This is optics.
+
+ Functions covering various aspects of optics.
+
+WWW: http://octave.sourceforge.net/
diff --git a/math/octave-forge-optics/pkg-plist b/math/octave-forge-optics/pkg-plist
new file mode 100644
index 000000000000..a999ec86c07e
--- /dev/null
+++ b/math/octave-forge-optics/pkg-plist
@@ -0,0 +1 @@
+@comment This file intentionally left empty