aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2011-10-14 14:30:26 +0800
committermaho <maho@FreeBSD.org>2011-10-14 14:30:26 +0800
commit691b053452c9307fe6f35a13a2895e7ea117fcba (patch)
tree0c11332a065922fa8e6519bcf3dac786c84457b4 /math
parent38b3db5934d62ef76ef2776f7309c07592ad6b93 (diff)
downloadfreebsd-ports-gnome-691b053452c9307fe6f35a13a2895e7ea117fcba.tar.gz
freebsd-ports-gnome-691b053452c9307fe6f35a13a2895e7ea117fcba.tar.zst
freebsd-ports-gnome-691b053452c9307fe6f35a13a2895e7ea117fcba.zip
Dynamic selection of arch is only for package building.
Submitted by: bf
Diffstat (limited to 'math')
-rw-r--r--math/gotoblas/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/math/gotoblas/Makefile b/math/gotoblas/Makefile
index 407f132f0d56..0bb4cbf1480e 100644
--- a/math/gotoblas/Makefile
+++ b/math/gotoblas/Makefile
@@ -40,6 +40,12 @@ PLIST_FILES= ${GOTOFILES:S|^|lib/|}
SUB_FILES= pkg-message
SUB_LIST= MAXTHREADS=${MAXTHREADS}
+.if defined(PACKAGE_BUILDING)
+DYNAMIC_ARCH_DEFAULT= on
+.else
+DYNAMIC_ARCH_DEFAULT= off
+.endif
+
OPTIONS= DYNAMIC_ARCH "Support multiple CPU types on i386 and amd64" \
${DYNAMIC_ARCH_DEFAULT} \
INTERFACE64 "Use 8 byte integers on 64-bit architectures" off \
@@ -48,12 +54,6 @@ OPTIONS= DYNAMIC_ARCH "Support multiple CPU types on i386 and amd64" \
.include <bsd.port.pre.mk>
-.if defined(PACKAGE_BUILDING)
-DYNAMIC_ARCH_DEFAULT= on
-.else
-DYNAMIC_ARCH_DEFAULT= off
-.endif
-
MAXTHREADS?= 8
.if ${ARCH:M*64} == ""
@@ -62,6 +62,10 @@ GOTOFLAGS+= BINARY32=1
GOTOFLAGS+= BINARY64=1
.endif
+.if ! ( defined(WITH_DYNAMIC_ARCH) && ( ${ARCH} == "amd64" || ${ARCH} == "i386" ) )
+MANUAL_PACKAGE_BUILD= Optimizes for the build machine.
+.endif
+
.if defined(WITH_DYNAMIC_ARCH)
GOTOFLAGS+= DYNAMIC_ARCH=1
.endif