aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-01-10 07:11:40 +0800
committermiwi <miwi@FreeBSD.org>2009-01-10 07:11:40 +0800
commit6dea2264426520dd15b771dac2547591f998badd (patch)
treea8fe3b166333f7e732938190a865596d0ea74e86 /math
parent54f5f6f43db641c729efe384b6ebf6a13aa88453 (diff)
downloadfreebsd-ports-gnome-6dea2264426520dd15b771dac2547591f998badd.tar.gz
freebsd-ports-gnome-6dea2264426520dd15b771dac2547591f998badd.tar.zst
freebsd-ports-gnome-6dea2264426520dd15b771dac2547591f998badd.zip
p5-Math-Polygon is a perl class provides an OO interface around
Math::Polygon::Calc and Math::Polygon::Clip. WWW: http://search.cpan.org/dist/Math-Polygon/ PR: ports/130302 Submitted by: Wen Heping <wenheping at gmail.com>
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-Polygon/Makefile31
-rw-r--r--math/p5-Math-Polygon/distinfo3
-rw-r--r--math/p5-Math-Polygon/pkg-descr4
-rw-r--r--math/p5-Math-Polygon/pkg-plist16
5 files changed, 55 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index c86f4a400550..e7a401b1c130 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -307,6 +307,7 @@
SUBDIR += p5-Math-Matrix
SUBDIR += p5-Math-NumberCruncher
SUBDIR += p5-Math-Pari
+ SUBDIR += p5-Math-Polygon
SUBDIR += p5-Math-Polynomial-Solve
SUBDIR += p5-Math-Random
SUBDIR += p5-Math-Random-MT
diff --git a/math/p5-Math-Polygon/Makefile b/math/p5-Math-Polygon/Makefile
new file mode 100644
index 000000000000..2ac2ff8dfc6c
--- /dev/null
+++ b/math/p5-Math-Polygon/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Math-Polygon
+# Date created: 2009-01-07
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Polygon
+PORTVERSION= 1.00
+CATEGORIES= math perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Class for Maintaining Polygon Data
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/Simple.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ p5-Test-Pod>=0:${PORTSDIR}/devel/p5-Test-Pod \
+ p5-Math-Complex>=1.54:${PORTSDIR}/math/p5-Math-Complex \
+ p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Math::Polygon.3 \
+ Math::Polygon::Calc.3 \
+ Math::Polygon::Clip.3 \
+ Math::Polygon::Surface.3 \
+ Math::Polygon::Transform.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Polygon/distinfo b/math/p5-Math-Polygon/distinfo
new file mode 100644
index 000000000000..499b9fac1b85
--- /dev/null
+++ b/math/p5-Math-Polygon/distinfo
@@ -0,0 +1,3 @@
+MD5 (Math-Polygon-1.00.tar.gz) = 52b17688acb351a38842c6ee9cea8a6a
+SHA256 (Math-Polygon-1.00.tar.gz) = c4f95b573d07d4057dd58247a01dfdcde15c95fcb021e02f703110d68ffd2f35
+SIZE (Math-Polygon-1.00.tar.gz) = 19528
diff --git a/math/p5-Math-Polygon/pkg-descr b/math/p5-Math-Polygon/pkg-descr
new file mode 100644
index 000000000000..0d641adb2b2d
--- /dev/null
+++ b/math/p5-Math-Polygon/pkg-descr
@@ -0,0 +1,4 @@
+p5-Math-Polygon is a perl class provides an OO interface around
+Math::Polygon::Calc and Math::Polygon::Clip.
+
+WWW: http://search.cpan.org/dist/Math-Polygon/
diff --git a/math/p5-Math-Polygon/pkg-plist b/math/p5-Math-Polygon/pkg-plist
new file mode 100644
index 000000000000..a4073adb26b7
--- /dev/null
+++ b/math/p5-Math-Polygon/pkg-plist
@@ -0,0 +1,16 @@
+%%SITE_PERL%%/Math/Polygon.pod
+%%SITE_PERL%%/Math/Polygon/Surface.pm
+%%SITE_PERL%%/Math/Polygon/Transform.pm
+%%SITE_PERL%%/Math/Polygon/Calc.pm
+%%SITE_PERL%%/Math/Polygon/Transform.pod
+%%SITE_PERL%%/Math/Polygon/Clip.pm
+%%SITE_PERL%%/Math/Polygon/Surface.pod
+%%SITE_PERL%%/Math/Polygon/Calc.pod
+%%SITE_PERL%%/Math/Polygon/Clip.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Polygon/.packlist
+%%SITE_PERL%%/Math/Polygon.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
+@dirrmtry %%SITE_PERL%%/Math/Polygon
+@dirrmtry %%SITE_PERL%%/Math
+@dirrmtry %%SITE_PERL%%/mach/auto/Math/Polygon
+@dirrmtry %%SITE_PERL%%/mach/auto/Math