aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2004-10-24 11:37:02 +0800
committermaho <maho@FreeBSD.org>2004-10-24 11:37:02 +0800
commit6ed26f209c5593a59520d6147cdad255da6c08e4 (patch)
tree07497e3bed17737b2789f726addd297397784287 /math
parent831eeb5a13bb7f12830a2d6078ad17bd00c9d788 (diff)
downloadfreebsd-ports-gnome-6ed26f209c5593a59520d6147cdad255da6c08e4.tar.gz
freebsd-ports-gnome-6ed26f209c5593a59520d6147cdad255da6c08e4.tar.zst
freebsd-ports-gnome-6ed26f209c5593a59520d6147cdad255da6c08e4.zip
Avoid the use of != statements in ports Makefile
PR: 71095 Submitted by: eik
Diffstat (limited to 'math')
-rw-r--r--math/atlas-devel/Makefile6
-rw-r--r--math/atlas/Makefile6
2 files changed, 10 insertions, 2 deletions
diff --git a/math/atlas-devel/Makefile b/math/atlas-devel/Makefile
index bf5c0e1a04d9..51d169bd0cf0 100644
--- a/math/atlas-devel/Makefile
+++ b/math/atlas-devel/Makefile
@@ -50,7 +50,11 @@ post-patch:
@(cd ${WRKSRC}; ${PATCH} < ${FILESDIR}/alpha-patch)
.endif
-PICFLAG!= ${MAKE} -f bsd.lib.mk -V PICFLAG
+.if ${MACHINE_ARCH} == "sparc64"
+PICFLAG?= -fPIC
+.else
+PICFLAG?= -fpic
+.endif
ANSWER_i386?= ${PRINTF} "\n\n\n\n\n\n\n\n\n\n"
ANSWER_ia64?= ${PRINTF} "\n\n\n2\n\n\n\n\nf77\n-O2 -static\n\n"
diff --git a/math/atlas/Makefile b/math/atlas/Makefile
index 7e6f246233f2..33122077e3f4 100644
--- a/math/atlas/Makefile
+++ b/math/atlas/Makefile
@@ -49,7 +49,11 @@ post-patch:
@(cd ${WRKSRC}; ${PATCH} < ${FILESDIR}/alpha-patch)
.endif
-PICFLAG!= ${MAKE} -f bsd.lib.mk -V PICFLAG
+.if ${MACHINE_ARCH} == "sparc64"
+PICFLAG?= -fPIC
+.else
+PICFLAG?= -fpic
+.endif
ANSWER_i386?= ${PRINTF} "\n\n\n\n\n\n\n\n\n\n"
ANSWER_ia64?= ${PRINTF} "\n\n\n2\n\n\n\n\nf77\n-O2 -static\n\n"