aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-09-03 01:04:14 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-09-03 01:04:14 +0800
commit863cab746f5dd32124a2af5217b1ed235f0171e4 (patch)
tree6e435a376ad5344fe3b37a2c9b3d1f343eaf07c8 /math
parent66fe3acd66c2ee223dbf465c800e10e77faf65d3 (diff)
downloadfreebsd-ports-gnome-863cab746f5dd32124a2af5217b1ed235f0171e4.tar.gz
freebsd-ports-gnome-863cab746f5dd32124a2af5217b1ed235f0171e4.tar.zst
freebsd-ports-gnome-863cab746f5dd32124a2af5217b1ed235f0171e4.zip
- Allow concurrent installation (USE_PYTHON=concurrent)
- Strip shared library - Bump PORTREVISION for package change
Diffstat (limited to 'math')
-rw-r--r--math/py-numexpr/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/math/py-numexpr/Makefile b/math/py-numexpr/Makefile
index f49e182baaa2..5f2cf98ce9ce 100644
--- a/math/py-numexpr/Makefile
+++ b/math/py-numexpr/Makefile
@@ -4,6 +4,7 @@
PORTNAME= numexpr
PORTVERSION= 2.4
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= math python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,10 +16,13 @@ LICENSE= MIT
BUILD_DEPENDS= ${PYNUMPY}
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_PYTHON= autoplist distutils
+USE_PYTHON= autoplist concurrent distutils
USES= python
GH_ACCOUNT= pydata
USE_GITHUB= yes
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/numexpr/interpreter.so
+
.include <bsd.port.mk>