aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorstephen <stephen@FreeBSD.org>2011-07-23 08:03:50 +0800
committerstephen <stephen@FreeBSD.org>2011-07-23 08:03:50 +0800
commit9945a9d89185da3ff4b2ee90a4917b741ad2bce4 (patch)
tree6e2ab2742edb48fb6413857fa32ea2410a50eb06 /math
parentcca74d0f4fa275cc0260a01d740aae996e09a10f (diff)
downloadfreebsd-ports-gnome-9945a9d89185da3ff4b2ee90a4917b741ad2bce4.tar.gz
freebsd-ports-gnome-9945a9d89185da3ff4b2ee90a4917b741ad2bce4.tar.zst
freebsd-ports-gnome-9945a9d89185da3ff4b2ee90a4917b741ad2bce4.zip
- Add patches to fix build errors.
- Bump portrevision. Approved by: maho (mentor, implicit)
Diffstat (limited to 'math')
-rw-r--r--math/octave-forge-communications/Makefile4
-rw-r--r--math/octave-forge-communications/files/patch-galois.cc36
-rw-r--r--math/octave-forge-communications/files/patch-gf.cc10
-rw-r--r--math/octave-forge-communications/files/patch-ov-galois.cc89
-rw-r--r--math/octave-forge-communications/files/patch-syndtable.cc10
5 files changed, 146 insertions, 3 deletions
diff --git a/math/octave-forge-communications/Makefile b/math/octave-forge-communications/Makefile
index a63a1c09f280..351fcc637b7b 100644
--- a/math/octave-forge-communications/Makefile
+++ b/math/octave-forge-communications/Makefile
@@ -7,14 +7,12 @@
PORTNAME= octave-forge-communications
PORTVERSION= 1.0.10
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= math
MAINTAINER= stephen@FreeBSD.org
COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
-BROKEN= Does not build with Octave-3.4.0
-
GNU_CONFIGURE= yes
RUN_DEPENDS+= ${TARBALLS_DIR}/signal.tar.gz:${PORTSDIR}/math/octave-forge-signal
diff --git a/math/octave-forge-communications/files/patch-galois.cc b/math/octave-forge-communications/files/patch-galois.cc
new file mode 100644
index 000000000000..d8facb18373b
--- /dev/null
+++ b/math/octave-forge-communications/files/patch-galois.cc
@@ -0,0 +1,36 @@
+--- src/galois.cc-orig 2011-07-22 23:34:28.000000000 +0000
++++ src/galois.cc 2011-07-22 23:40:32.000000000 +0000
+@@ -89,7 +89,7 @@
+ field = stored_galois_fields.create_galois_field(_m, _primpoly);
+ }
+
+-galois::galois (int nr, int nc, const int& val, const int& _m, const int& _primpoly) : MArray2<int> (nr, nc, val), field (NULL) {
++galois::galois (int nr, int nc, const int& val, const int& _m, const int& _primpoly) : MArray<int> (dim_vector(nr, nc), val), field (NULL) {
+ int _n = (1<<_m) - 1;
+
+ // Check the validity of the data in the matrix
+@@ -101,7 +101,7 @@
+ field = stored_galois_fields.create_galois_field(_m, _primpoly);
+ }
+
+-galois::galois (int nr, int nc, double val, const int& _m, const int& _primpoly) : MArray2<int> (nr, nc, (int)val), field (NULL) {
++galois::galois (int nr, int nc, double val, const int& _m, const int& _primpoly) : MArray<int> (dim_vector(nr, nc), (int)val), field (NULL) {
+ int _n = (1<<_m) - 1;
+
+ // Check the validity of the data in the matrix
+@@ -711,13 +711,13 @@
+ boolMatrix
+ galois::all (int dim) const
+ {
+- return do_mx_red_op<boolMatrix> (*this, dim, mx_inline_all);
++ return do_mx_red_op<bool> (*this, dim, mx_inline_all);
+ }
+
+ boolMatrix
+ galois::any (int dim) const
+ {
+- return do_mx_red_op<boolMatrix> (*this, dim, mx_inline_any);
++ return do_mx_red_op<bool> (*this, dim, mx_inline_any);
+ }
+
+ galois
diff --git a/math/octave-forge-communications/files/patch-gf.cc b/math/octave-forge-communications/files/patch-gf.cc
new file mode 100644
index 000000000000..8a2c47213ecb
--- /dev/null
+++ b/math/octave-forge-communications/files/patch-gf.cc
@@ -0,0 +1,10 @@
+--- src/gf.cc-orig 2011-07-22 23:41:54.000000000 +0000
++++ src/gf.cc 2011-07-22 23:42:13.000000000 +0000
+@@ -49,6 +49,7 @@
+ #include "ov-galois.h"
+ #include <octave/utils.h>
+ #include <octave/variables.h>
++#include <octave/Array2.h>
+
+ static bool galois_type_loaded = false;
+
diff --git a/math/octave-forge-communications/files/patch-ov-galois.cc b/math/octave-forge-communications/files/patch-ov-galois.cc
new file mode 100644
index 000000000000..fe4e4112b3b4
--- /dev/null
+++ b/math/octave-forge-communications/files/patch-ov-galois.cc
@@ -0,0 +1,89 @@
+--- src/ov-galois.cc-orig 2011-07-22 23:43:09.000000000 +0000
++++ src/ov-galois.cc 2011-07-22 23:52:23.000000000 +0000
+@@ -205,10 +205,6 @@
+ void
+ octave_galois::print_raw (std::ostream& os, bool) const
+ {
+- unwind_protect::begin_frame ("octave_galois_print");
+-
+- unwind_protect_int (Vstruct_levels_to_print);
+-
+ bool first = true;
+ int m = gval.m();
+ int primpoly = gval.primpoly();
+@@ -256,8 +252,6 @@
+
+ octave_print_internal (os, data, false, current_print_indent_level ());
+ newline (os);
+-
+- unwind_protect::run_frame ("octave_galois_print");
+ }
+
+ bool
+@@ -554,7 +548,7 @@
+ {
+ Matrix mval = matrix_value ();
+ hid_t group_hid = -1;
+- group_hid = H5Gcreate (loc_id, name, 0);
++ group_hid = H5Gcreate (loc_id, name, H5P_DEFAULT, H5P_DEFAULT, H5P_DEFAULT);
+ if (group_hid < 0 ) return false;
+
+ dim_vector d = dims ();
+@@ -572,7 +566,7 @@
+ }
+
+ data_hid = H5Dcreate (group_hid, "m", H5T_NATIVE_UCHAR, space_hid,
+- H5P_DEFAULT);
++ H5P_DEFAULT, H5P_DEFAULT, H5P_DEFAULT);
+ if (data_hid < 0)
+ {
+ H5Sclose (space_hid);
+@@ -592,7 +586,7 @@
+ }
+
+ data_hid = H5Dcreate (group_hid, "prim", H5T_NATIVE_UINT, space_hid,
+- H5P_DEFAULT);
++ H5P_DEFAULT, H5P_DEFAULT, H5P_DEFAULT);
+ if (data_hid < 0)
+ {
+ H5Sclose (space_hid);
+@@ -644,7 +638,7 @@
+ }
+
+ data_hid = H5Dcreate (group_hid, "val", save_type_hid, space_hid,
+- H5P_DEFAULT);
++ H5P_DEFAULT, H5P_DEFAULT, H5P_DEFAULT);
+ if (data_hid < 0)
+ {
+ H5Sclose (space_hid);
+@@ -671,10 +665,10 @@
+ hid_t group_hid, data_hid, space_id;
+ hsize_t rank;
+
+- group_hid = H5Gopen (loc_id, name);
++ group_hid = H5Gopen (loc_id, name, H5P_DEFAULT);
+ if (group_hid < 0 ) return false;
+
+- data_hid = H5Dopen (group_hid, "m");
++ data_hid = H5Dopen (group_hid, "m", H5P_DEFAULT);
+ space_id = H5Dget_space (data_hid);
+ rank = H5Sget_simple_extent_ndims (space_id);
+
+@@ -694,7 +688,7 @@
+ }
+
+ H5Dclose (data_hid);
+- data_hid = H5Dopen (group_hid, "prim");
++ data_hid = H5Dopen (group_hid, "prim", H5P_DEFAULT);
+ space_id = H5Dget_space (data_hid);
+ rank = H5Sget_simple_extent_ndims (space_id);
+
+@@ -714,7 +708,7 @@
+ }
+
+ H5Dclose (data_hid);
+- data_hid = H5Dopen (group_hid, "val");
++ data_hid = H5Dopen (group_hid, "val", H5P_DEFAULT);
+ space_id = H5Dget_space (data_hid);
+ rank = H5Sget_simple_extent_ndims (space_id);
+
diff --git a/math/octave-forge-communications/files/patch-syndtable.cc b/math/octave-forge-communications/files/patch-syndtable.cc
new file mode 100644
index 000000000000..df8b32d9c225
--- /dev/null
+++ b/math/octave-forge-communications/files/patch-syndtable.cc
@@ -0,0 +1,10 @@
+--- src/syndtable.cc-orig 2011-07-22 23:25:35.000000000 +0000
++++ src/syndtable.cc 2011-07-22 23:26:01.000000000 +0000
+@@ -27,6 +27,7 @@
+ #include <sstream>
+ #include <octave/oct.h>
+ #include <octave/pager.h>
++#include <octave/Array2.h>
+
+ #define COL_MAJ(N) (N / (SIZEOF_INT << 3))
+ #define COL_MIN(N) (N % (SIZEOF_INT << 3))