aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2014-03-28 17:23:08 +0800
committermakc <makc@FreeBSD.org>2014-03-28 17:23:08 +0800
commitb2a592306a8da9afccf9b91416b561ee388a575e (patch)
tree060c005917437635aa14c75c00174bc932c52884 /math
parent1a7b7ff2441bc557343b641838a83f54cd232a2f (diff)
downloadfreebsd-ports-gnome-b2a592306a8da9afccf9b91416b561ee388a575e.tar.gz
freebsd-ports-gnome-b2a592306a8da9afccf9b91416b561ee388a575e.tar.zst
freebsd-ports-gnome-b2a592306a8da9afccf9b91416b561ee388a575e.zip
graphics/vips and the rest:
- bump PORTREVISION after math/matio update math/dynare: - fix configure check for matio - while here, remove needless patch for configure.ac, and convert to USES=tar:xz Approved by: Fernando Apesteguia (maintainer) math/scilab: - mark BROKEN when building with MATIO option (doesn't support new matio) science/kst2: - fix dependency type for matio - add dependence on pkgconfig
Diffstat (limited to 'math')
-rw-r--r--math/dynare/Makefile10
-rw-r--r--math/dynare/files/patch-configure.ac27
-rw-r--r--math/scilab/Makefile1
3 files changed, 8 insertions, 30 deletions
diff --git a/math/dynare/Makefile b/math/dynare/Makefile
index 4d301dc0db0b..13a04b8700f9 100644
--- a/math/dynare/Makefile
+++ b/math/dynare/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dynare
PORTVERSION= 4.4.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= http://www.dynare.org/release/source/
@@ -16,8 +16,7 @@ LIB_DEPENDS= libumfpack.so:${PORTSDIR}/math/suitesparse \
WRKSRC= ${WRKDIR}/${DISTNAME}
GNU_CONFIGURE= yes
-USES= fortran gmake
-USE_XZ= yes
+USES= fortran gmake pkgconfig tar:xz
INFO= dynare
@@ -33,6 +32,11 @@ OCTAVE_BUILD_DEPENDS= octave:${PORTSDIR}/math/octave
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+pre-configure:
+# fix matio detection
+ ${REINPLACE_CMD} 's,-lmatio .*$$LIBS,`pkgconf --libs matio`,' \
+ ${WRKSRC}/configure ${WRKSRC}/mex/build/octave/configure
+
post-configure:
@${ECHO_MSG} ""
@${ECHO_MSG} ""
diff --git a/math/dynare/files/patch-configure.ac b/math/dynare/files/patch-configure.ac
deleted file mode 100644
index e1336c88135b..000000000000
--- a/math/dynare/files/patch-configure.ac
+++ /dev/null
@@ -1,27 +0,0 @@
---- mex/build/octave/configure.ac.orig 2013-12-06 14:52:59.682612000 +0100
-+++ mex/build/octave/configure.ac 2014-01-10 20:59:19.000000000 +0100
-@@ -36,6 +36,7 @@
- CFLAGS="$CFLAGS -Wall -Wno-parentheses"
- FFLAGS="$FFLAGS -Wall"
- CXXFLAGS="$CXXFLAGS -Wall -Wno-parentheses"
-+LIBS="-lumfpack -llapack -lblas -lsuitesparseconfig -lcholmod -lcolamd -lamd"
-
- AC_PROG_F77([gfortran g77 f77])
- AC_PROG_CC
-@@ -61,14 +62,10 @@
- AM_CONDITIONAL([HAVE_SLICOT], [test "x$has_slicot" = "xyes"])
-
- # Check for UMFPACK, needed by bytecode
--AC_CHECK_LIB([umfpack], [umfpack_dl_defaults], [LIBADD_UMFPACK="-lumfpack"], [AC_MSG_ERROR([Can't find UMFPACK])])
-+AC_CHECK_LIB([umfpack], [umfpack_dl_defaults], [LIBADD_UMFPACK="-lumfpack -llapack -lblas -lsuitesparseconfig -lcholmod -lcolamd -lamd"], [AC_MSG_ERROR([Can't find UMFPACK])])
- # For OS X, explicitly add libraries that libumfpack depends on as Homebrew
- # doesn't support the creation of shared libraries for suite-sparse 3.7.0
--case ${host_os} in
-- darwin*)
-- LIBADD_UMFPACK="-lumfpack -lcholmod -lcolamd -lamd"
-- ;;
--esac
-+LIBADD_UMFPACK="-lumfpack -llapack -lblas -lsuitesparseconfig -lcholmod -lcolamd -lamd"
- AC_SUBST([LIBADD_UMFPACK])
-
- AM_CONDITIONAL([DO_SOMETHING], [test "x$MKOCTFILE" != "x"])
diff --git a/math/scilab/Makefile b/math/scilab/Makefile
index cd5cd4d81df8..4b9e3b1b0808 100644
--- a/math/scilab/Makefile
+++ b/math/scilab/Makefile
@@ -173,6 +173,7 @@ CONFIGURE_ARGS+= --with-umfpack-include=${LOCALBASE}/include \
.if ! ${PORT_OPTIONS:MMATIO}
CONFIGURE_ARGS+= --without-matio
.else
+BROKEN= doesn't build with modern matio
LIB_DEPENDS+= libmatio.so:${PORTSDIR}/math/matio
.endif