aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorstephen <stephen@FreeBSD.org>2011-07-23 11:31:23 +0800
committerstephen <stephen@FreeBSD.org>2011-07-23 11:31:23 +0800
commitb389bdf19e8f8cd5c439cf5c001598b1b6d96fb9 (patch)
treec175cf966ca16093f1647f0b64b64c9a0a000689 /math
parent8d3b77959025e004b4bf9742b17c73437cbff1fa (diff)
downloadfreebsd-ports-gnome-b389bdf19e8f8cd5c439cf5c001598b1b6d96fb9.tar.gz
freebsd-ports-gnome-b389bdf19e8f8cd5c439cf5c001598b1b6d96fb9.tar.zst
freebsd-ports-gnome-b389bdf19e8f8cd5c439cf5c001598b1b6d96fb9.zip
- Add patch to fix build errors.
- Bump portrevision. Approved by: maho (mentor, implicit)
Diffstat (limited to 'math')
-rw-r--r--math/octave-forge-es/Makefile4
-rw-r--r--math/octave-forge-es/files/patch-help.icc38
-rw-r--r--math/octave-forge-pt_br/Makefile4
-rw-r--r--math/octave-forge-pt_br/files/patch-help.icc38
4 files changed, 78 insertions, 6 deletions
diff --git a/math/octave-forge-es/Makefile b/math/octave-forge-es/Makefile
index bee04010af9b..3da256693b40 100644
--- a/math/octave-forge-es/Makefile
+++ b/math/octave-forge-es/Makefile
@@ -7,14 +7,12 @@
PORTNAME= octave-forge-es
PORTVERSION= 0.0.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math
MAINTAINER= stephen@FreeBSD.org
COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
-BROKEN= Does not build with octave-3.4.0
-
WRKSRC= ${WRKDIR}/${OCTAVE_PKGNAME}/src
.include <bsd.port.pre.mk>
diff --git a/math/octave-forge-es/files/patch-help.icc b/math/octave-forge-es/files/patch-help.icc
new file mode 100644
index 000000000000..9ea3ffc8bf99
--- /dev/null
+++ b/math/octave-forge-es/files/patch-help.icc
@@ -0,0 +1,38 @@
+--- help.icc-orig 2011-07-23 03:15:10.000000000 +0000
++++ help.icc 2011-07-23 03:18:00.000000000 +0000
+@@ -36,6 +36,8 @@
+ #include <octave/parse.h>
+ #include <octave/procstream.h>
+ #include <octave/help.h>
++#include <octave/syswait.h>
++#include <octave/lo-sysdep.h>
+
+ #include "oct-md5.h"
+
+@@ -68,7 +70,7 @@
+ {
+ os.flush ();
+
+- std::string tmp_file_name = file_ops::tempnam ("", "");
++ std::string tmp_file_name = octave_tempnam ("", "");
+
+ int cols = command_editor::terminal_cols ();
+
+@@ -124,7 +126,7 @@
+ warning ("%s:\n\n%s\n\n", HELP_STRING, msg.c_str ());
+ }
+
+- file_ops::unlink (tmp_file_name);
++ octave_unlink (tmp_file_name);
+ }
+ else
+ os << msg;
+@@ -139,7 +141,7 @@
+ std::string h;
+
+ std::string file = octave_env::make_absolute
+- (load_path::find_file (nm + LANG_EXT), octave_env::getcwd ());
++ (load_path::find_file (nm + LANG_EXT), octave_getcwd ());
+
+ if (! file.empty ())
+ {
diff --git a/math/octave-forge-pt_br/Makefile b/math/octave-forge-pt_br/Makefile
index ab7223bebed9..e374df1ac000 100644
--- a/math/octave-forge-pt_br/Makefile
+++ b/math/octave-forge-pt_br/Makefile
@@ -7,14 +7,12 @@
PORTNAME= octave-forge-pt_br
PORTVERSION= 1.0.9
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math
MAINTAINER= stephen@FreeBSD.org
COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
-BROKEN= Does not build with octave-3.4.0
-
WRKSRC= ${WRKDIR}/pt_BR/src
.include <bsd.port.pre.mk>
diff --git a/math/octave-forge-pt_br/files/patch-help.icc b/math/octave-forge-pt_br/files/patch-help.icc
new file mode 100644
index 000000000000..9ea3ffc8bf99
--- /dev/null
+++ b/math/octave-forge-pt_br/files/patch-help.icc
@@ -0,0 +1,38 @@
+--- help.icc-orig 2011-07-23 03:15:10.000000000 +0000
++++ help.icc 2011-07-23 03:18:00.000000000 +0000
+@@ -36,6 +36,8 @@
+ #include <octave/parse.h>
+ #include <octave/procstream.h>
+ #include <octave/help.h>
++#include <octave/syswait.h>
++#include <octave/lo-sysdep.h>
+
+ #include "oct-md5.h"
+
+@@ -68,7 +70,7 @@
+ {
+ os.flush ();
+
+- std::string tmp_file_name = file_ops::tempnam ("", "");
++ std::string tmp_file_name = octave_tempnam ("", "");
+
+ int cols = command_editor::terminal_cols ();
+
+@@ -124,7 +126,7 @@
+ warning ("%s:\n\n%s\n\n", HELP_STRING, msg.c_str ());
+ }
+
+- file_ops::unlink (tmp_file_name);
++ octave_unlink (tmp_file_name);
+ }
+ else
+ os << msg;
+@@ -139,7 +141,7 @@
+ std::string h;
+
+ std::string file = octave_env::make_absolute
+- (load_path::find_file (nm + LANG_EXT), octave_env::getcwd ());
++ (load_path::find_file (nm + LANG_EXT), octave_getcwd ());
+
+ if (! file.empty ())
+ {