aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-10-03 14:52:41 +0800
committerjbeich <jbeich@FreeBSD.org>2016-10-03 14:52:41 +0800
commitb7d2a42bd8aaf2880fe45dbc03a3fc7b8866de6c (patch)
tree955e721cdf8da610f71af3e368910efc177e5f14 /math
parent1a1b18a7f9c10557cd34ecd31aa4a2879cefd31f (diff)
downloadfreebsd-ports-gnome-b7d2a42bd8aaf2880fe45dbc03a3fc7b8866de6c.tar.gz
freebsd-ports-gnome-b7d2a42bd8aaf2880fe45dbc03a3fc7b8866de6c.tar.zst
freebsd-ports-gnome-b7d2a42bd8aaf2880fe45dbc03a3fc7b8866de6c.zip
math/openfst: unbreak on 9.x
symbol-table-ops.cc: In function 'bool fst::AddAuxiliarySymbols(const string&, int64, int64, fst::SymbolTable*)': symbol-table-ops.cc:131:43: error: 'to_string' is not a member of 'std' if (index != syms->AddSymbol(prefix + std::to_string(i), index)) { ^ Reported by: pkg-fallout Approved by: portmgr blanket
Diffstat (limited to 'math')
-rw-r--r--math/openfst/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/math/openfst/Makefile b/math/openfst/Makefile
index 1e14c1e7ef71..4869fd33156c 100644
--- a/math/openfst/Makefile
+++ b/math/openfst/Makefile
@@ -18,6 +18,7 @@ USES= compiler:c++11-lib libtool python:2
USE_LDCONFIG= ${LOCALBASE}/lib/fst
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--enable-bin --enable-compact-fsts --enable-compress --enable-const-fsts --enable-far --enable-linear-fsts --enable-lookahead-fsts --enable-mpdt --enable-ngram-fsts --enable-pdt --enable-python
+CFLAGS+= -D_GLIBCXX_USE_C99 # XXX ports/193528
LDFLAGS+= "-L${LOCALBASE}/lib"
MAKE_ENV+= PYTHON=${PYTHON_CMD}