aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-05-15 23:50:32 +0800
committeraaron <aaron@FreeBSD.org>2006-05-15 23:50:32 +0800
commitbc5528de5d325916e9bc4ac7afef5338b4670920 (patch)
tree2464af7255daf6533c427798e79e2eca6061422d /math
parentc5d65d057d65f9739b05a7b75017c2149a97f0c7 (diff)
downloadfreebsd-ports-gnome-bc5528de5d325916e9bc4ac7afef5338b4670920.tar.gz
freebsd-ports-gnome-bc5528de5d325916e9bc4ac7afef5338b4670920.tar.zst
freebsd-ports-gnome-bc5528de5d325916e9bc4ac7afef5338b4670920.zip
Adding port math/p5-Math-Symbolic-Custom-Simplification, User defined simplification routines
Approved by: tobez (implicit)
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-Symbolic-Custom-Simplification/Makefile31
-rw-r--r--math/p5-Math-Symbolic-Custom-Simplification/distinfo3
-rw-r--r--math/p5-Math-Symbolic-Custom-Simplification/pkg-descr20
-rw-r--r--math/p5-Math-Symbolic-Custom-Simplification/pkg-plist9
5 files changed, 64 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 32bfcad3a710..601da879215a 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -195,6 +195,7 @@
SUBDIR += p5-Math-Symbolic-Custom-ErrorPropagation
SUBDIR += p5-Math-Symbolic-Custom-LaTeXDumper
SUBDIR += p5-Math-Symbolic-Custom-Pattern
+ SUBDIR += p5-Math-Symbolic-Custom-Simplification
SUBDIR += p5-Math-SymbolicX-BigNum
SUBDIR += p5-Math-SymbolicX-Complex
SUBDIR += p5-Math-SymbolicX-Inline
diff --git a/math/p5-Math-Symbolic-Custom-Simplification/Makefile b/math/p5-Math-Symbolic-Custom-Simplification/Makefile
new file mode 100644
index 000000000000..5b7bfdeb5b01
--- /dev/null
+++ b/math/p5-Math-Symbolic-Custom-Simplification/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: Math-Symbolic-Custom-Simplification
+# Date created: 15 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Symbolic-Custom-Simplification
+PORTVERSION= 1.01
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= User defined simplification routines
+
+BUILD_DEPENDS= ${SITE_PERL}/Math/Symbolic.pm:${PORTSDIR}/math/p5-Math-Symbolic
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Math::Symbolic::Custom::Simplification.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/p5-Math-Symbolic-Custom-Simplification/distinfo b/math/p5-Math-Symbolic-Custom-Simplification/distinfo
new file mode 100644
index 000000000000..daf8da44f302
--- /dev/null
+++ b/math/p5-Math-Symbolic-Custom-Simplification/distinfo
@@ -0,0 +1,3 @@
+MD5 (Math-Symbolic-Custom-Simplification-1.01.tar.gz) = dd516df0b2c870773aedcfef80a03b8b
+SHA256 (Math-Symbolic-Custom-Simplification-1.01.tar.gz) = cd99ef0a03596f8b76fa10bbdb5bed53763a3cd2ae040b897001bc7688e856cf
+SIZE (Math-Symbolic-Custom-Simplification-1.01.tar.gz) = 3767
diff --git a/math/p5-Math-Symbolic-Custom-Simplification/pkg-descr b/math/p5-Math-Symbolic-Custom-Simplification/pkg-descr
new file mode 100644
index 000000000000..fad27c9adbf7
--- /dev/null
+++ b/math/p5-Math-Symbolic-Custom-Simplification/pkg-descr
@@ -0,0 +1,20 @@
+This module is an extension to the Math::Symbolic module. A basic
+familiarity with that module is required.
+
+Math::Symbolic offers some builtin simplification routines. These,
+however, are not capable of complex simplifications. This extension offers
+facilities to override the default simplification routines through means
+of subclassing this module. A subclass of this module is required to
+define a simplify object method that implements a simplification of
+Math::Symbolic trees.
+
+There are two class methods to inherit: register and unregister. Calling
+the register method on your subclass registers your class as providing the
+simplify method that is invoked whenever simplify() is called on a
+Math::Symbolic::Operator object.
+
+Calling unregister on your subclass restores whichever simplification
+routines where in place before.
+
+WWW: http://search.cpan.org/dist/Math-Symbolic-Custom-Simplification
+Author: Steffen Mueller <symbolic-module@steffen-mueller.net>
diff --git a/math/p5-Math-Symbolic-Custom-Simplification/pkg-plist b/math/p5-Math-Symbolic-Custom-Simplification/pkg-plist
new file mode 100644
index 000000000000..fbb8312053f1
--- /dev/null
+++ b/math/p5-Math-Symbolic-Custom-Simplification/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Math/Symbolic/Custom/Simplification.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Symbolic/Custom/Simplification/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Symbolic/Custom/Simplification
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Symbolic/Custom
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Symbolic
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
+@dirrmtry %%SITE_PERL%%/Math/Symbolic/Custom
+@dirrmtry %%SITE_PERL%%/Math/Symbolic
+@dirrmtry %%SITE_PERL%%/Math