aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2017-12-20 23:16:30 +0800
committerbapt <bapt@FreeBSD.org>2017-12-20 23:16:30 +0800
commitc2dd1c155bc0b576e5e4d4c82df4ddf404b0d7ff (patch)
treeb82ef35086a89c7c75936ac0e648b48dd3269403 /math
parenta65a213315ab1705215a10c4fb7972b219f35cb2 (diff)
downloadfreebsd-ports-gnome-c2dd1c155bc0b576e5e4d4c82df4ddf404b0d7ff.tar.gz
freebsd-ports-gnome-c2dd1c155bc0b576e5e4d4c82df4ddf404b0d7ff.tar.zst
freebsd-ports-gnome-c2dd1c155bc0b576e5e4d4c82df4ddf404b0d7ff.zip
Use swig 3.0
Diffstat (limited to 'math')
-rw-r--r--math/plplot/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/math/plplot/Makefile b/math/plplot/Makefile
index 75de36b02b1c..8e67f4bbd27d 100644
--- a/math/plplot/Makefile
+++ b/math/plplot/Makefile
@@ -59,8 +59,9 @@ LUA_CMAKE_BOOL= ENABLE_lua
LUA_CMAKE_ON= -DLUA_EXECUTABLE:FILEPATH="${LUA_CMD}"
PYTHON_USES= python:2.7
-PYTHON_BUILD_DEPENDS= swig:devel/swig13 \
+PYTHON_BUILD_DEPENDS= swig3.0:devel/swig30 \
${PYNUMPY}
+PYTHON_BINARY_ALIAS= swig=swig3.0
PYTHON_RUN_DEPENDS= ${PYNUMPY}
PYTHON_CMAKE_BOOL= ENABLE_python
PYTHON_CONFIGURE_ENV= PYTHON_VERSION="${PYTHON_VERSION}"