aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorpfg <pfg@FreeBSD.org>2018-02-08 09:13:21 +0800
committerpfg <pfg@FreeBSD.org>2018-02-08 09:13:21 +0800
commitc887dd1e0e505a3586328cb1a9206c6f3efafb2f (patch)
treeee5a07f933ce5b4eaab7e253e64c60fa7760f2d0 /math
parent87f7f1fbbe9bc4287a3538e2a66ffd9605dabdfc (diff)
downloadfreebsd-ports-gnome-c887dd1e0e505a3586328cb1a9206c6f3efafb2f.tar.gz
freebsd-ports-gnome-c887dd1e0e505a3586328cb1a9206c6f3efafb2f.tar.zst
freebsd-ports-gnome-c887dd1e0e505a3586328cb1a9206c6f3efafb2f.zip
math/coinmp: Add an option for Fortran.
It can be convenient for performance to enable blas/lapack, which necessarilly involves using the fortran interface. Leave it OFF by default since it can interfere with some important consumers like Apache OpenOffice. Use the standard TEST_TARGET while here. No need to bump the portversion as this doesn't affect the package. PR: 219261 Approved by: cpm
Diffstat (limited to 'math')
-rw-r--r--math/coinmp/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/math/coinmp/Makefile b/math/coinmp/Makefile
index 4764cdfce7b1..9a3112468c4f 100644
--- a/math/coinmp/Makefile
+++ b/math/coinmp/Makefile
@@ -22,14 +22,19 @@ USES= libtool pathfix pkgconfig tar:tgz
USE_LDCONFIG= yes
CXXFLAGS+= -ffast-math
-OPTIONS_DEFINE= DEBUG DOCS GLPK
+OPTIONS_DEFINE= DEBUG DOCS FORTRAN GLPK
+FORTRAN_DESCR= Use BLAS/LAPACK with the fortran interface
GLPK_DESC= GNU Linear Programming Kit support
PORTDOCS= *
DEBUG_CXXFLAGS= -fomit-frame-pointer
+FORTRAN_USES= fortran blaslapack
+FORTRAN_CONFIGURE_ON= --with-lapack-lib="${LAPACKLIB} -L${LOCALBASE}/lib" \
+ --with-blas-lib="${BLASLIB} -L${LOCALBASE}/lib"
+
GLPK_LIB_DEPENDS= libglpk.so:math/glpk
GLPK_CONFIGURE_ON= --with-gmpl-incdir=${LOCALBASE}/include \
--with-gmpl-lib="-L${LOCALBASE}/lib -lglpk"
@@ -38,6 +43,9 @@ GLPK_CONFIGURE_OFF= --disable-glpk-libcheck
STRIP_FILES= libCoinUtils libOsi libOsiClp libOsiCommonTests libClp libClpSolver \
libCgl libCbc libCbcSolver libOsiCbc libCoinMP
+TEST_TARGET= unitTest
+TEST_WRKSRC= ${WRKSRC}/${PORTNAME}
+
post-patch::
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} \
-e 's|$$(DESTDIR)$$(addlibsdir)|$$(addlibsdir)|g' \
@@ -53,8 +61,4 @@ post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/${filename}.so.*
.endfor
-check regression-test test: build
- ${SETENV} ${MAKE_ENV} ${MAKE} ${_MAKE_JOBS} \
- ${MAKE_ARGS} test -C ${WRKSRC}
-
.include <bsd.port.mk>
>+52 * Remove USE_REINPLACE from all categories starting with Nedwin2006-05-121-1/+0 * Remove the FreeBSD KEYWORD from all rc.d scripts where it appears.dougb2006-02-211-1/+0 * SHA256ifyedwin2006-01-231-0/+1 * - Respect PREFIXsem2005-10-212-2/+2 * - Update to 0.5.11pav2005-05-079-753/+14 * - Update to 0.5.10pav2005-04-109-8/+746 * - Mark BROKEN until new version compatible with latest libosip2 is releasedpav2005-04-081-0/+2 * - Chase libosip shlib bumppav2005-04-051-1/+2 * - Fixing gnugetopt dependency for FreeBSD 5.x [1]leeym2004-11-125-54/+18