aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2009-01-08 09:21:47 +0800
committergerald <gerald@FreeBSD.org>2009-01-08 09:21:47 +0800
commitdc3d53063103b2f2f9a6e2456048ea68c571922d (patch)
tree0e037327dc3f5218dc01387d6470af13d89e6de0 /math
parent25bac9ac2880080a198b0a960855da717ff9c0e0 (diff)
downloadfreebsd-ports-gnome-dc3d53063103b2f2f9a6e2456048ea68c571922d.tar.gz
freebsd-ports-gnome-dc3d53063103b2f2f9a6e2456048ea68c571922d.tar.zst
freebsd-ports-gnome-dc3d53063103b2f2f9a6e2456048ea68c571922d.zip
Remove run-time dependency on lang/gcc42 which is now transparently
handled by USE_FORTRAN. Tweak various aspects of configuration. Submitted by: Li-Lun "Leland" Wang <llwang@infor.org> (maintainer)
Diffstat (limited to 'math')
-rw-r--r--math/py-numpy/Makefile11
-rw-r--r--math/py-numpy/files/patch-numpy-distutils-fcompiler-gnu.py6
2 files changed, 9 insertions, 8 deletions
diff --git a/math/py-numpy/Makefile b/math/py-numpy/Makefile
index b685471c53a9..3e5eba7dfda4 100644
--- a/math/py-numpy/Makefile
+++ b/math/py-numpy/Makefile
@@ -21,8 +21,7 @@ EXTRACT_ONLY= numpy-${PORTVERSION:S/r/rc/}${EXTRACT_SUFX}
MAINTAINER= llwang@infor.org
COMMENT= The New Numeric Extension to Python
-RUN_DEPENDS= gcc42:${PORTSDIR}/lang/gcc42 \
- nosetests:${PORTSDIR}/devel/py-nose
+RUN_DEPENDS= nosetests:${PORTSDIR}/devel/py-nose
OPTIONS= ATLAS "Use optimized blas library" Off
@@ -49,16 +48,18 @@ LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack \
post-extract:
@${CP} ${DISTDIR}/numpy.pdf ${WRKDIR}
-GCCLIBDIR= `${FC} -print-file-name=libgfortran.so|${SED} -e s/libgfortran.so//`
post-patch:
-.ifdef WITH_ATLAS
+ @${REINPLACE_CMD} -e "s+%%FC%%+${FC}+" ${WRKSRC}/numpy/distutils/fcompiler/gnu.py
@${CP} ${FILESDIR}/site.cfg ${WRKSRC}/site.cfg
+
+GCCLIBDIR= `${FC} -print-file-name=libgfortran.so|${SED} -e s/libgfortran.so//`
+pre-configure:
+.ifdef WITH_ATLAS
@${REINPLACE_CMD} -e "s+%%GCCLIBDIR%%+${GCCLIBDIR}+" \
-e "s+%%LOCALBASE%%+${LOCALBASE}+" \
-e "s+%%ATLASLIBS%%+alapack_r, f77blas_r, cblas_r, atlas_r+" \
${WRKSRC}/site.cfg
.else
- @${CP} ${FILESDIR}/site.cfg ${WRKSRC}/site.cfg
@${REINPLACE_CMD} -e "s+%%GCCLIBDIR%%+${GCCLIBDIR}+" \
-e "s+%%LOCALBASE%%+${LOCALBASE}+" \
-e "s+%%ATLASLIBS%%+lapack, blas+" \
diff --git a/math/py-numpy/files/patch-numpy-distutils-fcompiler-gnu.py b/math/py-numpy/files/patch-numpy-distutils-fcompiler-gnu.py
index 1eb1fcc823c1..35862e5dc671 100644
--- a/math/py-numpy/files/patch-numpy-distutils-fcompiler-gnu.py
+++ b/math/py-numpy/files/patch-numpy-distutils-fcompiler-gnu.py
@@ -5,7 +5,7 @@
# GNU Fortran (GCC) 3.4.2 (mingw-special)
- possible_executables = ['g77', 'f77']
-+ possible_executables = ['gfortran', 'gfortran42', 'g77', 'f77']
++ possible_executables = ['%%FC%%', 'g77', 'f77']
executables = {
'version_cmd' : [None, "--version"],
'compiler_f77' : [None, "-g", "-Wall", "-fno-second-underscore"],
@@ -14,7 +14,7 @@
executables[key].append('-mno-cygwin')
- g2c = 'g2c'
-+ g2c = 'gfortran'
++ g2c = '%%FC%%'
suggested_f90_compiler = 'gnu95'
@@ -23,7 +23,7 @@
# GNU Fortran (GCC) 4.3.0 20070316 (experimental)
- possible_executables = ['gfortran', 'f95']
-+ possible_executables = ['gfortran', 'gfortran42', 'f95']
++ possible_executables = ['%%FC%%', 'gfortran', 'f95']
executables = {
'version_cmd' : ["<F90>", "--version"],
'compiler_f77' : [None, "-Wall", "-ffixed-form",