aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-05-17 13:41:43 +0800
committersobomax <sobomax@FreeBSD.org>2002-05-17 13:41:43 +0800
commitee9c295d73efaa30ebd58d84f86c7e843995e507 (patch)
tree77095935d629b4a02fd9031fd4862e882b338a78 /math
parentb2c23e7d35a0f2fc1eaa5dcd57df86b9f9ebfb0a (diff)
downloadfreebsd-ports-gnome-ee9c295d73efaa30ebd58d84f86c7e843995e507.tar.gz
freebsd-ports-gnome-ee9c295d73efaa30ebd58d84f86c7e843995e507.tar.zst
freebsd-ports-gnome-ee9c295d73efaa30ebd58d84f86c7e843995e507.zip
Update to 0.4.
Diffstat (limited to 'math')
-rw-r--r--math/qscanplot/Makefile12
-rw-r--r--math/qscanplot/distinfo2
-rw-r--r--math/qscanplot/files/patch-configure35
-rw-r--r--math/qscanplot/files/patch-qscanplot::Makefile.in32
-rw-r--r--math/qscanplot/files/patch-qscanplot::plugins::make-all-plugins.sh12
-rw-r--r--math/qscanplot/files/patch-qscanplot::plugins::make-plugin.sh22
-rw-r--r--math/qscanplot/files/patch-qscanplot::templates::sample.qscanplotrc14
-rw-r--r--math/qscanplot/pkg-plist43
8 files changed, 98 insertions, 74 deletions
diff --git a/math/qscanplot/Makefile b/math/qscanplot/Makefile
index 23567562961a..a5128f9293ea 100644
--- a/math/qscanplot/Makefile
+++ b/math/qscanplot/Makefile
@@ -6,17 +6,25 @@
#
PORTNAME= qscanplot
-PORTVERSION= 0.3
+PORTVERSION= 0.4
CATEGORIES= math
MASTER_SITES= http://www.gae.ucm.es/~gonzalez/qscanplot/
MAINTAINER= sobomax@FreeBSD.org
+BUILD_DEPENDS= tmake:${PORTSDIR}/devel/tmake
+
USE_X_PREFIX= yes
USE_QT_VER= 2
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= LDFLAGS="-lm ${PTHREAD_LIBS}" \
- QTDIR=${X11BASE}
+ QTDIR=${X11BASE} \
+ LIBQT=-lqt2
+MAKE_ENV= QTDIR=${X11BASE}
+
+post-patch:
+ @${PERL} -pi -e 's|%%PREFIX%%|${PREFIX}|g' \
+ ${WRKSRC}/qscanplot/templates/sample.qscanplotrc
.include <bsd.port.mk>
diff --git a/math/qscanplot/distinfo b/math/qscanplot/distinfo
index 9879cdb5d430..50ef666c8c84 100644
--- a/math/qscanplot/distinfo
+++ b/math/qscanplot/distinfo
@@ -1 +1 @@
-MD5 (qscanplot-0.3.tar.gz) = 8416e924e55286a0fe8bdf97d98ca12d
+MD5 (qscanplot-0.4.tar.gz) = 48ec5f032e20f524eae9f99f5fdedc9d
diff --git a/math/qscanplot/files/patch-configure b/math/qscanplot/files/patch-configure
index 79c87b71ec81..7105dcf6d1a1 100644
--- a/math/qscanplot/files/patch-configure
+++ b/math/qscanplot/files/patch-configure
@@ -1,9 +1,24 @@
$FreeBSD$
---- configure 2002/01/10 16:20:07 1.1
-+++ configure 2002/01/10 16:20:10
-@@ -1217,7 +1217,7 @@
+--- configure.orig Sun Apr 21 13:34:06 2002
++++ configure Tue Apr 23 22:08:24 2002
+@@ -1117,10 +1117,10 @@
+
+ # The aliases save the names the user supplied, while $host etc.
+ # will get canonicalized.
+-test -n "$target_alias" &&
+- test "$program_prefix$program_suffix$program_transform_name" = \
+- NONENONEs,x,x, &&
+- program_prefix=${target_alias}-
++#test -n "$target_alias" &&
++# test "$program_prefix$program_suffix$program_transform_name" = \
++# NONENONEs,x,x, &&
++# program_prefix=${target_alias}-
+ test -z "$target_alias" &&
+ target_alias=$ac_cv_target
+
+@@ -2045,7 +2045,7 @@
fi
else
if test "$GCC" = yes; then
@@ -12,7 +27,7 @@ $FreeBSD$
else
CFLAGS=
fi
-@@ -1233,7 +1233,7 @@
+@@ -2170,7 +2170,7 @@
;;
esac
else
@@ -21,7 +36,7 @@ $FreeBSD$
fi
fi
-@@ -1394,7 +1394,7 @@
+@@ -2392,7 +2392,7 @@
fi
else
if test "$GXX" = yes; then
@@ -30,7 +45,7 @@ $FreeBSD$
else
CXXFLAGS=
fi
-@@ -1506,7 +1506,7 @@
+@@ -2589,7 +2589,7 @@
CXXFLAGS="-Wold-style-cast -Wredundant-decls -Wconversion $CXXFLAGS"
fi
else
@@ -39,3 +54,11 @@ $FreeBSD$
fi
fi
+@@ -8669,6 +8669,7 @@
+ else
+ LIB_QT="$kde_int_qt "'$(LIBPNG) $(LIBJPEG)'
+ fi
++LIB_QT="$LIBQT $LIB_QT"
+
+ DO_NOT_COMPILE="$DO_NOT_COMPILE CVS debian bsd-port admin"
+
diff --git a/math/qscanplot/files/patch-qscanplot::Makefile.in b/math/qscanplot/files/patch-qscanplot::Makefile.in
index c2b8b2aa078e..2e25a57ae1d2 100644
--- a/math/qscanplot/files/patch-qscanplot::Makefile.in
+++ b/math/qscanplot/files/patch-qscanplot::Makefile.in
@@ -1,26 +1,14 @@
$FreeBSD$
---- qscanplot/Makefile.in 2002/01/10 16:00:24 1.1
-+++ qscanplot/Makefile.in 2002/01/10 16:01:15
-@@ -615,16 +615,16 @@
- install-data-local:
- #>- $(mkinstalldirs) /opt/kde/share/icons/
- #>+ 1
-- $(mkinstalldirs) $(DESTDIR)/opt/kde/share/icons/
-+# $(mkinstalldirs) $(DESTDIR)/opt/kde/share/icons/
- #>- $(INSTALL_DATA) $(srcdir)/mini-qscanplot.xpm /opt/kde/share/icons/mini-qscanplot.xpm
- #>+ 1
-- $(INSTALL_DATA) $(srcdir)/mini-qscanplot.xpm $(DESTDIR)/opt/kde/share/icons/mini-qscanplot.xpm
-+# $(INSTALL_DATA) $(srcdir)/mini-qscanplot.xpm $(DESTDIR)/opt/kde/share/icons/mini-qscanplot.xpm
- #>- $(mkinstalldirs) /opt/kde/share/icons/
- #>+ 1
-- $(mkinstalldirs) $(DESTDIR)/opt/kde/share/icons/
-+# $(mkinstalldirs) $(DESTDIR)/opt/kde/share/icons/
- #>- $(INSTALL_DATA) $(srcdir)/qscanplot.xpm /opt/kde/share/icons/qscanplot.xpm
- #>+ 1
-- $(INSTALL_DATA) $(srcdir)/qscanplot.xpm $(DESTDIR)/opt/kde/share/icons/qscanplot.xpm
-+# $(INSTALL_DATA) $(srcdir)/qscanplot.xpm $(DESTDIR)/opt/kde/share/icons/qscanplot.xpm
+--- qscanplot/Makefile.in 2002/04/23 10:07:59 1.1
++++ qscanplot/Makefile.in 2002/04/23 10:08:15
+@@ -226,7 +226,7 @@
+ INTERFACES = dlgNewPlugin.ui dlgPreferences.ui dlgNewElement.ui dlgModels.ui dlgInterpolator.ui dlgGrid.ui dlgExportSetup.ui dlgExportPreview.ui dlgEditElement.ui dlgAxisPoint.ui dlgAbout.ui
+ TRANSLATIONS =
+ KDE_OPTIONS = qtonly
+-qscanplot_LDADD = -ldl -lm $(LIB_QT) $(LIBSOCKET)
++qscanplot_LDADD = -lm $(LIB_QT) $(LIBSOCKET)
+
+ SUBDIRS = docs plugins templates
- uninstall-local:
- #>- -rm -f /opt/kde/share/icons/mini-qscanplot.xpm
diff --git a/math/qscanplot/files/patch-qscanplot::plugins::make-all-plugins.sh b/math/qscanplot/files/patch-qscanplot::plugins::make-all-plugins.sh
new file mode 100644
index 000000000000..b84311483c68
--- /dev/null
+++ b/math/qscanplot/files/patch-qscanplot::plugins::make-all-plugins.sh
@@ -0,0 +1,12 @@
+
+$FreeBSD$
+
+--- qscanplot/plugins/make-all-plugins.sh 2002/04/23 09:48:36 1.1
++++ qscanplot/plugins/make-all-plugins.sh 2002/04/23 09:51:37
+@@ -4,5 +4,5 @@
+
+ for i in `cat FUNCTIONS`; do
+ echo ; echo \# Generating plugin for function \"$i\":
+- . make-plugin.sh $i
++ ./make-plugin.sh $i
+ done
diff --git a/math/qscanplot/files/patch-qscanplot::plugins::make-plugin.sh b/math/qscanplot/files/patch-qscanplot::plugins::make-plugin.sh
new file mode 100644
index 000000000000..69c3ba0cafbf
--- /dev/null
+++ b/math/qscanplot/files/patch-qscanplot::plugins::make-plugin.sh
@@ -0,0 +1,22 @@
+
+$FreeBSD$
+
+--- qscanplot/plugins/make-plugin.sh 2002/04/23 09:48:56 1.1
++++ qscanplot/plugins/make-plugin.sh 2002/04/23 09:53:40
+@@ -1,6 +1,6 @@
+ #! /bin/sh
+
+-TMAKEPATH=/usr/lib/tmake/linux-g++
++TMAKEPATH=${LOCALBASE}/share/tmake/freebsd-g++
+
+ export TMAKEPATH
+
+@@ -38,7 +38,7 @@
+
+ echo Building plugin $plg
+
+-make -f $plgmak
++gmake -f $plgmak
+ rm -f $plgmak $plgpro $plg.o
+
+ echo done.
diff --git a/math/qscanplot/files/patch-qscanplot::templates::sample.qscanplotrc b/math/qscanplot/files/patch-qscanplot::templates::sample.qscanplotrc
new file mode 100644
index 000000000000..08b3ac9b5693
--- /dev/null
+++ b/math/qscanplot/files/patch-qscanplot::templates::sample.qscanplotrc
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- qscanplot/templates/sample.qscanplotrc 2002/04/23 20:34:58 1.1
++++ qscanplot/templates/sample.qscanplotrc 2002/04/23 20:35:32
+@@ -7,7 +7,7 @@
+ <option key="Font_Weight" value="75" />
+ <option key="GUI_Style" value="5" />
+ <option key="Initial_Zoom" value="100" />
+- <option key="Plugins_Directory" value="/usr/lib/qscanplot/plugins/" />
++ <option key="Plugins_Directory" value="%%PREFIX%%/lib/qscanplot/plugins/" />
+ <option key="Splash" value="true" />
+ <option key="Window_Height" value="738" />
+ <option key="Window_Width" value="848" />
diff --git a/math/qscanplot/pkg-plist b/math/qscanplot/pkg-plist
index 901bc9a2039b..775626dfef77 100644
--- a/math/qscanplot/pkg-plist
+++ b/math/qscanplot/pkg-plist
@@ -1,52 +1,9 @@
bin/qscanplot
-share/doc/qscanplot/abund_qsp.xml
-share/doc/qscanplot/axispoint.jpg
-share/doc/qscanplot/btnapointer.jpg
-share/doc/qscanplot/btncpointer.jpg
-share/doc/qscanplot/btnexport.jpg
-share/doc/qscanplot/btnexportpreview.jpg
-share/doc/qscanplot/btnexportsetup.jpg
-share/doc/qscanplot/btnfilenew.jpg
-share/doc/qscanplot/btnfileopen.jpg
-share/doc/qscanplot/btnimport.jpg
-share/doc/qscanplot/btnnewaxes.jpg
-share/doc/qscanplot/btnnewcurve.jpg
-share/doc/qscanplot/btnnewgrid.jpg
-share/doc/qscanplot/btnnpointer.jpg
-share/doc/qscanplot/btnrecycle.jpg
-share/doc/qscanplot/btnsave.jpg
-share/doc/qscanplot/btnselectaxes.jpg
-share/doc/qscanplot/btnselectcurve.jpg
-share/doc/qscanplot/btnwhatsthis.jpg
-share/doc/qscanplot/cr_abund.jpg
-share/doc/qscanplot/editaxes.jpg
-share/doc/qscanplot/editcurves.jpg
-share/doc/qscanplot/editgrids.jpg
-share/doc/qscanplot/elementsmenu.jpg
-share/doc/qscanplot/export.jpg
-share/doc/qscanplot/exportpreview.jpg
-share/doc/qscanplot/exportsetup.jpg
-share/doc/qscanplot/filemenu.jpg
-share/doc/qscanplot/import.jpg
-share/doc/qscanplot/imported100.jpg
share/doc/qscanplot/index-1.html
share/doc/qscanplot/index-2.html
share/doc/qscanplot/index-3.html
share/doc/qscanplot/index-4.html
share/doc/qscanplot/index-5.html
share/doc/qscanplot/index-6.html
-share/doc/qscanplot/index-7.html
share/doc/qscanplot/index.html
-share/doc/qscanplot/interpolators.jpg
-share/doc/qscanplot/main_window.jpg
-share/doc/qscanplot/newaxes.jpg
-share/doc/qscanplot/newcurve.jpg
-share/doc/qscanplot/newgrid.jpg
-share/doc/qscanplot/optionsmenu.jpg
-share/doc/qscanplot/qscanplot_image.png
-share/doc/qscanplot/qscanplot_splash.png
-share/doc/qscanplot/ready.jpg
-share/doc/qscanplot/sample.tar.gz
-share/doc/qscanplot/special.jpg
-share/doc/qscanplot/viewmenu.jpg
@dirrm share/doc/qscanplot