aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-02-25 13:33:38 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-02-25 13:33:38 +0800
commitef4b146aeeb94d1794d4087e7d63e394863d4eca (patch)
treecb4485cd8a956ac2253553a5bc7e4347a8e1825c /math
parentf708269aa0e86859380e4e80da0257c73d3a97ab (diff)
downloadfreebsd-ports-gnome-ef4b146aeeb94d1794d4087e7d63e394863d4eca.tar.gz
freebsd-ports-gnome-ef4b146aeeb94d1794d4087e7d63e394863d4eca.tar.zst
freebsd-ports-gnome-ef4b146aeeb94d1794d4087e7d63e394863d4eca.zip
Update to 0.5.0
- Fix LICENSE - Add LICENSE_FILE - Allow concurrent installation (USE_PYTHON=concurrent) - Move PORTDOCS and PORTEXAMPLES to PLIST - Add PyPI as primary WWW - Take maintainership Changes: https://github.com/pydata/patsy/blob/master/doc/changes.rst
Diffstat (limited to 'math')
-rw-r--r--math/py-patsy/Makefile36
-rw-r--r--math/py-patsy/distinfo5
-rw-r--r--math/py-patsy/files/patch-setup.py10
-rw-r--r--math/py-patsy/pkg-descr1
-rw-r--r--math/py-patsy/pkg-plist17
5 files changed, 31 insertions, 38 deletions
diff --git a/math/py-patsy/Makefile b/math/py-patsy/Makefile
index f0182bfa54f1..76f5ec5b438f 100644
--- a/math/py-patsy/Makefile
+++ b/math/py-patsy/Makefile
@@ -2,49 +2,33 @@
# $FreeBSD$
PORTNAME= patsy
-PORTVERSION= 0.4.1
+PORTVERSION= 0.5.0
CATEGORIES= math python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Python package for statistical models and design matrices
-LICENSE= BSD3CLAUSE PSFL
+LICENSE= BSD2CLAUSE PSFL
LICENSE_COMB= multi
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= ${PYNUMPY} \
- ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${FLAVOR}
-USES= python zip
-USE_PYTHON= distutils autoplist
+USES= python
+USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
-PORTDOCS= API-reference.rst \
- R-comparison.rst \
- builtins-reference.rst \
- categorical-coding.rst \
- changes.rst \
- expert-model-specification.rst \
- formulas.rst \
- index.rst \
- library-developers.rst \
- overview.rst \
- py2-versus-py3.rst \
- quickstart.rst \
- stateful-transforms.rst \
-
-PORTEXAMPLES= add_predictors.py \
- example_lm.py \
- example_treatment.py
-
OPTIONS_DEFINE= DOCS EXAMPLES
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/doc/|} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.rst ${STAGEDIR}${DOCSDIR}
+
post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${PORTEXAMPLES:S|^|${WRKSRC}/doc/_examples/|} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/_examples/*.py ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/math/py-patsy/distinfo b/math/py-patsy/distinfo
index 5cb1b24b87e1..6fdfb40923a8 100644
--- a/math/py-patsy/distinfo
+++ b/math/py-patsy/distinfo
@@ -1,2 +1,3 @@
-SHA256 (patsy-0.4.1.zip) = dc1cc280045b0e6e50c04706fd1e26d2a00ea400aa112f88e8142f88b0b7d3d4
-SIZE (patsy-0.4.1.zip) = 425390
+TIMESTAMP = 1519513259
+SHA256 (patsy-0.5.0.tar.gz) = e05f38d5c38c8d216f0cc2b765b1069b433c92d628b954fb2fee68d13e42883b
+SIZE (patsy-0.5.0.tar.gz) = 399109
diff --git a/math/py-patsy/files/patch-setup.py b/math/py-patsy/files/patch-setup.py
deleted file mode 100644
index 118d50223fb0..000000000000
--- a/math/py-patsy/files/patch-setup.py
+++ /dev/null
@@ -1,10 +0,0 @@
---- setup.py.orig 2015-12-08 02:16:42 UTC
-+++ setup.py
-@@ -21,7 +21,6 @@ setup(
- license="2-clause BSD",
- packages=["patsy"],
- url="https://github.com/pydata/patsy",
-- install_requires=["six", "numpy"],
- classifiers =
- [ "Development Status :: 4 - Beta",
- "Intended Audience :: Developers",
diff --git a/math/py-patsy/pkg-descr b/math/py-patsy/pkg-descr
index a201aef1f15e..9bde2ede2d91 100644
--- a/math/py-patsy/pkg-descr
+++ b/math/py-patsy/pkg-descr
@@ -2,4 +2,5 @@ Patsy is a Python library for describing statistical models (especially linear
models, or models that have a linear component) and building design matrices.
Patsy brings the convenience of R "formulas" to Python.
+WWW: https://pypi.python.org/pypi/patsy
WWW: https://github.com/pydata/patsy
diff --git a/math/py-patsy/pkg-plist b/math/py-patsy/pkg-plist
new file mode 100644
index 000000000000..72321f15d4da
--- /dev/null
+++ b/math/py-patsy/pkg-plist
@@ -0,0 +1,17 @@
+%%PORTDOCS%%%%DOCSDIR%%/API-reference.rst
+%%PORTDOCS%%%%DOCSDIR%%/R-comparison.rst
+%%PORTDOCS%%%%DOCSDIR%%/builtins-reference.rst
+%%PORTDOCS%%%%DOCSDIR%%/categorical-coding.rst
+%%PORTDOCS%%%%DOCSDIR%%/changes.rst
+%%PORTDOCS%%%%DOCSDIR%%/expert-model-specification.rst
+%%PORTDOCS%%%%DOCSDIR%%/formulas.rst
+%%PORTDOCS%%%%DOCSDIR%%/index.rst
+%%PORTDOCS%%%%DOCSDIR%%/library-developers.rst
+%%PORTDOCS%%%%DOCSDIR%%/overview.rst
+%%PORTDOCS%%%%DOCSDIR%%/py2-versus-py3.rst
+%%PORTDOCS%%%%DOCSDIR%%/quickstart.rst
+%%PORTDOCS%%%%DOCSDIR%%/spline-regression.rst
+%%PORTDOCS%%%%DOCSDIR%%/stateful-transforms.rst
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/add_predictors.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_lm.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_treatment.py