aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorsanpei <sanpei@FreeBSD.org>2014-06-20 20:51:37 +0800
committersanpei <sanpei@FreeBSD.org>2014-06-20 20:51:37 +0800
commitf2789018d7b421624e6511b73465472b858b17bc (patch)
treec5fdb26c10e9476a3ce82921c113f91bc16d8108 /math
parent7636971d1713d203f301d215eabf001c58980dda (diff)
downloadfreebsd-ports-gnome-f2789018d7b421624e6511b73465472b858b17bc.tar.gz
freebsd-ports-gnome-f2789018d7b421624e6511b73465472b858b17bc.tar.zst
freebsd-ports-gnome-f2789018d7b421624e6511b73465472b858b17bc.zip
support stage
Diffstat (limited to 'math')
-rw-r--r--math/ngraph/Makefile1
-rw-r--r--math/ngraph/files/patch-aa10
-rw-r--r--math/ngraph/files/patch-install.sh30
-rw-r--r--math/ngraph/pkg-plist12
4 files changed, 41 insertions, 12 deletions
diff --git a/math/ngraph/Makefile b/math/ngraph/Makefile
index d0e4a68b02a6..b1f2b72983c2 100644
--- a/math/ngraph/Makefile
+++ b/math/ngraph/Makefile
@@ -14,5 +14,4 @@ COMMENT= XY plotting tool for students, scientists, and engineers
USES= gmake motif
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/math/ngraph/files/patch-aa b/math/ngraph/files/patch-aa
index 7d938fce3402..62734d0a1bf5 100644
--- a/math/ngraph/files/patch-aa
+++ b/math/ngraph/files/patch-aa
@@ -1,15 +1,15 @@
---- Makefile.orig 2008-08-01 22:28:06.000000000 +0900
-+++ Makefile 2009-02-06 21:39:03.000000000 +0900
+--- Makefile.orig 2009-10-15 20:17:47.000000000 +0900
++++ Makefile 2014-06-20 21:48:30.928895628 +0900
@@ -2,26 +2,26 @@
MAINVERSION = '"6.03"'
- GUIVERSION = '".48"'
+ GUIVERSION = '".51"'
ALIGNSIZE = 8
-LIBDIR = '"/usr/local/lib/Ngraph"'
-INSTALLDIR = /usr/local/lib/Ngraph
-BINDIR = /usr/local/bin
+LIBDIR = '"${PREFIX}/lib/Ngraph"'
-+INSTALLDIR = ${PREFIX}/lib/Ngraph
-+BINDIR = ${PREFIX}/bin
++INSTALLDIR = ${DESTDIR}${PREFIX}/lib/Ngraph
++BINDIR = ${DESTDIR}${PREFIX}/bin
#
#
###############################################################################
diff --git a/math/ngraph/files/patch-install.sh b/math/ngraph/files/patch-install.sh
new file mode 100644
index 000000000000..c864d19c5bb8
--- /dev/null
+++ b/math/ngraph/files/patch-install.sh
@@ -0,0 +1,30 @@
+--- install.sh.orig 2009-10-15 20:17:47.000000000 +0900
++++ install.sh 2014-06-20 21:40:11.532930042 +0900
+@@ -2,6 +2,7 @@
+
+ INSTALLDIR=${INSTALLDIR:-/usr/local/lib/Ngraph}
+ BINDIR=${BINDIR:-/usr/local/bin}
++LIBDIR=${PREFIX}/lib/Ngraph
+
+ TEXTFILES="Ngraph.ini .Ngraph .Ngraph.ngp .fit.ngp INSTALL.jis gpl.txt gpl.ja.txt"
+ ADDINFILES="append.nsc math.nsc text-in.nsc \
+@@ -26,8 +27,8 @@
+ then
+ cp Ngraph.ini ./org
+ fi
+-sed -e "s?INSTALLDIR?${INSTALLDIR}?" ./org/ngraph.sh > ngraph.sh
+-sed -e "s?INSTALLDIR?${INSTALLDIR}?" ./org/Ngraph.ini > Ngraph.ini
++sed -e "s?INSTALLDIR?${LIBDIR}?" ./org/ngraph.sh > ngraph.sh
++sed -e "s?INSTALLDIR?${LIBDIR}?" ./org/Ngraph.ini > Ngraph.ini
+
+ echo "Making directories in ${INSTALLDIR}"
+ if [ ! -d ${INSTALLDIR} ]
+@@ -90,7 +91,7 @@
+ if [ ! -h ${BINDIR}/ngraph ]
+ then
+ echo "Making a symbolic link ${BINDIR}/ngraph"
+- ln -s ${INSTALLDIR}/ngraph.sh ${BINDIR}/ngraph
++ ln -s ${LIBDIR}/ngraph.sh ${BINDIR}/ngraph
+ fi
+
+ if [ -f ./org/ngraph.sh ]
diff --git a/math/ngraph/pkg-plist b/math/ngraph/pkg-plist
index d2f363ba839c..0a8fe7482b03 100644
--- a/math/ngraph/pkg-plist
+++ b/math/ngraph/pkg-plist
@@ -10,8 +10,6 @@ lib/Ngraph/Ngraph.xpm
lib/Ngraph/append.nsc
lib/Ngraph/calc.nsc
lib/Ngraph/calc.tcl
-lib/Ngraph/gpl.txt
-lib/Ngraph/gpl.ja.txt
lib/Ngraph/demo/demo.ngp
lib/Ngraph/demo/demo1.dat
lib/Ngraph/demo/demo1.ngp
@@ -32,6 +30,8 @@ lib/Ngraph/fft.nsc
lib/Ngraph/fft.tcl
lib/Ngraph/fitrslt.nsc
lib/Ngraph/fitrslt.tcl
+lib/Ngraph/gpl.txt
+lib/Ngraph/gpl.ja.txt
lib/Ngraph/gra2ps
lib/Ngraph/gra2ps.ini
lib/Ngraph/gra2wmf
@@ -44,7 +44,7 @@ lib/Ngraph/ngraph
lib/Ngraph/ngraph.sh
lib/Ngraph/terminal
lib/Ngraph/text-in.nsc
-@dirrm lib/Ngraph/demo
-@dirrm lib/Ngraph/doc
-@dirrm lib/Ngraph/ja
-@dirrm lib/Ngraph
+@dirrmtry lib/Ngraph/demo
+@dirrmtry lib/Ngraph/doc
+@dirrmtry lib/Ngraph/ja
+@dirrmtry lib/Ngraph