aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-12-12 21:01:40 +0800
committerbapt <bapt@FreeBSD.org>2013-12-12 21:01:40 +0800
commitf9d4be6cb76f701b71c67b907d31d6e209455b3a (patch)
tree4001d5f3f8ce7ed1c00ed7855c9522129d5a9fe7 /math
parent145bf2bd9f4df368ec9bf802b02f2914d2d378ad (diff)
downloadfreebsd-ports-gnome-f9d4be6cb76f701b71c67b907d31d6e209455b3a.tar.gz
freebsd-ports-gnome-f9d4be6cb76f701b71c67b907d31d6e209455b3a.tar.zst
freebsd-ports-gnome-f9d4be6cb76f701b71c67b907d31d6e209455b3a.zip
Convert LIB_DEPENDS for ports depending on boost
Diffstat (limited to 'math')
-rw-r--r--math/armadillo/Makefile4
-rw-r--r--math/carve/Makefile4
-rw-r--r--math/kig/Makefile2
-rw-r--r--math/py-graphtool/Makefile6
-rw-r--r--math/rocs/Makefile2
-rw-r--r--math/ufc/Makefile2
6 files changed, 10 insertions, 10 deletions
diff --git a/math/armadillo/Makefile b/math/armadillo/Makefile
index eb6532dabb9f..dcf9812d806d 100644
--- a/math/armadillo/Makefile
+++ b/math/armadillo/Makefile
@@ -11,8 +11,8 @@ COMMENT= C++ linear algebra library
LICENSE= MPL
-LIB_DEPENDS= lapack:${PORTSDIR}/math/lapack \
- boost_date_time:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= liblapack.so:${PORTSDIR}/math/lapack \
+ libboost_date_time.so:${PORTSDIR}/devel/boost-libs
USES= cmake
USE_LDCONFIG= yes
diff --git a/math/carve/Makefile b/math/carve/Makefile
index 4e12f7e0ae3d..f66cab1449b4 100644
--- a/math/carve/Makefile
+++ b/math/carve/Makefile
@@ -11,7 +11,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= gahr@FreeBSD.org
COMMENT= A fast, robust constructive solid geometry library
-LIB_DEPENDS= boost_filesystem:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= libboost_filesystem.so:${PORTSDIR}/devel/boost-libs
OPTIONS_DEFINE= GUI
@@ -28,7 +28,7 @@ NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGUI}
-LIB_DEPENDS+= glui:${PORTSDIR}/devel/glui
+LIB_DEPENDS+= libglui.so:${PORTSDIR}/devel/glui
PLIST_SUB+= GUI=""
CMAKE_ARGS+= -DCARVE_WITH_GUI:BOOL=true
.else
diff --git a/math/kig/Makefile b/math/kig/Makefile
index 4da954fbb8d9..98fc792ae34e 100644
--- a/math/kig/Makefile
+++ b/math/kig/Makefile
@@ -27,7 +27,7 @@ NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPYTHON}
-LIB_DEPENDS+= boost_python:${PORTSDIR}/devel/boost-python-libs
+LIB_DEPENDS+= libboost_python.so:${PORTSDIR}/devel/boost-python-libs
.endif
.include <bsd.port.mk>
diff --git a/math/py-graphtool/Makefile b/math/py-graphtool/Makefile
index ae26815c6826..975bb77453c3 100644
--- a/math/py-graphtool/Makefile
+++ b/math/py-graphtool/Makefile
@@ -14,9 +14,9 @@ COMMENT= Python module for complex network based on C++
BUILD_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}matplotlib>=0.90.1:${PORTSDIR}/math/py-matplotlib \
${PYTHON_PKGNAMEPREFIX}scipy>=0.8.0:${PORTSDIR}/science/py-scipy
-LIB_DEPENDS= boost_python:${PORTSDIR}/devel/boost-python-libs \
- boost_graph:${PORTSDIR}/devel/boost-libs \
- CGAL.10:${PORTSDIR}/math/cgal
+LIB_DEPENDS= libboost_python.so:${PORTSDIR}/devel/boost-python-libs \
+ libboost_graph.so:${PORTSDIR}/devel/boost-libs \
+ libCGAL.so:${PORTSDIR}/math/cgal
USE_BZIP2= yes
USE_GCC= yes
diff --git a/math/rocs/Makefile b/math/rocs/Makefile
index b840176aefb1..cec7dc267ad7 100644
--- a/math/rocs/Makefile
+++ b/math/rocs/Makefile
@@ -10,7 +10,7 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE Graph theory IDE
-LIB_DEPENDS= boost_thread:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs
CONFLICTS= kdeedu-4.[0-6].*
diff --git a/math/ufc/Makefile b/math/ufc/Makefile
index 58fafd04ca37..1fc1a38bb70b 100644
--- a/math/ufc/Makefile
+++ b/math/ufc/Makefile
@@ -10,7 +10,7 @@ MAINTAINER= jwbacon@tds.net
COMMENT= Unified framework for finite element assembly
BUILD_DEPENDS= swig2.0:${PORTSDIR}/devel/swig20
-LIB_DEPENDS= boost_math_c99:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= libboost_math_c99.so:${PORTSDIR}/devel/boost-libs
# LICENSE= public domain