aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-06-07 06:23:17 +0800
committerpawel <pawel@FreeBSD.org>2014-06-07 06:23:17 +0800
commit00877bf1533807ffe82ef55b2ea5f2b66fd56e58 (patch)
treeb1d25df2ec2b1afcda1d3b048595fc6bb6cf3506 /math
parent1e6d6a5c7ec4b87bb6f841195810683c57f96dbc (diff)
downloadfreebsd-ports-gnome-00877bf1533807ffe82ef55b2ea5f2b66fd56e58.tar.gz
freebsd-ports-gnome-00877bf1533807ffe82ef55b2ea5f2b66fd56e58.tar.zst
freebsd-ports-gnome-00877bf1533807ffe82ef55b2ea5f2b66fd56e58.zip
Add staging support, allow it as normal user
Diffstat (limited to 'math')
-rw-r--r--math/emacs-calc/Makefile1
-rw-r--r--math/emacs-calc/files/patch-Makefile8
2 files changed, 4 insertions, 5 deletions
diff --git a/math/emacs-calc/Makefile b/math/emacs-calc/Makefile
index 29f09f0921fd..be0a0b96a7bc 100644
--- a/math/emacs-calc/Makefile
+++ b/math/emacs-calc/Makefile
@@ -19,7 +19,6 @@ EMACS_PORT_NAME=emacs21
INFO= calc
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/Makefile
diff --git a/math/emacs-calc/files/patch-Makefile b/math/emacs-calc/files/patch-Makefile
index b53505e10b2c..4942735cd0c9 100644
--- a/math/emacs-calc/files/patch-Makefile
+++ b/math/emacs-calc/files/patch-Makefile
@@ -40,16 +40,16 @@
+ $(MAKE) info
+
+install: ${installfiles}
-+ install-info ${infodir}/calc.info ${infodir}/dir
++ install-info ${DESTDIR}${infodir}/calc.info ${DESTDIR}${infodir}/dir
+
+.for file in ${infofiles}
+${infodir}/${file}: ${file}
-+ install -o root -g wheel -m 0444 $? $@
++ ${BSD_INSTALL_DATA} $? ${DESTDIR}$@
+.endfor
+
+.for file in ${sitefiles}
+${calcsitedir}/${file}: ${file}
-+ @install -d -o root -g wheel -m 0755 ${@D}
-+ install -o root -g wheel -m 0444 $? $@
++ @install -d -m 0755 ${DESTDIR}${@D}
++ ${BSD_INSTALL_DATA} $? ${DESTDIR}$@
+.endfor