aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2018-12-17 02:32:07 +0800
committerlwhsu <lwhsu@FreeBSD.org>2018-12-17 02:32:07 +0800
commit04714e7e74b5a715e8339d5fe0090c7ed3465bc9 (patch)
tree95d3f93fdf60bd816b1a2daecb8bb438b98fd898 /math
parente83158ca9b36fdc3268678e7ea3f755656486354 (diff)
downloadfreebsd-ports-gnome-04714e7e74b5a715e8339d5fe0090c7ed3465bc9.tar.gz
freebsd-ports-gnome-04714e7e74b5a715e8339d5fe0090c7ed3465bc9.tar.zst
freebsd-ports-gnome-04714e7e74b5a715e8339d5fe0090c7ed3465bc9.zip
Add math/py-pyclipper, cython wrapper for the C++ translation of Clipper
library PR: 228027 Submitted by: Ting-Wei Lan <lantw44@gmail.com>
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/py-pyclipper/Makefile21
-rw-r--r--math/py-pyclipper/distinfo3
-rw-r--r--math/py-pyclipper/pkg-descr4
4 files changed, 29 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 7794fe10f499..ef2d4c5e7999 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -757,6 +757,7 @@
SUBDIR += py-pyFFTW
SUBDIR += py-pyasp
SUBDIR += py-pybloom
+ SUBDIR += py-pyclipper
SUBDIR += py-pycosat
SUBDIR += py-pygsl
SUBDIR += py-pygslodeiv2
diff --git a/math/py-pyclipper/Makefile b/math/py-pyclipper/Makefile
new file mode 100644
index 000000000000..6bccc5288ed2
--- /dev/null
+++ b/math/py-pyclipper/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= pyclipper
+PORTVERSION= 1.1.0
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= lantw44@gmail.com
+COMMENT= Cython wrapper for the C++ translation of Clipper library
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=1.11.1:devel/py-setuptools_scm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools_scm_git_archive>=1.0:devel/py-setuptools_scm_git_archive@${PY_FLAVOR}
+
+USES= python zip
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/math/py-pyclipper/distinfo b/math/py-pyclipper/distinfo
new file mode 100644
index 000000000000..02e512f6a483
--- /dev/null
+++ b/math/py-pyclipper/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1525598760
+SHA256 (pyclipper-1.1.0.zip) = 3f11e87f0b82bccc6de57eead2628ca419694352e8b843bcd228eec9c9357680
+SIZE (pyclipper-1.1.0.zip) = 133364
diff --git a/math/py-pyclipper/pkg-descr b/math/py-pyclipper/pkg-descr
new file mode 100644
index 000000000000..eed9eec38254
--- /dev/null
+++ b/math/py-pyclipper/pkg-descr
@@ -0,0 +1,4 @@
+Pyclipper is a Cython wrapper exposing public functions and classes of the C++
+translation of the Angus Johnson's Clipper library.
+
+WWW: https://github.com/greginvm/pyclipper