aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-03-18 22:58:23 +0800
committerswills <swills@FreeBSD.org>2014-03-18 22:58:23 +0800
commit4febe3babb3976f3fdbb4be3d761cf5fe90ca851 (patch)
tree436308847be77e342aa805b554c059fe719ba85d /math
parent8451a3d34b4ff68d4440c5b1b787071777c9b085 (diff)
downloadfreebsd-ports-gnome-4febe3babb3976f3fdbb4be3d761cf5fe90ca851.tar.gz
freebsd-ports-gnome-4febe3babb3976f3fdbb4be3d761cf5fe90ca851.tar.zst
freebsd-ports-gnome-4febe3babb3976f3fdbb4be3d761cf5fe90ca851.zip
- Add USES=compiler, needed for clang patch
- Add DOCS to Options - Change REINPLACE, CC and CFLAGS - Remove unused -g CFLAGS for clang - Bump PORTREVISION PR: ports/187671 Submitted by: Horia Racoviceanu <horia@racoviceanu.com> (maintainer)
Diffstat (limited to 'math')
-rw-r--r--math/ent/Makefile20
1 files changed, 16 insertions, 4 deletions
diff --git a/math/ent/Makefile b/math/ent/Makefile
index 2c834686e1c2..197e26c6d951 100644
--- a/math/ent/Makefile
+++ b/math/ent/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ent
PORTVERSION= 0.20080128
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= http://www.fourmilab.ch/random/
DISTNAME= random
@@ -11,19 +12,30 @@ DIST_SUBDIR= ${PORTNAME}/${PORTVERSION}
MAINTAINER= horia@racoviceanu.com
COMMENT= Entropy calculation and analysis of putative random sequences
-USES= zip
+USES= compiler zip
NO_WRKSUBDIR= yes
ALL_TARGET= ent
PLIST_FILES= bin/ent
+PORTDOCS= ent.html entitle.gif
+OPTIONS_DEFINE= DOCS
+
regression-test: build
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check)
+.include <bsd.port.pre.mk>
+
post-patch:
- ${REINPLACE_CMD} -e '/CC = /d' -e '/CFLAGS = /s,$$, ${CFLAGS},' \
- ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's|gcc|${CC}|; s|^CFLAGS |&+|' ${WRKSRC}/Makefile
+
+.if ${COMPILER_TYPE} == clang
+ ${REINPLACE_CMD} -e 's|-g ||' ${WRKSRC}/Makefile
+.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
-.include <bsd.port.mk>
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.post.mk>