aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2014-04-26 23:59:43 +0800
committerdemon <demon@FreeBSD.org>2014-04-26 23:59:43 +0800
commit77c1f005a0233470d9a830f75d83191702fd7844 (patch)
tree6979d7572ca7d40391b8588ed651589ee6c42fc9 /math
parent45b3a3e6e3475f17c50fed0dc99fec1f69c5485d (diff)
downloadfreebsd-ports-gnome-77c1f005a0233470d9a830f75d83191702fd7844.tar.gz
freebsd-ports-gnome-77c1f005a0233470d9a830f75d83191702fd7844.tar.zst
freebsd-ports-gnome-77c1f005a0233470d9a830f75d83191702fd7844.zip
Update to version 1.4.0.
Diffstat (limited to 'math')
-rw-r--r--math/openfst/Makefile7
-rw-r--r--math/openfst/distinfo4
-rw-r--r--math/openfst/pkg-plist40
3 files changed, 41 insertions, 10 deletions
diff --git a/math/openfst/Makefile b/math/openfst/Makefile
index cfd68cb2289f..5ad6bb355e10 100644
--- a/math/openfst/Makefile
+++ b/math/openfst/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= openfst
-PORTVERSION= 1.3.4
-PORTREVISION= 1
+PORTVERSION= 1.4.0
CATEGORIES= math
MASTER_SITES= http://www.openfst.org/twiki/pub/FST/FstDownload/
@@ -15,9 +14,9 @@ LICENSE= APACHE20
USE_GCC= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--enable-compact-fsts --enable-const-fsts --enable-far --enable-lookahead-fsts --enable-pdt
+CONFIGURE_ARGS+=--enable-compact-fsts --enable-const-fsts --enable-far --enable-linear-fsts --enable-ngram-fsts --enable-lookahead-fsts --enable-pdt
post-patch:
- ${REINPLACE_CMD} -e s#-ldl## ${WRKSRC}/src/extensions/far/Makefile.in ${WRKSRC}/src/extensions/pdt/Makefile.in ${WRKSRC}/src/bin/Makefile.in ${WRKSRC}/src/test/Makefile.in
+ ${REINPLACE_CMD} -e s#-ldl## ${WRKSRC}/src/extensions/far/Makefile.in ${WRKSRC}/src/extensions/pdt/Makefile.in ${WRKSRC}/src/bin/Makefile.in ${WRKSRC}/src/test/Makefile.in ${WRKSRC}/src/extensions/linear/Makefile.in
.include <bsd.port.mk>
diff --git a/math/openfst/distinfo b/math/openfst/distinfo
index 6e36291836f5..ddfcde5fff52 100644
--- a/math/openfst/distinfo
+++ b/math/openfst/distinfo
@@ -1,2 +1,2 @@
-SHA256 (openfst-1.3.4.tar.gz) = e95fa96674e1c9d6866bbf79b9cd755c5121ad165b76224c7c6bbfa139399a61
-SIZE (openfst-1.3.4.tar.gz) = 769158
+SHA256 (openfst-1.4.0.tar.gz) = eb557f37560438f03912b4e43335c4c9e72aa486d4f2046127131185eb88f17a
+SIZE (openfst-1.4.0.tar.gz) = 822883
diff --git a/math/openfst/pkg-plist b/math/openfst/pkg-plist
index cbf46baa6958..f745ca13fc21 100644
--- a/math/openfst/pkg-plist
+++ b/math/openfst/pkg-plist
@@ -13,6 +13,7 @@ bin/fstconnect
bin/fstconvert
bin/fstdeterminize
bin/fstdifference
+bin/fstdisambiguate
bin/fstdraw
bin/fstencode
bin/fstepsnormalize
@@ -21,6 +22,8 @@ bin/fstequivalent
bin/fstinfo
bin/fstintersect
bin/fstinvert
+bin/fstlinear
+bin/fstloglinearapply
bin/fstmap
bin/fstminimize
bin/fstprint
@@ -66,6 +69,7 @@ include/fst/const-fst.h
include/fst/determinize.h
include/fst/dfs-visit.h
include/fst/difference.h
+include/fst/disambiguate.h
include/fst/edit-fst.h
include/fst/encode.h
include/fst/epsnormalize.h
@@ -85,6 +89,15 @@ include/fst/extensions/far/main.h
include/fst/extensions/far/print-strings.h
include/fst/extensions/far/stlist.h
include/fst/extensions/far/sttable.h
+include/fst/extensions/linear/linear-fst-data-builder.h
+include/fst/extensions/linear/linear-fst-data.h
+include/fst/extensions/linear/linear-fst.h
+include/fst/extensions/linear/linearscript.h
+include/fst/extensions/linear/loglinear-apply.h
+include/fst/extensions/linear/trie.h
+include/fst/extensions/ngram/bitmap-index.h
+include/fst/extensions/ngram/ngram-fst.h
+include/fst/extensions/ngram/nthbit.h
include/fst/extensions/pdt/collection.h
include/fst/extensions/pdt/compose.h
include/fst/extensions/pdt/expand.h
@@ -97,6 +110,7 @@ include/fst/extensions/pdt/replace.h
include/fst/extensions/pdt/reverse.h
include/fst/extensions/pdt/shortest-path.h
include/fst/factor-weight.h
+include/fst/filter-state.h
include/fst/flags.h
include/fst/float-weight.h
include/fst/fst-decl.h
@@ -118,6 +132,7 @@ include/fst/map.h
include/fst/mapped-file.h
include/fst/matcher-fst.h
include/fst/matcher.h
+include/fst/memory.h
include/fst/minimize.h
include/fst/mutable-fst.h
include/fst/pair-weight.h
@@ -290,24 +305,41 @@ lib/fst/libfstfar.so.1
lib/fst/libfstfarscript.la
lib/fst/libfstfarscript.so
lib/fst/libfstfarscript.so.1
+lib/fst/libfstlinearscript.la
+lib/fst/libfstlinearscript.so
+lib/fst/libfstlinearscript.so.1
lib/fst/libfstlookahead.la
lib/fst/libfstlookahead.so
lib/fst/libfstlookahead.so.0
+lib/fst/libfstngram.la
+lib/fst/libfstngram.so
+lib/fst/libfstngram.so.1
lib/fst/libfstpdtscript.la
lib/fst/libfstpdtscript.so
lib/fst/libfstpdtscript.so.1
+lib/fst/linear_classifier-fst.la
+lib/fst/linear_classifier-fst.so
+lib/fst/linear_classifier-fst.so.0
+lib/fst/linear_tagger-fst.la
+lib/fst/linear_tagger-fst.so
+lib/fst/linear_tagger-fst.so.0
+lib/fst/ngram-fst.la
+lib/fst/ngram-fst.so
+lib/fst/ngram-fst.so.0
lib/fst/olabel_lookahead-fst.la
lib/fst/olabel_lookahead-fst.so
lib/fst/olabel_lookahead-fst.so.0
lib/libfst.la
lib/libfst.so
-lib/libfst.so.1
+lib/libfst.so.2
lib/libfstscript.la
lib/libfstscript.so
lib/libfstscript.so.1
-@dirrm include/fst/script
-@dirrm include/fst/extensions/pdt
+@dirrm lib/fst
@dirrm include/fst/extensions/far
+@dirrm include/fst/extensions/linear
+@dirrm include/fst/extensions/ngram
+@dirrm include/fst/extensions/pdt
@dirrm include/fst/extensions
+@dirrm include/fst/script
@dirrm include/fst
-@dirrm lib/fst