aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2016-04-28 00:36:41 +0800
committerswills <swills@FreeBSD.org>2016-04-28 00:36:41 +0800
commit900b8428054e4288c9669f4f17359be2ae8a45c3 (patch)
tree146c1b1aad08357a95df3348dea477d956cd3816 /math
parentc5f5d48270cbe2ede4cb24ba577ced5ea769dd2f (diff)
downloadfreebsd-ports-gnome-900b8428054e4288c9669f4f17359be2ae8a45c3.tar.gz
freebsd-ports-gnome-900b8428054e4288c9669f4f17359be2ae8a45c3.tar.zst
freebsd-ports-gnome-900b8428054e4288c9669f4f17359be2ae8a45c3.zip
create USES=gem and update rubygem- ports to use it
Note that for now ports still have to have USE_RUBY=yes to use USES=gem PR: 209041 Differential Revision: https://reviews.freebsd.org/D6070
Diffstat (limited to 'math')
-rw-r--r--math/rubygem-expression_parser/Makefile3
-rw-r--r--math/rubygem-fftw3/Makefile3
-rw-r--r--math/rubygem-narray/Makefile3
-rw-r--r--math/rubygem-narray_miss/Makefile3
-rw-r--r--math/rubygem-numru-misc/Makefile3
-rw-r--r--math/rubygem-numru-units/Makefile3
-rw-r--r--math/rubygem-rb-gsl/Makefile3
7 files changed, 7 insertions, 14 deletions
diff --git a/math/rubygem-expression_parser/Makefile b/math/rubygem-expression_parser/Makefile
index 22c5169986a1..cc87924ad271 100644
--- a/math/rubygem-expression_parser/Makefile
+++ b/math/rubygem-expression_parser/Makefile
@@ -11,7 +11,6 @@ COMMENT= Mathematical expression parser for Ruby
NO_ARCH= yes
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/math/rubygem-fftw3/Makefile b/math/rubygem-fftw3/Makefile
index c947eb8575b0..bb18a8c8670c 100644
--- a/math/rubygem-fftw3/Makefile
+++ b/math/rubygem-fftw3/Makefile
@@ -14,7 +14,6 @@ LIB_DEPENDS= libfftw3.so:math/fftw3
USE_RUBY= yes
USE_RAKE= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/math/rubygem-narray/Makefile b/math/rubygem-narray/Makefile
index 972031ba6c12..32c1b3138953 100644
--- a/math/rubygem-narray/Makefile
+++ b/math/rubygem-narray/Makefile
@@ -11,8 +11,7 @@ COMMENT= Numerical N-dimensional array library for Ruby
USE_RUBY= yes
USE_RAKE= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include "${.CURDIR}/Makefile.version"
diff --git a/math/rubygem-narray_miss/Makefile b/math/rubygem-narray_miss/Makefile
index 2c42a0de96f8..cb92ca336a04 100644
--- a/math/rubygem-narray_miss/Makefile
+++ b/math/rubygem-narray_miss/Makefile
@@ -13,7 +13,6 @@ RUN_DEPENDS= rubygem-narray>0:math/rubygem-narray
USE_RUBY= yes
USE_RAKE= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/math/rubygem-numru-misc/Makefile b/math/rubygem-numru-misc/Makefile
index 408bef80c44b..3c62c3266cfa 100644
--- a/math/rubygem-numru-misc/Makefile
+++ b/math/rubygem-numru-misc/Makefile
@@ -14,7 +14,6 @@ RUN_DEPENDS= rubygem-narray>0:math/rubygem-narray \
USE_RUBY= yes
USE_RAKE= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/math/rubygem-numru-units/Makefile b/math/rubygem-numru-units/Makefile
index 4b41a864c6da..c0bc5f6bec07 100644
--- a/math/rubygem-numru-units/Makefile
+++ b/math/rubygem-numru-units/Makefile
@@ -13,7 +13,6 @@ NO_ARCH= yes
USE_RUBY= yes
USE_RAKE= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>
diff --git a/math/rubygem-rb-gsl/Makefile b/math/rubygem-rb-gsl/Makefile
index 1d57b54f12bf..b7e17923c977 100644
--- a/math/rubygem-rb-gsl/Makefile
+++ b/math/rubygem-rb-gsl/Makefile
@@ -15,7 +15,6 @@ LIB_DEPENDS= libgsl.so:math/gsl
RUN_DEPENDS= rubygem-narray>=0.5.9:math/rubygem-narray
USE_RUBY= yes
-USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST= yes
+USES= gem:autoplist
.include <bsd.port.mk>