aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-05-10 17:13:08 +0800
committerantoine <antoine@FreeBSD.org>2014-05-10 17:13:08 +0800
commitb1e119e6e2ea03ac6ffdfa0ea1bfe08bad9ce797 (patch)
tree3443bbd3cc555f6ca8d45519c22980c30c988c1c /math
parent8fa6d57a701c631acb805b2e9a45e7ac5d5d428b (diff)
downloadfreebsd-ports-gnome-b1e119e6e2ea03ac6ffdfa0ea1bfe08bad9ce797.tar.gz
freebsd-ports-gnome-b1e119e6e2ea03ac6ffdfa0ea1bfe08bad9ce797.tar.zst
freebsd-ports-gnome-b1e119e6e2ea03ac6ffdfa0ea1bfe08bad9ce797.zip
Runtime fix: all the dynamically generated part of the plist was not packaged
With hat: portmgr
Diffstat (limited to 'math')
-rw-r--r--math/octave/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/math/octave/Makefile b/math/octave/Makefile
index f30678eee9ba..9712bff743c8 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -3,7 +3,7 @@
PORTNAME= octave
PORTVERSION= 3.8.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= octave
@@ -61,7 +61,7 @@ OPTIONS_DEFINE= DOCS
INFO= octave liboctave
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
.if exists(${LOCALBASE}/lib/libopenblas.so)
WITH_BLAS?= openblas
@@ -108,7 +108,7 @@ post-install:
.endfor
${RM} -f ${WRKDIR}/PLIST
.for d in ${PREFIX}/include/octave-${OCTAVE_VERSION} ${PREFIX}/share/octave/${OCTAVE_VERSION} ${PREFIX}/share/octave/site ${PREFIX}/lib/octave/${OCTAVE_VERSION} ${PREFIX}/libexec/octave/${OCTAVE_VERSION}
- @${FIND} -s ${STAGEDIR}$d -not -type d | \
+ @${FIND} -s ${STAGEDIR}$d -not -type d -not -name '*.la' | \
${SED} -e 's#^${STAGEDIR}${PREFIX}/##' >> ${WRKDIR}/PLIST
@${FIND} -s ${STAGEDIR}$d -type d -empty | \
${SED} -e 's,^${STAGEDIR}${PREFIX}/,@exec ${MKDIR} %D/,' \
@@ -130,4 +130,4 @@ post-install:
check regression-test: build
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} check)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>