aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-04-16 14:17:58 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-04-16 14:17:58 +0800
commitdb04d08539f7ddf9d10b95713192e74ecc69b87b (patch)
tree4e266e163d1108458ac495a4b071d37c386b86dd /math
parent015c4d23c1282d0f9a30f4874145e4a35b1668e7 (diff)
downloadfreebsd-ports-gnome-db04d08539f7ddf9d10b95713192e74ecc69b87b.tar.gz
freebsd-ports-gnome-db04d08539f7ddf9d10b95713192e74ecc69b87b.tar.zst
freebsd-ports-gnome-db04d08539f7ddf9d10b95713192e74ecc69b87b.zip
- Add LICENSE
- Fix install wrt PREFIX/LOCALBASE - Fix build on >= 10.0 - Strip library
Diffstat (limited to 'math')
-rw-r--r--math/gracetmpl/Makefile8
-rw-r--r--math/gracetmpl/files/patch-gracetmpl.cc13
-rw-r--r--math/gracetmpl/files/patch-gracetmpldemo.cpp16
3 files changed, 32 insertions, 5 deletions
diff --git a/math/gracetmpl/Makefile b/math/gracetmpl/Makefile
index 525667037a68..9a7e2239a1ac 100644
--- a/math/gracetmpl/Makefile
+++ b/math/gracetmpl/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gracetmpl
PORTVERSION= 0.3.2
+PORTREVISION= 1
CATEGORIES= math print
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -12,6 +13,9 @@ COMMENT= Provide an easy way to use existing grace-files as a template
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numarray/__init__.py:${PORTSDIR}/math/py-numarray
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/numarray/__init__.py:${PORTSDIR}/math/py-numarray
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
USES= gmake python tar:bzip2
MAKE_ARGS= PREFIX="${PREFIX}" \
BIN_PREFIX="${PREFIX}/bin" \
@@ -25,6 +29,7 @@ MAKE_ARGS= PREFIX="${PREFIX}" \
PYTHON="${PYTHON_CMD}"
ALL_TARGET= all pythonwrap
INSTALL_TARGET= install
+USE_GCC= yes
PLIST_SUB+= PYTHON_VER=${PYTHON_VER}
@@ -36,7 +41,8 @@ post-patch:
post-install:
@(cd ${INSTALL_WRKSRC}/python; ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py \
- install --root=${STAGEDIR} --prefix=${LOCALBASE} -c -O1)
+ install --root=${STAGEDIR} --prefix=${PREFIX} -c -O1)
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/graceTMPL/graceTMPL.so
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/html/* ${STAGEDIR}${DOCSDIR}
diff --git a/math/gracetmpl/files/patch-gracetmpl.cc b/math/gracetmpl/files/patch-gracetmpl.cc
index 920c4a7476be..db337c406ba6 100644
--- a/math/gracetmpl/files/patch-gracetmpl.cc
+++ b/math/gracetmpl/files/patch-gracetmpl.cc
@@ -1,6 +1,11 @@
---- gracetmpl.cpp.bak Fri Sep 24 21:56:02 2004
-+++ gracetmpl.cpp Sat Jun 18 00:18:52 2005
-@@ -24,7 +24,7 @@
+--- gracetmpl.cpp.orig 2004-09-24 16:56:02.000000000 +0400
++++ gracetmpl.cpp
+@@ -21,10 +21,12 @@
+ #include <vector>
+ #include <map>
+ #include <iostream>
++#include <cstring>
++#include <cstdlib>
extern "C" {
#include <math.h>
@@ -9,7 +14,7 @@
#include <ctype.h>
#include <time.h>
#include <sys/time.h>
-@@ -981,7 +981,7 @@
+@@ -981,7 +983,7 @@ string time2string (const string &format
gettimeofday(&tv,0);
size= (tm==0) ?
diff --git a/math/gracetmpl/files/patch-gracetmpldemo.cpp b/math/gracetmpl/files/patch-gracetmpldemo.cpp
new file mode 100644
index 000000000000..04ee2b53d8f1
--- /dev/null
+++ b/math/gracetmpl/files/patch-gracetmpldemo.cpp
@@ -0,0 +1,16 @@
+--- gracetmpldemo.cpp.orig 2003-03-04 10:32:45 UTC
++++ gracetmpldemo.cpp
+@@ -3,11 +3,13 @@ extern "C" {
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <getopt.h>
++#include <sys/syslimits.h>
+ }
+ #include <iostream>
+ #include <string>
+ #include <vector>
+ #include <map>
++#include <cstring>
+
+ #include "gracetmpl.h"
+