aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-11-01 09:53:44 +0800
committerclsung <clsung@FreeBSD.org>2006-11-01 09:53:44 +0800
commit0b5081b400ad9bc4c1c1b20184ecd9e5e417f27a (patch)
tree4c04305ef01b50db0b1c77b122ade00670392b4d /math
parentde0cfe0bc2af21bd3916015e86d58a3e7e841f9f (diff)
downloadfreebsd-ports-gnome-0b5081b400ad9bc4c1c1b20184ecd9e5e417f27a.tar.gz
freebsd-ports-gnome-0b5081b400ad9bc4c1c1b20184ecd9e5e417f27a.tar.zst
freebsd-ports-gnome-0b5081b400ad9bc4c1c1b20184ecd9e5e417f27a.zip
Add p5-Algorithm-CurveFit 1.02, nonlinear Least Squares Fitting.
PR: ports/104620 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Algorithm-CurveFit/Makefile31
-rw-r--r--math/p5-Algorithm-CurveFit/distinfo3
-rw-r--r--math/p5-Algorithm-CurveFit/pkg-descr6
-rw-r--r--math/p5-Algorithm-CurveFit/pkg-plist6
5 files changed, 47 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 8e48950ee533..40dca06ef37e 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -170,6 +170,7 @@
SUBDIR += p5-AI-NeuralNet-Mesh
SUBDIR += p5-AI-Perceptron
SUBDIR += p5-Algorithm-Combinatorics
+ SUBDIR += p5-Algorithm-CurveFit
SUBDIR += p5-Bit-ShiftReg
SUBDIR += p5-Bit-Vector
SUBDIR += p5-Bit-Vector-Minimal
diff --git a/math/p5-Algorithm-CurveFit/Makefile b/math/p5-Algorithm-CurveFit/Makefile
new file mode 100644
index 000000000000..4861bfbae796
--- /dev/null
+++ b/math/p5-Algorithm-CurveFit/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Algorithm-CurveFit
+# Date created: 2006-10-20
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Algorithm-CurveFit
+PORTVERSION= 1.02
+CATEGORIES= math
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Algorithm
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Nonlinear Least Squares Fitting
+
+RUN_DEPENDS= ${SITE_PERL}/Math/MatrixReal.pm:${PORTSDIR}/math/p5-MatrixReal \
+ ${SITE_PERL}/Math/Symbolic.pm:${PORTSDIR}/math/p5-Math-Symbolic
+
+PERL_CONFIGURE= yes
+
+MAN3= Algorithm::CurveFit.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600 # inherited from math/p5-Math-Symbolic
+IGNORE= requires 5.6.0 or newer. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/p5-Algorithm-CurveFit/distinfo b/math/p5-Algorithm-CurveFit/distinfo
new file mode 100644
index 000000000000..df443f7d8da6
--- /dev/null
+++ b/math/p5-Algorithm-CurveFit/distinfo
@@ -0,0 +1,3 @@
+MD5 (Algorithm-CurveFit-1.02.tar.gz) = d6a7e924fc9d27f498452dd560883949
+SHA256 (Algorithm-CurveFit-1.02.tar.gz) = 4d6e122e12fd1a429788991b7fbc9bed3a3e7dc1be893d2e0e21a4c4048aac5a
+SIZE (Algorithm-CurveFit-1.02.tar.gz) = 8494
diff --git a/math/p5-Algorithm-CurveFit/pkg-descr b/math/p5-Algorithm-CurveFit/pkg-descr
new file mode 100644
index 000000000000..f37560d0c511
--- /dev/null
+++ b/math/p5-Algorithm-CurveFit/pkg-descr
@@ -0,0 +1,6 @@
+Algorithm::CurveFit implements a nonlinear least squares curve fitting
+algorithm. That means, it fits a curve of known form (sine-like,
+exponential, polynomial of degree n, etc.) to a given set of data
+points.
+
+WWW: http://search.cpan.org/dist/Algorithm-CurveFit/
diff --git a/math/p5-Algorithm-CurveFit/pkg-plist b/math/p5-Algorithm-CurveFit/pkg-plist
new file mode 100644
index 000000000000..46dd59b709a2
--- /dev/null
+++ b/math/p5-Algorithm-CurveFit/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/CurveFit/.packlist
+%%SITE_PERL%%/Algorithm/CurveFit.pm
+@dirrmtry %%SITE_PERL%%/Algorithm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/CurveFit
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm