aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorak <ak@FreeBSD.org>2014-06-06 23:26:41 +0800
committerak <ak@FreeBSD.org>2014-06-06 23:26:41 +0800
commit0f745f489ad0222501a397101b34d7d775d2e7eb (patch)
treee64e38f3c341f18dafeb8cfc804d3d868ce5881f /math
parenta96bbf53e83e05784f9f205c0c9f1801f6b1b416 (diff)
downloadfreebsd-ports-gnome-0f745f489ad0222501a397101b34d7d775d2e7eb.tar.gz
freebsd-ports-gnome-0f745f489ad0222501a397101b34d7d775d2e7eb.tar.zst
freebsd-ports-gnome-0f745f489ad0222501a397101b34d7d775d2e7eb.zip
- Use /usr/bin/unzip for zip files extraction (part 2)
Remove most of USES=zip:infozip PR: ports/188419 Approved by: portmgr (bapt) Exp-run: antoine
Diffstat (limited to 'math')
-rw-r--r--math/jama/Makefile4
-rw-r--r--math/miracl/Makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/math/jama/Makefile b/math/jama/Makefile
index 975229207bef..0fdeb4c32750 100644
--- a/math/jama/Makefile
+++ b/math/jama/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/tnt/tnt.h:${PORTSDIR}/devel/tnt \
unzip:${PORTSDIR}/archivers/unzip
RUN_DEPENDS= ${LOCALBASE}/include/tnt/tnt.h:${PORTSDIR}/devel/tnt
-USES= zip:infozip
+USES= zip
NO_BUILD= yes
do-install:
@@ -27,7 +27,7 @@ do-install:
${UNZIP_CMD} ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME} \
-d ${STAGEDIR}${PREFIX}/include/tnt
${MKDIR} ${WRKDIR}/doc ${STAGEDIR}${DOCSDIR}
- ${UNZIP_CMD} -o ${DISTDIR}/${DIST_SUBDIR}/jama102doc \
+ ${UNZIP_CMD} -o ${DISTDIR}/${DIST_SUBDIR}/jama102doc.zip \
-d ${WRKDIR}/doc
(cd ${WRKDIR}/doc/doxygen && ${COPYTREE_SHARE} \* ${STAGEDIR}${DOCSDIR})
diff --git a/math/miracl/Makefile b/math/miracl/Makefile
index 85a4008670f2..f2b6989c56bf 100644
--- a/math/miracl/Makefile
+++ b/math/miracl/Makefile
@@ -24,10 +24,10 @@ LICENSE_PERMS_COMMERCIAL= dist-mirror dist-sell pkg-mirror pkg-sell no-auto-acce
ONLY_FOR_ARCHS= i386 amd64
-USES= zip:infozip
+USES= zip
USE_LDCONFIG= yes
-EXTRACT_BEFORE_ARGS= -j -aa -L -q
+EXTRACT_BEFORE_ARGS= -j -L -q
EXTRACT_AFTER_ARGS= -d ${WRKSRC}
PLIST_FILES= lib/libmiracl.a \