aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authordb <db@FreeBSD.org>2014-12-11 21:00:44 +0800
committerdb <db@FreeBSD.org>2014-12-11 21:00:44 +0800
commit2bc302f75245126fb7dc259728c9bfab0393da89 (patch)
tree6ecbc07584ae82b05cb5ec53c908d401a5849818 /math
parentc488be2d25d989450b87272e9dacd88a85887fce (diff)
downloadfreebsd-ports-gnome-2bc302f75245126fb7dc259728c9bfab0393da89.tar.gz
freebsd-ports-gnome-2bc302f75245126fb7dc259728c9bfab0393da89.tar.zst
freebsd-ports-gnome-2bc302f75245126fb7dc259728c9bfab0393da89.zip
- Tiny fix to f2py2e.py to allow it to deal with -fstack-protector flag
as without this fix, f2py will attempt to compile -fstack-protector Submitted by: db Reviewed by: wg Approved by: wg
Diffstat (limited to 'math')
-rw-r--r--math/py-numpy/Makefile1
-rw-r--r--math/py-numpy/files/patch-numpy-f2py-f2py2e.py10
2 files changed, 6 insertions, 5 deletions
diff --git a/math/py-numpy/Makefile b/math/py-numpy/Makefile
index 12a19b39f32a..dbf3a3a4990d 100644
--- a/math/py-numpy/Makefile
+++ b/math/py-numpy/Makefile
@@ -3,6 +3,7 @@
PORTNAME= numpy
PORTVERSION= 1.9.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= math python
MASTER_SITES= http://docs.scipy.org/doc/${PORTNAME}/:doc \
diff --git a/math/py-numpy/files/patch-numpy-f2py-f2py2e.py b/math/py-numpy/files/patch-numpy-f2py-f2py2e.py
index edaa9241330e..44715a1138a8 100644
--- a/math/py-numpy/files/patch-numpy-f2py-f2py2e.py
+++ b/math/py-numpy/files/patch-numpy-f2py-f2py2e.py
@@ -1,14 +1,14 @@
---- numpy/f2py/f2py2e.py.orig 2013-10-30 13:31:41.000000000 -0500
-+++ numpy/f2py/f2py2e.py 2014-04-09 10:23:49.000000000 -0500
-@@ -520,6 +520,7 @@
+--- numpy/f2py/f2py2e.py.orig 2014-10-26 10:36:14.000000000 -0400
++++ numpy/f2py/f2py2e.py 2014-12-11 07:52:11.000000000 -0500
+@@ -516,6 +516,7 @@
include_dirs, sources = filter_files('-I', '', sources, remove_prefix=1)
library_dirs, sources = filter_files('-L', '', sources, remove_prefix=1)
libraries, sources = filter_files('-l', '', sources, remove_prefix=1)
-+ extra_link_args, sources = filter_files('-Wl,|-B','',sources,remove_prefix=0)
++ extra_link_args, sources = filter_files('-Wl,|-B|-f','',sources,remove_prefix=0)
undef_macros, sources = filter_files('-U', '', sources, remove_prefix=1)
define_macros, sources = filter_files('-D', '', sources, remove_prefix=1)
using_numarray = 0
-@@ -555,6 +556,7 @@
+@@ -551,6 +552,7 @@
'undef_macros': undef_macros,
'extra_objects': extra_objects,
'f2py_options': f2py_flags,