aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-12-07 12:10:42 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-12-07 12:10:42 +0800
commit40998a233a7c3ad205ece8f6b05f284af050cc95 (patch)
tree9b741ee85f270340a6b270e303275de3f6cd832a /math
parent09e37fa0ff32c51914a39eefb3561bcc1607ef81 (diff)
downloadfreebsd-ports-gnome-40998a233a7c3ad205ece8f6b05f284af050cc95.tar.gz
freebsd-ports-gnome-40998a233a7c3ad205ece8f6b05f284af050cc95.tar.zst
freebsd-ports-gnome-40998a233a7c3ad205ece8f6b05f284af050cc95.zip
Provides support for big integer calculations. Not intended to be used
by other modules. Other modules which sport the same functions can also be used to support Math::BigInt, like Math::BigInt::GMP or Math::BigInt::Pari. WWW: http://search.cpan.org/dist/Math-BigInt-FastCalc/ PR: ports/152635 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-BigInt-FastCalc/Makefile23
-rw-r--r--math/p5-Math-BigInt-FastCalc/distinfo2
-rw-r--r--math/p5-Math-BigInt-FastCalc/pkg-descr6
-rw-r--r--math/p5-Math-BigInt-FastCalc/pkg-plist10
5 files changed, 42 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 11b7fcb570f3..adf1d8b6435e 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -324,6 +324,7 @@
SUBDIR += p5-Math-Bezier
SUBDIR += p5-Math-Bezier-Convert
SUBDIR += p5-Math-BigInt
+ SUBDIR += p5-Math-BigInt-FastCalc
SUBDIR += p5-Math-BigInt-GMP
SUBDIR += p5-Math-BigInt-Pari
SUBDIR += p5-Math-BigRat
diff --git a/math/p5-Math-BigInt-FastCalc/Makefile b/math/p5-Math-BigInt-FastCalc/Makefile
new file mode 100644
index 000000000000..de6c6ef8df85
--- /dev/null
+++ b/math/p5-Math-BigInt-FastCalc/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: p5-Math-BigInt-FastCalc
+# Date created: 2010-11-26
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-BigInt-FastCalc
+PORTVERSION= 0.24
+CATEGORIES= math perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Math::BigInt::Calc with some XS for more speed
+
+RUN_DEPENDS= p5-Math-BigInt>=0:${PORTSDIR}/math/p5-Math-BigInt
+
+PERL_CONFIGURE= yes
+
+MAN3= Math::BigInt::FastCalc.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-BigInt-FastCalc/distinfo b/math/p5-Math-BigInt-FastCalc/distinfo
new file mode 100644
index 000000000000..57e93d502b8b
--- /dev/null
+++ b/math/p5-Math-BigInt-FastCalc/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Math-BigInt-FastCalc-0.24.tar.gz) = b537a6217771ea54321ba90130b25b074c024ca253e6091941f0db77c2cd80e7
+SIZE (Math-BigInt-FastCalc-0.24.tar.gz) = 62000
diff --git a/math/p5-Math-BigInt-FastCalc/pkg-descr b/math/p5-Math-BigInt-FastCalc/pkg-descr
new file mode 100644
index 000000000000..8cb95253c9de
--- /dev/null
+++ b/math/p5-Math-BigInt-FastCalc/pkg-descr
@@ -0,0 +1,6 @@
+Provides support for big integer calculations. Not intended to be used
+by other modules. Other modules which sport the same functions can
+also be used to support Math::BigInt, like Math::BigInt::GMP or
+Math::BigInt::Pari.
+
+WWW: http://search.cpan.org/dist/Math-BigInt-FastCalc/
diff --git a/math/p5-Math-BigInt-FastCalc/pkg-plist b/math/p5-Math-BigInt-FastCalc/pkg-plist
new file mode 100644
index 000000000000..1774273a0e3a
--- /dev/null
+++ b/math/p5-Math-BigInt-FastCalc/pkg-plist
@@ -0,0 +1,10 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/Math/BigInt/FastCalc.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/BigInt/FastCalc/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/BigInt/FastCalc/FastCalc.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/BigInt/FastCalc/FastCalc.so
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/BigInt/FastCalc
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/BigInt
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Math/BigInt
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Math