aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2010-06-14 15:47:11 +0800
committergahr <gahr@FreeBSD.org>2010-06-14 15:47:11 +0800
commit5195b9f359ea858e5697fd257b40ae555c902c0b (patch)
treea679524dbc17656af040181b97af63c9c7800372 /math
parent01b9d65bf5fdffaa782b2eaa6f10aa98004b6a76 (diff)
downloadfreebsd-ports-gnome-5195b9f359ea858e5697fd257b40ae555c902c0b.tar.gz
freebsd-ports-gnome-5195b9f359ea858e5697fd257b40ae555c902c0b.tar.zst
freebsd-ports-gnome-5195b9f359ea858e5697fd257b40ae555c902c0b.zip
- Activate tcl/tk 8.5
- Fix build onf amd64 [1] Reported by: PH (via pav) [1] Tested by: pluknet (on EFNet/#bsdports)
Diffstat (limited to 'math')
-rw-r--r--math/goblin/Makefile21
-rw-r--r--math/goblin/files/patch-Makefile.conf30
2 files changed, 9 insertions, 42 deletions
diff --git a/math/goblin/Makefile b/math/goblin/Makefile
index 99d5fb67b8f3..00aac906486c 100644
--- a/math/goblin/Makefile
+++ b/math/goblin/Makefile
@@ -16,28 +16,25 @@ EXTRACT_SUFX= .tgz
MAINTAINER= gahr@FreeBSD.org
COMMENT= A Graph Object Library for Network Programming Problems
-USE_TK= 84
-USE_TCL= 84
-USE_XORG= x11
+USE_TK= 84+
+USE_TCL= 84+
USE_GMAKE= yes
USE_LDCONFIG= yes
MAKE_ARGS= CC="${CC}" CCFLAGS="${CFLAGS}" \
CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" \
- LD="${CXX}" LIBS="-lm ${LDFLAGS}" LISShared="-lm ${LDFLAGS}" \
- libtcl=84 libtk=84 prefix=${PREFIX}
+ LD="${CXX}" LIBS="-lm ${LDFLAGS}" \
+ libtcl=${USE_TCL} libtk=${USE_TK} prefix=${PREFIX}
ALL_TARGET= all shared
PLIST_SUB+= VERSION=${PORTVERSION:R}
-CFLAGS+= -I${LOCALBASE}/include/tcl8.4 -I${LOCALBASE}/include/ \
- -I${LOCALBASE}/include/tk8.4 ${PTHREAD_CFLAGS}
-LDFLAGS= -L${LOCALBASE}/lib -ltcl84 -ltk84 ${PTHREAD_LIBS}
-
-WISH= ${LOCALBASE}/bin/wish8.4
+CFLAGS+= -I${LOCALBASE}/include/tcl${TCL_VER} -I${LOCALBASE}/include/ \
+ -I${LOCALBASE}/include/tk${TK_VER} ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib -ltcl${USE_TCL} -ltk${USE_TK} ${PTHREAD_LIBS}
.include <bsd.port.pre.mk>
-.if ${ARCH} != "i386"
-BROKEN= does not build on !i386
+.if ${ARCH} == "amd64"
+CFLAGS+= -fPIC
.endif
post-patch:
diff --git a/math/goblin/files/patch-Makefile.conf b/math/goblin/files/patch-Makefile.conf
deleted file mode 100644
index db4ebe427a23..000000000000
--- a/math/goblin/files/patch-Makefile.conf
+++ /dev/null
@@ -1,30 +0,0 @@
---- Makefile.conf.orig 2008-05-05 07:51:22.000000000 +0200
-+++ Makefile.conf 2008-05-31 02:08:59.000000000 +0200
-@@ -27,8 +27,8 @@
- libtcl = tcl
- libtk = tk
- else
-- libtcl = tcl8.4
-- libtk = tk8.4
-+ libtcl = tcl84
-+ libtk = tk84
- endif
-
- # Qualifier is necessary with Tcl/Tk 8.4 headers:
-@@ -44,7 +44,7 @@
- ifeq ($(os),solaris)
- wish_name = /opt/csw/bin/wish
- else
-- wish_name = /usr/bin/wish
-+ wish_name = %%WISH%%
- endif
-
-
-@@ -52,7 +52,6 @@
-
- ## GNU default settings, especially used for linux
-
--CC = gcc
- CCFLAGS = -trigraphs -fPIC
- CXX = g++
- CXXFLAGS = -g -Wall -pedantic -fPIC