aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-12-21 01:56:52 +0800
committerantoine <antoine@FreeBSD.org>2014-12-21 01:56:52 +0800
commit61018e28c26a01adbc873120840fb6e1677e2c01 (patch)
tree8d339c6a1c8d504f0158e463ee9e30d58cf716c5 /math
parent56c5a59edc8aa55d583430dea1250d11dbc13dcf (diff)
downloadfreebsd-ports-gnome-61018e28c26a01adbc873120840fb6e1677e2c01.tar.gz
freebsd-ports-gnome-61018e28c26a01adbc873120840fb6e1677e2c01.tar.zst
freebsd-ports-gnome-61018e28c26a01adbc873120840fb6e1677e2c01.zip
- Use GH_COMMIT
- Use shebangfix instead of doing it manually
Diffstat (limited to 'math')
-rw-r--r--math/bsdnt/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/math/bsdnt/Makefile b/math/bsdnt/Makefile
index 5f342f16a320..886670420d7b 100644
--- a/math/bsdnt/Makefile
+++ b/math/bsdnt/Makefile
@@ -12,19 +12,16 @@ LICENSE= BSD3CLAUSE
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
-USES= gmake
+USES= gmake shebangfix
+SHEBANG_FILES= configure
USE_GITHUB= yes
GH_ACCOUNT= wbhart
GH_PROJECT= ${PORTNAME}
GH_TAGNAME= 72e20a7
+GH_COMMIT= 72e20a7
USE_LDCONFIG= yes
-WRKSRC= ${WRKDIR}/wbhart-${PORTNAME}-${GH_TAGNAME}
-
-pre-configure:
- @${REINPLACE_CMD} -e "s,#!/bin/bash,#!${LOCALBASE}/bin/bash," ${WRKSRC}/configure
-
do-configure:
@cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ./configure --prefix=${STAGEDIR}${PREFIX} CC=cc CXX=c++ AS=cc