aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorstephen <stephen@FreeBSD.org>2013-02-04 09:34:42 +0800
committerstephen <stephen@FreeBSD.org>2013-02-04 09:34:42 +0800
commit66ccc801cf22e31f93fc68fb8ea75069ecd5a187 (patch)
treec20da5727b76d42fcc23d711ecbb49b6008cc0b0 /math
parent004e16dc2bd6cc1e4198d4bd07eaf19b9cc98d19 (diff)
downloadfreebsd-ports-gnome-66ccc801cf22e31f93fc68fb8ea75069ecd5a187.tar.gz
freebsd-ports-gnome-66ccc801cf22e31f93fc68fb8ea75069ecd5a187.tar.zst
freebsd-ports-gnome-66ccc801cf22e31f93fc68fb8ea75069ecd5a187.zip
- New port math/octave-forge-database.
The octave-forge package is the result of The GNU Octave Repositry project, which is intended to be a central location for custom scripts, functions and extensions for GNU Octave. contains the source for all the functions plus build and install scripts. This is database: interface to SQL databases, currently only postgresql using libpq.
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/octave-forge-database/Makefile33
-rw-r--r--math/octave-forge-database/distinfo2
-rw-r--r--math/octave-forge-database/pkg-descr10
-rw-r--r--math/octave-forge-database/pkg-plist1
5 files changed, 47 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 7e535b8bdaf3..670d3027d7bb 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -280,6 +280,7 @@
SUBDIR += octave-forge-communications
SUBDIR += octave-forge-control
SUBDIR += octave-forge-data-smoothing
+ SUBDIR += octave-forge-database
SUBDIR += octave-forge-dataframe
SUBDIR += octave-forge-dicom
SUBDIR += octave-forge-econometrics
diff --git a/math/octave-forge-database/Makefile b/math/octave-forge-database/Makefile
new file mode 100644
index 000000000000..d6538ecc22aa
--- /dev/null
+++ b/math/octave-forge-database/Makefile
@@ -0,0 +1,33 @@
+# Created by: Stephen Montgomery-Smith <stephen@FreeBSd.org>
+# $FreeBSD$
+
+PORTNAME= octave-forge-database
+PORTVERSION= 2.0.0
+CATEGORIES= math
+
+MAINTAINER= stephen@FreeBSD.org
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${DISTNAME}
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
+
+#USE_AUTOTOOLS= autoconf
+GNU_CONFIGURE= yes
+USE_PGSQL= yes
+ALL_TARGET=
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.octave.mk"
+
+post-build:
+ ${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
+
+post-patch:
+ ${REINPLACE_CMD} 's#postgresql/##' ${WRKSRC}/*
+ ${REINPLACE_CMD} 's#endian.h#sys/endian.h#' ${WRKSRC}/*
+
+.include <bsd.port.post.mk>
diff --git a/math/octave-forge-database/distinfo b/math/octave-forge-database/distinfo
new file mode 100644
index 000000000000..dc97d8cee6e3
--- /dev/null
+++ b/math/octave-forge-database/distinfo
@@ -0,0 +1,2 @@
+SHA256 (octave-forge/database-2.0.0.tar.gz) = 28768fbcba7f9581ca730c0a389097f16e064b4d264f34d5fce54da655a0cf80
+SIZE (octave-forge/database-2.0.0.tar.gz) = 75074
diff --git a/math/octave-forge-database/pkg-descr b/math/octave-forge-database/pkg-descr
new file mode 100644
index 000000000000..f57be45c0916
--- /dev/null
+++ b/math/octave-forge-database/pkg-descr
@@ -0,0 +1,10 @@
+The octave-forge package is the result of The GNU Octave Repositry project,
+which is intended to be a central location for custom scripts, functions and
+extensions for GNU Octave. contains the source for all the functions plus
+build and install scripts.
+
+This is database.
+
+ Interface to SQL databases, currently only postgresql using libpq.
+
+WWW: http://octave.sourceforge.net/
diff --git a/math/octave-forge-database/pkg-plist b/math/octave-forge-database/pkg-plist
new file mode 100644
index 000000000000..a999ec86c07e
--- /dev/null
+++ b/math/octave-forge-database/pkg-plist
@@ -0,0 +1 @@
+@comment This file intentionally left empty