aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-12-26 03:04:25 +0800
committerantoine <antoine@FreeBSD.org>2014-12-26 03:04:25 +0800
commit8dc323dc2bd29f0219de5776d0c246c80eba274e (patch)
tree1ab8a61c390fb88b46b924e62465cf67b9cc354f /math
parent25c80782c536ce329491182eaac8df1c164c4f79 (diff)
downloadfreebsd-ports-gnome-8dc323dc2bd29f0219de5776d0c246c80eba274e.tar.gz
freebsd-ports-gnome-8dc323dc2bd29f0219de5776d0c246c80eba274e.tar.zst
freebsd-ports-gnome-8dc323dc2bd29f0219de5776d0c246c80eba274e.zip
Change libpng15.so to libpng.so in LIB_DEPENDS to prepare the upgrade
Diffstat (limited to 'math')
-rw-r--r--math/R/Makefile2
-rw-r--r--math/grace/Makefile2
-rw-r--r--math/ploticus/Makefile2
-rw-r--r--math/qtiplot/Makefile2
-rw-r--r--math/reduce/Makefile2
-rw-r--r--math/vtk5/Makefile2
6 files changed, 6 insertions, 6 deletions
diff --git a/math/R/Makefile b/math/R/Makefile
index b892dd1df373..361e36aac373 100644
--- a/math/R/Makefile
+++ b/math/R/Makefile
@@ -224,7 +224,7 @@ PLIST_SUB+= PANGOCAIRO="@comment "
.endif
.if ${PORT_OPTIONS:MPNG}
-LIB_DEPENDS+= libpng15.so:${PORTSDIR}/graphics/png
+LIB_DEPENDS+= libpng.so:${PORTSDIR}/graphics/png
CONFIGURE_ARGS+= --with-libpng
.else
CONFIGURE_ARGS+= --without-libpng
diff --git a/math/grace/Makefile b/math/grace/Makefile
index 8007b72abb13..6cca980d4958 100644
--- a/math/grace/Makefile
+++ b/math/grace/Makefile
@@ -16,7 +16,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libt1.so:${PORTSDIR}/devel/t1lib \
libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng15.so:${PORTSDIR}/graphics/png \
+ libpng.so:${PORTSDIR}/graphics/png \
libXbae.so:${PORTSDIR}/x11-toolkits/xbae
RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils
diff --git a/math/ploticus/Makefile b/math/ploticus/Makefile
index 246d90fbc427..6b990f15d01c 100644
--- a/math/ploticus/Makefile
+++ b/math/ploticus/Makefile
@@ -14,7 +14,7 @@ COMMENT?= Generates plots and graphs from data
LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd \
libjpeg.so:${PORTSDIR}/graphics/jpeg \
libming.so:${PORTSDIR}/graphics/ming \
- libpng15.so:${PORTSDIR}/graphics/png \
+ libpng.so:${PORTSDIR}/graphics/png \
libfreetype.so:${PORTSDIR}/print/freetype2
BUILD_WRKSRC= ${WRKSRC}/src
diff --git a/math/qtiplot/Makefile b/math/qtiplot/Makefile
index b7d393bf49a5..af80f6ff6b38 100644
--- a/math/qtiplot/Makefile
+++ b/math/qtiplot/Makefile
@@ -12,7 +12,7 @@ COMMENT= Data analysis and scientific plotting
LIB_DEPENDS= libgsl.so:${PORTSDIR}/math/gsl \
libmuparser.so:${PORTSDIR}/math/muparser \
- libpng15.so:${PORTSDIR}/graphics/png
+ libpng.so:${PORTSDIR}/graphics/png
# use bundled modified libraries
# qwt.5:${PORTSDIR}/x11-toolkits/qwt5 \
# qwtplot3d-qt4:${PORTSDIR}/math/qwtplot3d-qt4
diff --git a/math/reduce/Makefile b/math/reduce/Makefile
index e765f2e75caf..f920ac49817b 100644
--- a/math/reduce/Makefile
+++ b/math/reduce/Makefile
@@ -15,7 +15,7 @@ LICENSE= BSD2CLAUSE
RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng15.so:${PORTSDIR}/graphics/png \
+ libpng.so:${PORTSDIR}/graphics/png \
libtiff.so:${PORTSDIR}/graphics/tiff
USES= gmake tar:bzip2
diff --git a/math/vtk5/Makefile b/math/vtk5/Makefile
index 523d0d05f658..31c53811d1c8 100644
--- a/math/vtk5/Makefile
+++ b/math/vtk5/Makefile
@@ -16,7 +16,7 @@ LICENSE= BSD3CLAUSE
LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2 \
libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng15.so:${PORTSDIR}/graphics/png \
+ libpng.so:${PORTSDIR}/graphics/png \
libtiff.so:${PORTSDIR}/graphics/tiff
WRKSRC= ${WRKDIR}/VTK${PORTVERSION}