aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2007-08-15 15:17:17 +0800
committeritetcu <itetcu@FreeBSD.org>2007-08-15 15:17:17 +0800
commit8e423cca3af703f86910ae1edafd191f318137b8 (patch)
tree0397e636c63a49aeca548b5af90a5578d39cc90b /math
parenta2de379e9ba30e00830620123d117268ba9e3e6b (diff)
downloadfreebsd-ports-gnome-8e423cca3af703f86910ae1edafd191f318137b8.tar.gz
freebsd-ports-gnome-8e423cca3af703f86910ae1edafd191f318137b8.tar.zst
freebsd-ports-gnome-8e423cca3af703f86910ae1edafd191f318137b8.zip
- Update QT_COMPONENTS in Makefile since bsd.qt.mk has been change [1]
- Remove corelib in QT_COMPONENTS because it depends by gui [1] - use PTHREAD_LIBS [2] PR: ports/115519 [1] Submitted by: Yinghong.Liu (maintainer) [1], sat@ [2]
Diffstat (limited to 'math')
-rw-r--r--math/speedcrunch/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/math/speedcrunch/Makefile b/math/speedcrunch/Makefile
index 939d64afcf75..e22acf04f6a6 100644
--- a/math/speedcrunch/Makefile
+++ b/math/speedcrunch/Makefile
@@ -16,11 +16,11 @@ COMMENT= A desktop calculator for power users
BUILD_DEPENDS= cmake:${PORTSDIR}/devel/cmake
USE_QT_VER= 4
-QT_COMPONENTS= qmake corelib moc gui rcc
+QT_COMPONENTS= qmake_build moc_build rcc_build gui
CMAKE_ARGS= -DCMAKE_BUILD_TYPE:STRING=Release \
-DCMAKE_C_COMPILER:STRING='${CC}' \
-DCMAKE_CXX_COMPILER:STRING=${CXX} \
- -DCMAKE_CXX_FLAGS:STRING="${CXXFLAGS} -pthread" \
+ -DCMAKE_CXX_FLAGS:STRING="${CXXFLAGS} ${PTHREAD_LIBS}" \
-DCMAKE_INSTALL_PREFIX=${PREFIX}
MYPORTDOCS= COPYING ChangeLog HACKING.txt INSTALL.txt LISEZMOI PACKAGERS README \