aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2004-03-14 14:17:56 +0800
committerade <ade@FreeBSD.org>2004-03-14 14:17:56 +0800
commit9291e9a32f6612ca0d4f25bdcb5c417e0451d313 (patch)
tree545e55afde412d844a25f5c03d6d51b17ceeebb9 /math
parenta8a89c37fe338cbff0192ceeef27ccf7a13714a5 (diff)
downloadfreebsd-ports-gnome-9291e9a32f6612ca0d4f25bdcb5c417e0451d313.tar.gz
freebsd-ports-gnome-9291e9a32f6612ca0d4f25bdcb5c417e0451d313.tar.zst
freebsd-ports-gnome-9291e9a32f6612ca0d4f25bdcb5c417e0451d313.zip
Whoa there, boy, that's a mighty big commit y'all have there...
Begin autotools sanitization sequence by requiring ports to explicitly specify which version of {libtool,autoconf,automake} they need, erasing the concept of a "system default". For ports-in-waiting: USE_LIBTOOL=YES -> USE_LIBTOOL_VER=13 USE_AUTOCONF=YES -> USE_AUTOCONF_VER=213 USE_AUTOMAKE=YES -> USE_AUTOMAKE_VER=14 Ports attempting to use the old style system after June 1st 2004 will be sorely disappointed.
Diffstat (limited to 'math')
-rw-r--r--math/asir2000/Makefile3
-rw-r--r--math/cln/Makefile2
-rw-r--r--math/fftw/Makefile2
-rw-r--r--math/fftw3/Makefile2
-rw-r--r--math/fung-calc/Makefile2
-rw-r--r--math/gcalctool/Makefile2
-rw-r--r--math/geg/Makefile2
-rw-r--r--math/gmp/Makefile2
-rw-r--r--math/gnumeric/Makefile2
-rw-r--r--math/gnumeric2/Makefile2
-rw-r--r--math/gnuplot+/Makefile2
-rw-r--r--math/gsl/Makefile2
-rw-r--r--math/koctave/Makefile2
-rw-r--r--math/libgmp4/Makefile2
-rw-r--r--math/libmath++/Makefile2
-rw-r--r--math/libneural/Makefile2
-rw-r--r--math/maxima/Makefile4
-rw-r--r--math/mtl/Makefile2
-rw-r--r--math/spar/Makefile2
19 files changed, 20 insertions, 21 deletions
diff --git a/math/asir2000/Makefile b/math/asir2000/Makefile
index 0b079d9d102f..1caae0673d0b 100644
--- a/math/asir2000/Makefile
+++ b/math/asir2000/Makefile
@@ -19,8 +19,7 @@ COMMENT= The system Risa/Asir is a general computer algebra system
LIB_DEPENDS= pari-2.2:${PORTSDIR}/math/pari-devel
GNU_CONFIGURE= yes
-USE_AUTOMAKE= yes
-USE_AUTOCONF= yes
+USE_AUTOCONF_VER= 213
USE_AUTOMAKE_VER= 15
USE_XLIB= yes
CONFIGURE_ARGS= --enable-shared --enable-plot --enable-fep --enable-interval --with-pari=new
diff --git a/math/cln/Makefile b/math/cln/Makefile
index ea9e48cca2e3..61680cdb35aa 100644
--- a/math/cln/Makefile
+++ b/math/cln/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gnomehack
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --infodir=${PREFIX}/info --mandir=${PREFIX}/man \
diff --git a/math/fftw/Makefile b/math/fftw/Makefile
index a16aff6b3bd0..b0932029fea0 100644
--- a/math/fftw/Makefile
+++ b/math/fftw/Makefile
@@ -18,7 +18,7 @@ MAINTAINER= Lars.Koeller@Uni-Bielefeld.DE
COMMENT= Fast C routines to compute the Discrete Fourier Transform
USE_GMAKE= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
CONFIGURE_ARGS= --enable-shared
diff --git a/math/fftw3/Makefile b/math/fftw3/Makefile
index a16aff6b3bd0..b0932029fea0 100644
--- a/math/fftw3/Makefile
+++ b/math/fftw3/Makefile
@@ -18,7 +18,7 @@ MAINTAINER= Lars.Koeller@Uni-Bielefeld.DE
COMMENT= Fast C routines to compute the Discrete Fourier Transform
USE_GMAKE= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
CONFIGURE_ARGS= --enable-shared
diff --git a/math/fung-calc/Makefile b/math/fung-calc/Makefile
index 869b8748ebe3..23268874b494 100644
--- a/math/fung-calc/Makefile
+++ b/math/fung-calc/Makefile
@@ -17,7 +17,7 @@ COMMENT= Advanced graphic calculator
USE_KDELIBS_VER= 3
USE_GL= yes
USE_GMAKE= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
diff --git a/math/gcalctool/Makefile b/math/gcalctool/Makefile
index 7d676b8490b7..4c5362e6f2b2 100644
--- a/math/gcalctool/Makefile
+++ b/math/gcalctool/Makefile
@@ -18,7 +18,7 @@ COMMENT= A GNOME 2 calculator tool based on the old calctool for OpenWindows
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
USE_REINPLACE= yes
USE_GNOME= gnomeprefix gnomehack lthack intlhack libgnomeui
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/math/geg/Makefile b/math/geg/Makefile
index 0d464bd32d4f..e96a0872578f 100644
--- a/math/geg/Makefile
+++ b/math/geg/Makefile
@@ -18,7 +18,7 @@ COMMENT= Visualise multiple 2D-functions of one variable
USE_X_PREFIX= yes
USE_GNOME= gtk12
-USE_AUTOMAKE= yes
+USE_AUTOMAKE_VER= 14
AUTOMAKE_ARGS= -a -i
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/math/gmp/Makefile b/math/gmp/Makefile
index 1f4e7cc7dc58..e085ce60b8f3 100644
--- a/math/gmp/Makefile
+++ b/math/gmp/Makefile
@@ -19,7 +19,7 @@ COMMENT= A free library for arbitrary precision arithmetic
CONFLICTS= libgmp-2*
USE_REINPLACE= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
CONFIGURE_ARGS= --enable-cxx --enable-mpfr
INSTALLS_SHLIB= yes
diff --git a/math/gnumeric/Makefile b/math/gnumeric/Makefile
index 620672e1914c..c792e12aac44 100644
--- a/math/gnumeric/Makefile
+++ b/math/gnumeric/Makefile
@@ -28,7 +28,7 @@ USE_PERL5= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack gnomelibs bonobo libglade gal
USE_PYTHON= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --with-evolution --without-guile
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
diff --git a/math/gnumeric2/Makefile b/math/gnumeric2/Makefile
index 0534b610a62b..76d91ad7993d 100644
--- a/math/gnumeric2/Makefile
+++ b/math/gnumeric2/Makefile
@@ -27,7 +27,7 @@ USE_GNOME= gnomeprefix gnomehack gnomehier libgnomeprintui libgnomedb \
libgsf
USE_PYTHON= yes
USE_REINPLACE= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
CONFIGURE_ARGS= --without-guile --with-bonobo --with-gnome-db
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib -liconv ${PTHREAD_LIBS}" \
diff --git a/math/gnuplot+/Makefile b/math/gnuplot+/Makefile
index 67f12d27055d..efa0edbf007f 100644
--- a/math/gnuplot+/Makefile
+++ b/math/gnuplot+/Makefile
@@ -26,7 +26,7 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
USE_FREETYPE= yes
USE_XLIB= yes
USE_GMAKE= yes
-USE_AUTOCONF= yes
+USE_AUTOCONF_VER= 213
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --exec-prefix=${PREFIX} \
--includedir=${LOCALBASE}/include/ \
diff --git a/math/gsl/Makefile b/math/gsl/Makefile
index e0eaf2f6dd4f..fe3bd6d96614 100644
--- a/math/gsl/Makefile
+++ b/math/gsl/Makefile
@@ -18,7 +18,7 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= The GNU Scientific Library - mathematical libs
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV+= MAKEINFO='makeinfo --no-split'
diff --git a/math/koctave/Makefile b/math/koctave/Makefile
index 8ffba480933d..f4e6cc826e2e 100644
--- a/math/koctave/Makefile
+++ b/math/koctave/Makefile
@@ -17,7 +17,7 @@ COMMENT= KDEGUI for octave
RUN_DEPENDS= octave:${PORTSDIR}/math/octave
USE_BZIP2= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
USE_QT_VER= 3
USE_KDELIBS_VER=3
USE_GMAKE= yes
diff --git a/math/libgmp4/Makefile b/math/libgmp4/Makefile
index 1f4e7cc7dc58..e085ce60b8f3 100644
--- a/math/libgmp4/Makefile
+++ b/math/libgmp4/Makefile
@@ -19,7 +19,7 @@ COMMENT= A free library for arbitrary precision arithmetic
CONFLICTS= libgmp-2*
USE_REINPLACE= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
CONFIGURE_ARGS= --enable-cxx --enable-mpfr
INSTALLS_SHLIB= yes
diff --git a/math/libmath++/Makefile b/math/libmath++/Makefile
index ab2b3f38358c..420893a956a8 100644
--- a/math/libmath++/Makefile
+++ b/math/libmath++/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= jhb@FreeBSD.org
COMMENT= C++ Library for Symbolic and Numeric Calculus Applications
USE_GMAKE= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
.include <bsd.port.mk>
diff --git a/math/libneural/Makefile b/math/libneural/Makefile
index 10f4330d7a5d..9c37368e32e5 100644
--- a/math/libneural/Makefile
+++ b/math/libneural/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= http://ieee.uow.edu.au/documents/contrib/
MAINTAINER= ports@FreeBSD.org
COMMENT= C++ implementation of the classic 3-layer perceptron in library form
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
.include <bsd.port.mk>
diff --git a/math/maxima/Makefile b/math/maxima/Makefile
index 04ce0abf19d5..931cf88c9d77 100644
--- a/math/maxima/Makefile
+++ b/math/maxima/Makefile
@@ -22,8 +22,8 @@ RUN_DEPENDS= ${LOCALBASE}/bin/${LISPPORT} \
USE_XLIB= yes
USE_GMAKE= yes
-USE_AUTOMAKE= yes
-USE_AUTOCONF= yes
+USE_AUTOMAKE_VER= 14
+USE_AUTOCONF_VER= 213
CONFIGURE_ARGS+= --prefix=${PREFIX} \
--with-posix-shell=${LOCALBASE}/bin/bash \
--with-wish=${LOCALBASE}/bin/wish8.4 \
diff --git a/math/mtl/Makefile b/math/mtl/Makefile
index d1c244ac78ef..f679be2cee13 100644
--- a/math/mtl/Makefile
+++ b/math/mtl/Makefile
@@ -15,7 +15,7 @@ DISTNAME= ${PORTNAME}-2.1.2-21
MAINTAINER= ports@FreeBSD.org
COMMENT= The Matrix Template Library
-USE_AUTOCONF= yes
+USE_AUTOCONF_VER= 213
GNU_CONFIGURE= yes
NO_BUILD= yes
diff --git a/math/spar/Makefile b/math/spar/Makefile
index c78cc8c33561..e7fe94a63b61 100644
--- a/math/spar/Makefile
+++ b/math/spar/Makefile
@@ -17,7 +17,7 @@ COMMENT= A modular math parser
USE_GETOPT_LONG= yes
USE_REINPLACE= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
MAN1= spar.1