aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2007-03-06 21:59:09 +0800
committerrafan <rafan@FreeBSD.org>2007-03-06 21:59:09 +0800
commitb125a4b97100ae9a6f0d7782c9ccfcce2327f7d5 (patch)
treecacd7cbfeeeb81cb33f9eb0e16b17386f57c094a /math
parent56ae9d4d574ed31c4e4f21a44e73e5a55ee422ee (diff)
downloadfreebsd-ports-gnome-b125a4b97100ae9a6f0d7782c9ccfcce2327f7d5.tar.gz
freebsd-ports-gnome-b125a4b97100ae9a6f0d7782c9ccfcce2327f7d5.tar.zst
freebsd-ports-gnome-b125a4b97100ae9a6f0d7782c9ccfcce2327f7d5.zip
Add p5-Math-NumberCruncher 5.00, collection of useful math-related
functions. PR: ports/109964 Submitted by: chinsan
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-NumberCruncher/Makefile25
-rw-r--r--math/p5-Math-NumberCruncher/distinfo3
-rw-r--r--math/p5-Math-NumberCruncher/pkg-descr6
-rw-r--r--math/p5-Math-NumberCruncher/pkg-plist6
5 files changed, 41 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index d9c2c71d8de4..4bec0d4005b3 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -211,6 +211,7 @@
SUBDIR += p5-Math-LinearCombination
SUBDIR += p5-Math-Logic
SUBDIR += p5-Math-Matrix
+ SUBDIR += p5-Math-NumberCruncher
SUBDIR += p5-Math-Pari
SUBDIR += p5-Math-Polynomial-Solve
SUBDIR += p5-Math-Random
diff --git a/math/p5-Math-NumberCruncher/Makefile b/math/p5-Math-NumberCruncher/Makefile
new file mode 100644
index 000000000000..aa90d1ce09cf
--- /dev/null
+++ b/math/p5-Math-NumberCruncher/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: math/p5-Math-NumberCruncher
+# Date created: 2007/03/06
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-NumberCruncher
+PORTVERSION= 5.00
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Collection of useful math-related functions
+
+BUILD_DEPENDS= p5-Math-BigInt>=0:${PORTSDIR}/math/p5-Math-BigInt
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Math::NumberCruncher.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-NumberCruncher/distinfo b/math/p5-Math-NumberCruncher/distinfo
new file mode 100644
index 000000000000..121d715dd2ff
--- /dev/null
+++ b/math/p5-Math-NumberCruncher/distinfo
@@ -0,0 +1,3 @@
+MD5 (Math-NumberCruncher-5.00.tar.gz) = 42a86b1ea9d47b2413300af28ce5df9f
+SHA256 (Math-NumberCruncher-5.00.tar.gz) = 481ee17c60939060509c431d1cc701a4cfae485d68de2e7d4f70d1eae1e8df0d
+SIZE (Math-NumberCruncher-5.00.tar.gz) = 82311
diff --git a/math/p5-Math-NumberCruncher/pkg-descr b/math/p5-Math-NumberCruncher/pkg-descr
new file mode 100644
index 000000000000..8a7d7b7f0406
--- /dev/null
+++ b/math/p5-Math-NumberCruncher/pkg-descr
@@ -0,0 +1,6 @@
+Math::NumberCruncher - Collection of useful math-related functions.
+This module is a collection of commonly needed number-related functions,
+including numerous standard statistical, geometric, and probability
+functions.
+
+WWW: http://search.cpan.org/dist/Math-NumberCruncher/
diff --git a/math/p5-Math-NumberCruncher/pkg-plist b/math/p5-Math-NumberCruncher/pkg-plist
new file mode 100644
index 000000000000..1e5140b25071
--- /dev/null
+++ b/math/p5-Math-NumberCruncher/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/NumberCruncher/.packlist
+%%SITE_PERL%%/Math/NumberCruncher.pod
+%%SITE_PERL%%/Math/NumberCruncher.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/NumberCruncher
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
+@dirrmtry %%SITE_PERL%%/Math