aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2006-08-07 09:27:36 +0800
committermaho <maho@FreeBSD.org>2006-08-07 09:27:36 +0800
commitba43a1e4c320122ea7776ab37358a366d45aed1e (patch)
tree641ae81080e6b8b39d5c3f24f5f292455bde4792 /math
parent4674125d6fde487f20272047857b5a43bd7fbaa1 (diff)
downloadfreebsd-ports-gnome-ba43a1e4c320122ea7776ab37358a366d45aed1e.tar.gz
freebsd-ports-gnome-ba43a1e4c320122ea7776ab37358a366d45aed1e.tar.zst
freebsd-ports-gnome-ba43a1e4c320122ea7776ab37358a366d45aed1e.zip
Add missing dependency to atlas.
Submitted by: kris
Diffstat (limited to 'math')
-rw-r--r--math/suitesparse/Makefile13
-rw-r--r--math/ufsparse/Makefile13
2 files changed, 20 insertions, 6 deletions
diff --git a/math/suitesparse/Makefile b/math/suitesparse/Makefile
index 11d6657abc78..813d6962c56b 100644
--- a/math/suitesparse/Makefile
+++ b/math/suitesparse/Makefile
@@ -16,12 +16,19 @@ COMMENT= UFspace is a set of packages for sparse matrices calculation
BUILD_DEPENDS= ${LOCALBASE}/lib/libmetis.a:${PORTSDIR}/math/metis
+.if defined(WITH_BLAS)
+LIB_DEPENDS+= blas.1:${PORTSDIR}/math/blas
+BLAS= -L${LOCALBASE}/lib -lblas
+LAPACK= -L${LOCALBASE}/lib -llapack
+.else
+LIB_DEPENDS+= atlas.1:${PORTSDIR}/math/atlas
+BLAS= -L${LOCALBASE}/lib -lf77blas -latlas -lg2c
+LAPACK= -L${LOCALBASE}/lib -lalapack -lcblas
+.endif
+
USE_GMAKE= yes
ALL_TARGET=
-BLAS= -L${LOCALBASE}/lib -lf77blas -latlas -lg2c
-LAPACK= -L${LOCALBASE}/lib -lalapack -lcblas
-
post-patch:
@${REINPLACE_CMD} -e 's,%%CC%%,${CC},g' \
-e 's,%%CFLAGS%%,${CFLAGS},g' \
diff --git a/math/ufsparse/Makefile b/math/ufsparse/Makefile
index 11d6657abc78..813d6962c56b 100644
--- a/math/ufsparse/Makefile
+++ b/math/ufsparse/Makefile
@@ -16,12 +16,19 @@ COMMENT= UFspace is a set of packages for sparse matrices calculation
BUILD_DEPENDS= ${LOCALBASE}/lib/libmetis.a:${PORTSDIR}/math/metis
+.if defined(WITH_BLAS)
+LIB_DEPENDS+= blas.1:${PORTSDIR}/math/blas
+BLAS= -L${LOCALBASE}/lib -lblas
+LAPACK= -L${LOCALBASE}/lib -llapack
+.else
+LIB_DEPENDS+= atlas.1:${PORTSDIR}/math/atlas
+BLAS= -L${LOCALBASE}/lib -lf77blas -latlas -lg2c
+LAPACK= -L${LOCALBASE}/lib -lalapack -lcblas
+.endif
+
USE_GMAKE= yes
ALL_TARGET=
-BLAS= -L${LOCALBASE}/lib -lf77blas -latlas -lg2c
-LAPACK= -L${LOCALBASE}/lib -lalapack -lcblas
-
post-patch:
@${REINPLACE_CMD} -e 's,%%CC%%,${CC},g' \
-e 's,%%CFLAGS%%,${CFLAGS},g' \