aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-07-16 08:47:55 +0800
committermaho <maho@FreeBSD.org>2007-07-16 08:47:55 +0800
commitfc391090df48585af257922fc2801befb3add809 (patch)
tree2dfad924b361ac579be6408855a6c1d07dca30e5 /math
parent812a6f7ef585371609e7d8699084893fd7a728c9 (diff)
downloadfreebsd-ports-gnome-fc391090df48585af257922fc2801befb3add809.tar.gz
freebsd-ports-gnome-fc391090df48585af257922fc2801befb3add809.tar.zst
freebsd-ports-gnome-fc391090df48585af257922fc2801befb3add809.zip
Now we use USE_FORTRAN=yes to use FORTRAN compiler.
Diffstat (limited to 'math')
-rw-r--r--math/octave/Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/math/octave/Makefile b/math/octave/Makefile
index 4b181fcb5539..195478d88ba7 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -34,10 +34,7 @@ OCTAVE_VERSION= ${PORTVERSION}
GNU_HOST= ${ARCH}-portbld-freebsd${OSREL}
PLIST_SUB= OCTAVE_VERSION=${OCTAVE_VERSION} GNU_HOST=${GNU_HOST}
-WANT_FORTRAN=yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \