aboutsummaryrefslogtreecommitdiffstats
path: root/mbone/vic
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2007-03-26 13:48:58 +0800
committermi <mi@FreeBSD.org>2007-03-26 13:48:58 +0800
commit5e6189b11958d301953fda4abb1521153830644b (patch)
tree7702a6586ba791dd3b0d2d86214a5a59a78845e5 /mbone/vic
parentde7581d68d00b3a4d4b3658c477f1a2eda3d1611 (diff)
downloadfreebsd-ports-gnome-5e6189b11958d301953fda4abb1521153830644b.tar.gz
freebsd-ports-gnome-5e6189b11958d301953fda4abb1521153830644b.tar.zst
freebsd-ports-gnome-5e6189b11958d301953fda4abb1521153830644b.zip
Add a patch to fix a harmless warning, which breaks this port under
the stricter g++42 (and 41): Prodded by: kris While here switch to USE_TK and make -with-ipv6 conditional on the NO_INET6 being undefined.
Diffstat (limited to 'mbone/vic')
-rw-r--r--mbone/vic/Makefile15
-rw-r--r--mbone/vic/files/patch-warns9
2 files changed, 18 insertions, 6 deletions
diff --git a/mbone/vic/Makefile b/mbone/vic/Makefile
index 92a1a4825342..d1ad10b8651f 100644
--- a/mbone/vic/Makefile
+++ b/mbone/vic/Makefile
@@ -16,18 +16,21 @@ COMMENT= MBONE video tool
BUILD_DEPENDS+= v4l_compat>=1.0.20060801:${PORTSDIR}/multimedia/v4l_compat
-LIB_DEPENDS= tk84:${PORTSDIR}/x11-toolkits/tk84 \
- uclmmbase:${PORTSDIR}/devel/uclmmbase
+LIB_DEPENDS= uclmmbase:${PORTSDIR}/devel/uclmmbase
+USE_TK= yes
+USE_TK_BUILD= yes
USE_AUTOTOOLS= autoconf:213
USE_X_PREFIX= yes
-CONFIGURE_ARGS= -x-libraries=${PREFIX}/lib \
- -x-includes=${PREFIX}/include \
+CONFIGURE_ARGS= -x-libraries=${X11BASE}/lib \
+ -x-includes=${X11BASE}/include \
-without-ucltcl \
-with-tcl=${LOCALBASE} \
-without-ucltk \
- -with-tk=${LOCALBASE} \
- -enable-ipv6
+ -with-tk=${LOCALBASE}
+.ifndef (NO_INET6)
+CONFIGURE_ARGS+=-enable-ipv6
+.endif
MAN1= vic.1
post-patch:
diff --git a/mbone/vic/files/patch-warns b/mbone/vic/files/patch-warns
new file mode 100644
index 000000000000..8db7f714fc0a
--- /dev/null
+++ b/mbone/vic/files/patch-warns
@@ -0,0 +1,9 @@
+--- codec/p64/p64.cpp Thu Sep 9 08:46:10 1999
++++ codec/p64/p64.cpp Mon Mar 26 01:44:44 2007
+@@ -1069,5 +1069,5 @@
+ * with 8 bits; otherwise, prime it with a 16.
+ */
+- if ((int)bp & 1) {
++ if ((intptr_t)bp & 1) {
+ bs_ = (u_short*)(bp + 1);
+ bb_ = *bp;