aboutsummaryrefslogtreecommitdiffstats
path: root/mbone
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2005-11-15 14:52:12 +0800
committerade <ade@FreeBSD.org>2005-11-15 14:52:12 +0800
commit8d9d5197561118544281733430b48b0b60884450 (patch)
tree45e5dcd7c2206fce8b01186555aac96b6292c602 /mbone
parent081b17449bd91bcac5390cd0d8a63ed3914df51d (diff)
downloadfreebsd-ports-gnome-8d9d5197561118544281733430b48b0b60884450.tar.gz
freebsd-ports-gnome-8d9d5197561118544281733430b48b0b60884450.tar.zst
freebsd-ports-gnome-8d9d5197561118544281733430b48b0b60884450.zip
Mass-conversion to the USE_AUTOTOOLS New World Order. The code present
in bsd.autotools.mk essentially makes this a no-op given that all the old variables set a USE_AUTOTOOLS_COMPAT variable, which is parsed in exactly the same way as USE_AUTOTOOLS itself. Moreover, USE_AUTOTOOLS has already been extensively tested by the GNOME team -- all GNOME 2.12.x ports use it. Preliminary documentation can be found at: http://people.FreeBSD.org/~ade/autotools.txt which is in the process of being SGMLized before introduction into the Porters Handbook. Light blue touch-paper. Run.
Diffstat (limited to 'mbone')
-rw-r--r--mbone/rat/Makefile2
-rw-r--r--mbone/rtpmon/Makefile2
-rw-r--r--mbone/vat/Makefile2
-rw-r--r--mbone/vic/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/mbone/rat/Makefile b/mbone/rat/Makefile
index 8481e1c1916d..d6597db03a45 100644
--- a/mbone/rat/Makefile
+++ b/mbone/rat/Makefile
@@ -19,7 +19,7 @@ COMMENT= IPv4/v6 Multicast and unicast audio conferencing tool
TCLTK_VERSION= 8.3
LIB_DEPENDS= tk83.1:${PORTSDIR}/x11-toolkits/tk83
-USE_AUTOCONF_VER= 213
+USE_AUTOTOOLS= autoconf:213
USE_GMAKE= yes
MAN1= rat.1
MANCOMPRESSED= no
diff --git a/mbone/rtpmon/Makefile b/mbone/rtpmon/Makefile
index 279f43f848cf..b09d58e47664 100644
--- a/mbone/rtpmon/Makefile
+++ b/mbone/rtpmon/Makefile
@@ -16,7 +16,7 @@ COMMENT= A program to montior loss in multicast sessions
LIB_DEPENDS= tk83.1:${PORTSDIR}/x11-toolkits/tk83
-WANT_AUTOCONF_VER=253
+USE_AUTOTOOLS= autoconf:253:env
GNU_CONFIGURE= yes
USE_X_PREFIX= yes
MAN1= rtpmon.1
diff --git a/mbone/vat/Makefile b/mbone/vat/Makefile
index 97ca722aaf4a..dcabef94cc45 100644
--- a/mbone/vat/Makefile
+++ b/mbone/vat/Makefile
@@ -26,7 +26,7 @@ LIB_DEPENDS= tk83.1:${PORTSDIR}/x11-toolkits/tk83 \
gsm.1:${GSM_DIR}
USE_X_PREFIX= yes
-USE_AUTOCONF_VER= 213
+USE_AUTOTOOLS= autoconf:213
CONFIGURE_ARGS= --with-gsm=${GSM_WORK}
INSTALL_TARGET= install install-man
MAN1= vat.1
diff --git a/mbone/vic/Makefile b/mbone/vic/Makefile
index 06531c477491..89d3cf2b20f6 100644
--- a/mbone/vic/Makefile
+++ b/mbone/vic/Makefile
@@ -17,7 +17,7 @@ COMMENT= MBONE video tool
LIB_DEPENDS= tk84:${PORTSDIR}/x11-toolkits/tk84 \
uclmmbase:${PORTSDIR}/devel/uclmmbase
-USE_AUTOCONF_VER= 213
+USE_AUTOTOOLS= autoconf:213
USE_X_PREFIX= yes
CONFIGURE_ARGS= -x-libraries=${PREFIX}/lib \
-x-includes=${PREFIX}/include \