aboutsummaryrefslogtreecommitdiffstats
path: root/misc/41upgrade
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>2000-08-25 18:23:15 +0800
committerasami <asami@FreeBSD.org>2000-08-25 18:23:15 +0800
commit9725ab64e61688be220c3886e1a102489e02ec88 (patch)
tree43d2761a31d573fa129c888c21cf6e1a182590b9 /misc/41upgrade
parentb5520255daa6e704a9ab708867ab3379bda185c0 (diff)
downloadfreebsd-ports-gnome-9725ab64e61688be220c3886e1a102489e02ec88.tar.gz
freebsd-ports-gnome-9725ab64e61688be220c3886e1a102489e02ec88.tar.zst
freebsd-ports-gnome-9725ab64e61688be220c3886e1a102489e02ec88.zip
New port 41upgrade, a 4.1-release to 4-stable upgrade kit.
Diffstat (limited to 'misc/41upgrade')
-rw-r--r--misc/41upgrade/Makefile36
-rw-r--r--misc/41upgrade/pkg-comment1
-rw-r--r--misc/41upgrade/pkg-descr5
-rw-r--r--misc/41upgrade/pkg-install5
-rw-r--r--misc/41upgrade/pkg-plist1
-rw-r--r--misc/41upgrade/pkg-req5
6 files changed, 53 insertions, 0 deletions
diff --git a/misc/41upgrade/Makefile b/misc/41upgrade/Makefile
new file mode 100644
index 000000000000..0d0c6030cce9
--- /dev/null
+++ b/misc/41upgrade/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: 4.1R to 4-stable upgrade kit
+# Date created: 25 Aug 2000
+# Whom: asami
+#
+# $FreeBSD$
+#
+
+PORTNAME= 41upgrade
+PORTVERSION= 2000.08.25
+CATEGORIES= misc
+DISTFILES= # empty
+
+MAINTAINER= asami@FreeBSD.org
+
+.include <bsd.port.pre.mk>
+
+.if !defined(PACKAGE_BUILDING)
+BROKEN= this \"port\" is for building packages for distribution only, please get the package from http://www.freebsd.org/ports/ if you need an upgrade
+.elif ${OSVERSION} < 410000 || ${OSVERSION} >= 500000
+FORBIDDEN= this needs to be built on a recent 4-stable system
+.endif
+NO_MTREE= yes
+PREFIX= /
+NO_BUILD= yes
+PKGINSTALL= ${WRKDIR}/INSTALL
+DATE!= cat /var/db/port.mkversion
+
+do-install:
+ ${SED} -e "s/%%VERSION%%/${DATE}/" ${PKGDIR}/INSTALL \
+ > ${PKGINSTALL}
+
+deinstall:
+ @${ECHO} "You can't delete this port."
+ @${FALSE}
+
+.include <bsd.port.post.mk>
diff --git a/misc/41upgrade/pkg-comment b/misc/41upgrade/pkg-comment
new file mode 100644
index 000000000000..abd495e9a42d
--- /dev/null
+++ b/misc/41upgrade/pkg-comment
@@ -0,0 +1 @@
+A convenience package to upgrade your 4.1 system to 4-stable for ports
diff --git a/misc/41upgrade/pkg-descr b/misc/41upgrade/pkg-descr
new file mode 100644
index 000000000000..d9cf2f28873f
--- /dev/null
+++ b/misc/41upgrade/pkg-descr
@@ -0,0 +1,5 @@
+This package will allow you to upgrade your 4.1R system to
+4-stable, so you can compile and use all ports in ports-current.
+
+Satoshi
+asami@freebsd.org
diff --git a/misc/41upgrade/pkg-install b/misc/41upgrade/pkg-install
new file mode 100644
index 000000000000..8ed8de67d62f
--- /dev/null
+++ b/misc/41upgrade/pkg-install
@@ -0,0 +1,5 @@
+#!/bin/sh
+if [ "$2" != "PRE-INSTALL" ]; then
+ exit 0
+fi
+echo %%VERSION%% > /var/db/port.mkversion
diff --git a/misc/41upgrade/pkg-plist b/misc/41upgrade/pkg-plist
new file mode 100644
index 000000000000..d3fa9b81c1c4
--- /dev/null
+++ b/misc/41upgrade/pkg-plist
@@ -0,0 +1 @@
+etc/mtree/BSD.x11-4.dist
diff --git a/misc/41upgrade/pkg-req b/misc/41upgrade/pkg-req
new file mode 100644
index 000000000000..1eb81c651314
--- /dev/null
+++ b/misc/41upgrade/pkg-req
@@ -0,0 +1,5 @@
+#!/bin/sh
+if [ $2 = "DEINSTALL" ]; then
+ echo "Package $1 cannot be removed -- to do so will render your system useless."
+ exit 1
+fi