aboutsummaryrefslogtreecommitdiffstats
path: root/misc/afbackup
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-01-29 19:48:57 +0800
committerknu <knu@FreeBSD.org>2002-01-29 19:48:57 +0800
commit5b243306947e74184be0fc39cd0f0d1eb8063940 (patch)
treecea3c8a6099c3422b99712692a2c3e0e2964a6d2 /misc/afbackup
parentf6e00c6523a54ccae8d9221d4c43c1bebbe1592d (diff)
downloadfreebsd-ports-gnome-5b243306947e74184be0fc39cd0f0d1eb8063940.tar.gz
freebsd-ports-gnome-5b243306947e74184be0fc39cd0f0d1eb8063940.tar.zst
freebsd-ports-gnome-5b243306947e74184be0fc39cd0f0d1eb8063940.zip
Use ${ECHO_CMD} instead of ${ECHO} where you mean the echo command;
the ECHO macro is set to "echo" by default, but it is set to "true" if make(1) is invoked with the -s option while ECHO_CMD is always set to the echo command.
Diffstat (limited to 'misc/afbackup')
-rw-r--r--misc/afbackup/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/misc/afbackup/Makefile b/misc/afbackup/Makefile
index 630f4ea6cd7c..4392d06e97cb 100644
--- a/misc/afbackup/Makefile
+++ b/misc/afbackup/Makefile
@@ -162,14 +162,14 @@ pre-install:
@${ECHO} "==> Creating custom pkg-plist..."
@${RM} -rf ${PLIST}
.if !defined(NOPORTDOCS)
- @for docfile in $(AFBACKUP_DOCS:S/^/share\/doc\/${PORTNAME}\//); do ${ECHO} $$docfile >>${PLIST}; done
+ @for docfile in $(AFBACKUP_DOCS:S/^/share\/doc\/${PORTNAME}\//); do ${ECHO_CMD} $$docfile >>${PLIST}; done
.endif
@for plistfile in ${PLIST_SRC}; do ${CAT} ${FILESDIR}/$$plistfile >>${PLIST}; done
@${CAT} ${PLIST} | perl -nle 'print unless $$lines{$$_}++' >${PLIST}.tmp
@${CAT} ${PLIST}.tmp ${FILESDIR}/pkg-plist.fixedorder >${PLIST}
.if !defined(NOPORTDOCS)
- @${ECHO} @cwd ${PREFIX} >>${PLIST}
- @${ECHO} @dirrm share/doc/${PORTNAME} >>${PLIST}
+ @${ECHO_CMD} @cwd ${PREFIX} >>${PLIST}
+ @${ECHO_CMD} @dirrm share/doc/${PORTNAME} >>${PLIST}
.endif
@$(PKGINSTALL_ENV) ${PKGINSTALL} ${PKGNAME} PRE-INSTALL