aboutsummaryrefslogtreecommitdiffstats
path: root/misc/alevt
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2005-05-25 19:47:57 +0800
committeroliver <oliver@FreeBSD.org>2005-05-25 19:47:57 +0800
commit2d20f27fdffe9944ed7d5a630f5c6af19bff3241 (patch)
tree2e9b5e8a822c7c713205b291d164fbb1fdcd3c54 /misc/alevt
parenta7943690656a64d80f1028a5262ecf5850e13bc6 (diff)
downloadfreebsd-ports-gnome-2d20f27fdffe9944ed7d5a630f5c6af19bff3241.tar.gz
freebsd-ports-gnome-2d20f27fdffe9944ed7d5a630f5c6af19bff3241.tar.zst
freebsd-ports-gnome-2d20f27fdffe9944ed7d5a630f5c6af19bff3241.zip
make png support optional (on by default)
add an option to make alevt use a smaller font (off by default)
Diffstat (limited to 'misc/alevt')
-rw-r--r--misc/alevt/Makefile16
-rw-r--r--misc/alevt/files/patch-aa25
2 files changed, 33 insertions, 8 deletions
diff --git a/misc/alevt/Makefile b/misc/alevt/Makefile
index 5606de055c5e..01a8c576410e 100644
--- a/misc/alevt/Makefile
+++ b/misc/alevt/Makefile
@@ -14,9 +14,21 @@ MASTER_SITES= http://www.goron.de/~froese/alevt/
MAINTAINER= ports@FreeBSD.org
COMMENT= X11 Teletext decoding and display program. (reads from /dev/vbi)
-LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+OPTIONS= PNG "export pages as png image" on \
+ SMALLFONT "use a smaller and thiner font" off
USE_X_PREFIX= yes
MAN1= alevt.1x alevt-date.1 alevt-cap.1
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PNG)
+LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
+MAKE_ARGS+= -DWITH_PNG
+.endif
+
+.if defined(WITH_SMALLFONT)
+MAKE_ARGS+= -DWITH_SMALLFONT
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/misc/alevt/files/patch-aa b/misc/alevt/files/patch-aa
index 0ad37c0c9d7d..ca72d5d979a8 100644
--- a/misc/alevt/files/patch-aa
+++ b/misc/alevt/files/patch-aa
@@ -1,12 +1,25 @@
--- Makefile.orig Tue Aug 20 05:17:53 2002
-+++ Makefile Wed May 25 12:15:57 2005
-@@ -6,28 +6,26 @@
- # a smaller and thinner font
- #FONT=neep9
++++ Makefile Wed May 25 13:41:55 2005
+@@ -1,33 +1,35 @@
+ VER=1.6.1
+-OPT=-O2 -s
+-#OPT=-O -g
++
++.if defined(WITH_PNG)
+ DEFS=-DWITH_PNG
++PNG_LIBS=-L${LOCALBASE}/lib -lpng -lz -lm
++.endif
++
++.if defined(WITH_SMALLFONT)
++FONT=neep9
++.else
+ FONT=vtxt
+-# a smaller and thinner font
+-#FONT=neep9
++.endif
-CFLAGS=$(OPT) -DVERSION=\"$(VER)\" $(DEFS) -I/usr/X11R6/include -I/usr/local/include -W
+CFLAGS+=-DVERSION=\"$(VER)\" $(DEFS) -I${X11BASE}/include -I${LOCALBASE}/include -W
-+PNG_LIBS=-L${LOCALBASE}/lib -lpng -lz -lm
+X11_LIBS=-L${X11BASE}/lib -lX11
EXPOBJS=export.o exp-txt.o exp-html.o exp-gfx.o font.o
@@ -35,7 +48,7 @@
font.o: font1.xbm font2.xbm
fontsize.h: font1.xbm font2.xbm
-@@ -69,13 +67,9 @@
+@@ -69,13 +71,9 @@
# anything below this line is just for me!
install: all