aboutsummaryrefslogtreecommitdiffstats
path: root/misc/amanda25-server/Makefile
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2005-10-14 23:40:16 +0800
committermnag <mnag@FreeBSD.org>2005-10-14 23:40:16 +0800
commit3625011c7b60ca780d520dd9e7df2cbdefc07cb5 (patch)
tree56733a1ff3b0c15ea1283cf9d87a1255dd15867c /misc/amanda25-server/Makefile
parent7a2f59aff1053136dd983dc02a08d67471f9d741 (diff)
downloadfreebsd-ports-gnome-3625011c7b60ca780d520dd9e7df2cbdefc07cb5.tar.gz
freebsd-ports-gnome-3625011c7b60ca780d520dd9e7df2cbdefc07cb5.tar.zst
freebsd-ports-gnome-3625011c7b60ca780d520dd9e7df2cbdefc07cb5.zip
Add archivers/gtar dependencies
Bump PORTREVISION Fix pkg-plist Make portlint happyer PR: 87426 Notified by: Patrick M. Hausen <hausen@punkt.de>
Diffstat (limited to 'misc/amanda25-server/Makefile')
-rw-r--r--misc/amanda25-server/Makefile19
1 files changed, 13 insertions, 6 deletions
diff --git a/misc/amanda25-server/Makefile b/misc/amanda25-server/Makefile
index 4f1c4680d7d0..60147fec978a 100644
--- a/misc/amanda25-server/Makefile
+++ b/misc/amanda25-server/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= ${MASTERPORTNAME}
PORTVERSION= 2.4.5
-PORTREVISION?= 1
+PORTREVISION?= 2
PORTEPOCH= 1
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -70,15 +70,18 @@ pre-fetch:
USE_PERL5= yes
-RUN_DEPENDS= ${LOCALBASE}/sbin/amrecover:${PORTSDIR}/misc/amanda-client
-BUILD_DEPENDS= ${LOCALBASE}/sbin/amrecover:${PORTSDIR}/misc/amanda-client
+BUILD_DEPENDS+= ${LOCALBASE}/sbin/amrecover:${PORTSDIR}/misc/amanda-client \
+ ${LOCALBASE}/bin/gtar:${PORTSDIR}/archivers/gtar
+RUN_DEPENDS+= ${LOCALBASE}/sbin/amrecover:${PORTSDIR}/misc/amanda-client \
+ ${LOCALBASE}/bin/gtar:${PORTSDIR}/archivers/gtar
CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
--with-amandahosts --with-fqdn \
--with-dump-honor-nodump --with-buffered-dump \
--without-client --disable-libtool --prefix=${PREFIX} \
--with-user=${AMANDA_USER} --with-group=${AMANDA_GROUP} \
- --with-gnutar-listdir=${AMANDA_GNUTAR_LISTDIR}
+ --with-gnutar-listdir=${AMANDA_GNUTAR_LISTDIR} \
+ --with-gnutar=${LOCALBASE}/bin/gtar
MAN8= amadmin.8 amcheck.8 amcheckdb.8 amcleanup.8 amdd.8 \
amdump.8 amflush.8 amgetconf.8 amlabel.8 ammt.8 \
@@ -131,7 +134,7 @@ CONFIGURE_ARGS+= --with-portrange=${AMANDA_PORTRANGE}
.if ${OSVERSION} < 400000
PLIST_SUB+= SCSICHG=''
.elif ${OSVERSION} >= 480000
-.if ${MACHINE_ARCH} == "amd64"
+.if ${ARCH} == "amd64"
PLIST_SUB+= SCSICHG='@comment '
.elif ${OSVERSION} >= 502000
PLIST_SUB+= SCSICHG='@comment '
@@ -170,12 +173,16 @@ pre-fetch:
@${ECHO} " The default is no restriction on UDP ports."
@${ECHO} ""
+BUILD_DEPENDS+= ${LOCALBASE}/bin/gtar:${PORTSDIR}/archivers/gtar
+RUN_DEPENDS+= ${LOCALBASE}/bin/gtar:${PORTSDIR}/archivers/gtar
+
CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
--with-amandahosts --with-fqdn \
--with-dump-honor-nodump --with-buffered-dump \
--without-server --disable-libtool --prefix=${PREFIX} \
--with-user=${AMANDA_USER} --with-group=${AMANDA_GROUP} \
- --with-gnutar-listdir=${AMANDA_GNUTAR_LISTDIR}
+ --with-gnutar-listdir=${AMANDA_GNUTAR_LISTDIR} \
+ --with-gnutar=${LOCALBASE}/bin/gtar
MAN8= amanda.8 amrecover.8 amrestore.8