aboutsummaryrefslogtreecommitdiffstats
path: root/misc/amanda32-server/Makefile
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2010-12-03 23:15:39 +0800
committerkuriyama <kuriyama@FreeBSD.org>2010-12-03 23:15:39 +0800
commit84317d7356fbc13b836a6235ee5e970772af7d0b (patch)
tree11f6dc88830079978b56b9525682b67ec09ae86a /misc/amanda32-server/Makefile
parent7154fd37f779c8f908a9ace523808ec0f86339a6 (diff)
downloadfreebsd-ports-gnome-84317d7356fbc13b836a6235ee5e970772af7d0b.tar.gz
freebsd-ports-gnome-84317d7356fbc13b836a6235ee5e970772af7d0b.tar.zst
freebsd-ports-gnome-84317d7356fbc13b836a6235ee5e970772af7d0b.zip
- Amanda/Constants.pm is installed by amanda-client, and it includes
constat variable as of client components only. When amanda-server installed, Constants.pm should include also server components. - To work around it, use pkg-install/pkg-deinstall script to tweak this variable by inplace updating. Reported by: Christian Gusenbauer <c47g@gmx.at>
Diffstat (limited to 'misc/amanda32-server/Makefile')
-rw-r--r--misc/amanda32-server/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/misc/amanda32-server/Makefile b/misc/amanda32-server/Makefile
index 2cef20aa58da..b2cf3119d38e 100644
--- a/misc/amanda32-server/Makefile
+++ b/misc/amanda32-server/Makefile
@@ -7,7 +7,7 @@
PORTNAME= amanda
PORTVERSION= 3.2.0
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= misc
MASTER_SITES= SF/amanda/amanda%20-%20stable/${PORTVERSION}
@@ -78,6 +78,9 @@ RUN_DEPENDS+= gtar:${PORTSDIR}/archivers/gtar
# amanda-server part
.if !defined(CLIENT_ONLY)
+SUB_FILES+= pkg-install pkg-deinstall
+SUB_LIST+= PERL=${PERL} SITE_PERL_REL=${SITE_PERL_REL}
+
pre-everything::
.if defined(AMANDA_TAPE)
@${ECHO} "Use of \$AMANDA_TAPE is deprecated. Specify it in amanda.conf."
@@ -158,7 +161,8 @@ PLIST_SUB+= S3DEVICE='@comment '
.endif
post-install:
- ${CAT} ${PKGMESSAGE}
+ @${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${CAT} ${PKGMESSAGE}
# amanda-client part
.else