aboutsummaryrefslogtreecommitdiffstats
path: root/misc/amanda32-server/Makefile
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2010-11-01 22:21:26 +0800
committerkuriyama <kuriyama@FreeBSD.org>2010-11-01 22:21:26 +0800
commit85d5f7ae5014a2d5a5ad75aa9f43861baf741e06 (patch)
tree5cb6a0353ca874d75e4e3e9495b0ebb841b95bc2 /misc/amanda32-server/Makefile
parent408eead1ddf44887fa39b933d4cb1c7969eb87c6 (diff)
downloadfreebsd-ports-gnome-85d5f7ae5014a2d5a5ad75aa9f43861baf741e06.tar.gz
freebsd-ports-gnome-85d5f7ae5014a2d5a5ad75aa9f43861baf741e06.tar.zst
freebsd-ports-gnome-85d5f7ae5014a2d5a5ad75aa9f43861baf741e06.zip
Finally upgrade amanda-{server,client} to 3.2.0. Old 2.6.x was
repocopied as amanda26-{server,client}. Please stay in 2.6.x branch if you are conservative. Yes, you should so for important infrastructre like as backup system :-). New 3.2.0 port includes: - Use misc/amanda-perl-wrapper as perl5 interpreter which is linked with libthr.so to avoid thread problem. - Unique UID, GID assigned and use it by default. amanda user/group will be added automatically when not exist. - Deprecate AMANDA_{CONFIG,TAPE} port knobs. They can be set in runtime config easily. References: http://wiki.zmanda.com/index.php/3.2_features
Diffstat (limited to 'misc/amanda32-server/Makefile')
-rw-r--r--misc/amanda32-server/Makefile122
1 files changed, 59 insertions, 63 deletions
diff --git a/misc/amanda32-server/Makefile b/misc/amanda32-server/Makefile
index 0de2c48af5f9..9fd6719e8e84 100644
--- a/misc/amanda32-server/Makefile
+++ b/misc/amanda32-server/Makefile
@@ -6,16 +6,19 @@
#
PORTNAME= amanda
-PORTVERSION= 2.6.1p2
-PORTREVISION= 2
+PORTVERSION= 3.2.0
PORTEPOCH= 1
CATEGORIES= misc
MASTER_SITES= SF/amanda/amanda%20-%20stable/${PORTVERSION}
+DISTNAME= ${PORTNAME}-${PORTVERSION}
PKGNAMESUFFIX?= -server
MAINTAINER= kuriyama@FreeBSD.org
COMMENT?= The Advanced Maryland Automatic Network Disk Archiver (server)
+RUN_DEPENDS= perl-amanda:${PORTSDIR}/misc/amanda-perl-wrapper
+BUILD_DEPENDS= perl-amanda:${PORTSDIR}/misc/amanda-perl-wrapper
+
WRKSRC= ${WRKDIR}/amanda-${PORTVERSION}
SLAVEDIRS= misc/amanda-client
@@ -24,26 +27,36 @@ GNU_CONFIGURE= yes
USE_GNOME= pkgconfig glib20
USE_GMAKE= yes
USE_OPENSSL= yes
-PATCH_STRIP=
+USE_LDCONFIG= yes
+USE_PERL5= yes
CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
--without-amlibexecdir \
--with-amandahosts --with-fqdn \
- --with-dump-honor-nodump --with-buffered-dump \
+ --with-dump-honor-nodump \
--prefix=${PREFIX} \
--disable-glibtest \
- --with-user=${AMANDA_USER} --with-group=${AMANDA_GROUP} \
+ --with-user=${USERS} --with-group=${GROUPS} \
--with-bsdtcp-security --with-bsdudp-security \
--with-ssh-security
-
-USE_LDCONFIG= yes
-USE_PERL5= yes
+CONFIGURE_ENV= PERL=${LOCALBASE}/bin/perl-amanda
+PKG_MESSAGE= ${WRKDIR}/pkg-message
+SUB_FILES= pkg-message
+SUB_LIST= PORTSDIR=${PORTSDIR}
OPTIONS= GNUTAR "use GNU tar" on
.include <bsd.port.pre.mk>
-AMANDA_USER?= operator
-AMANDA_GROUP?= operator
+.if defined(AMANDA_USER)
+USERS= ${AMANDA_USER}
+.else
+USERS?= amanda
+.endif
+.if defined(AMANDA_GROUP)
+GROUPS= ${AMANDA_GROUP}
+.else
+GROUPS?= amanda
+.endif
AMANDA_GNUTAR_LISTDIR?= ${PREFIX}/var/amanda/gnutar-lists
AMANDA_DATES?= ${PREFIX}/var/amanda/amandates
PLIST_SUB= SHLIBVER=${PORTVERSION} AMANDA_DATES=${AMANDA_DATES}
@@ -54,38 +67,40 @@ CONFIGURE_ARGS+= --with-index-server=${AMANDA_SERVER}
CONFIGURE_ARGS+= --with-tape-server=${AMANDA_SERVER}
.endif
-.if defined (AMANDA_CONFIG)
-CONFIGURE_ARGS+= --with-config=${AMANDA_CONFIG}
-.endif
-
.if !defined(WITHOUT_GNUTAR)
CONFIGURE_ARGS+=--with-gnutar-listdir=${AMANDA_GNUTAR_LISTDIR} \
--with-gnutar=${LOCALBASE}/bin/gtar
-BUILD_DEPENDS= gtar:${PORTSDIR}/archivers/gtar
-RUN_DEPENDS= gtar:${PORTSDIR}/archivers/gtar
+BUILD_DEPENDS+= gtar:${PORTSDIR}/archivers/gtar
+RUN_DEPENDS+= gtar:${PORTSDIR}/archivers/gtar
.endif
# amanda-server part
.if !defined(CLIENT_ONLY)
+pre-everything::
+.if defined(AMANDA_TAPE)
+ @${ECHO} "Use of \$AMANDA_TAPE is deprecated. Specify it in amanda.conf."
+ exit 1
+.endif
+.if defined(AMANDA_CONFIG)
+ @${ECHO} "Use of \$AMANDA_CONFIG is deprecated. Specify it in amanda.conf."
+ exit 1
+.endif
+
pre-fetch:
@${ECHO} ""
@${ECHO} "You may use the following build options:"
@${ECHO} ""
@${ECHO} " AMANDA_SERVER=server to specify a server name"
@${ECHO} " The default is `uname -n`"
- @${ECHO} " AMANDA_TAPE=tape to specify the default tape device"
- @${ECHO} " The default is /dev/nrsa0"
- @${ECHO} " AMANDA_CONFIG=config to specify the default configuration"
- @${ECHO} " The default is DailySet1"
@${ECHO} " AMANDA_USER=user to specify the default user"
- @${ECHO} " The default is operator"
+ @${ECHO} " The default is amanda"
@${ECHO} " AMANDA_GROUP=group to specify the default group"
- @${ECHO} " The default is operator"
+ @${ECHO} " The default is amanda"
@${ECHO} " AMANDA_DATES=path to client amandates file"
@${ECHO} ""
-CONFLICTS= amanda-server-2.5.*
+CONFLICTS= amanda-server-2.5.* amanda-server-2.6.*
BUILD_DEPENDS+= ${LOCALBASE}/lib/amanda/libamandad-${PORTVERSION}.so:${PORTSDIR}/misc/amanda-client
RUN_DEPENDS+= ${LOCALBASE}/lib/amanda/libamandad-${PORTVERSION}.so:${PORTSDIR}/misc/amanda-client
@@ -95,7 +110,9 @@ CONFIGURE_ARGS+=--without-client
MAN5= disklist.5 \
tapelist.5
MAN7= amanda-changers.7 \
- amanda-devices.7
+ amanda-compatibility.7 \
+ amanda-devices.7 \
+ amanda-taperscan.7
MAN8= amaddclient.8 amadmin.8 amaespipe.8 amcheck.8 \
amcheckdb.8 amcheckdump.8 amcleanup.8 \
amcrypt.8 amcryptsimple.8 amcrypt-ossl-asym.8 amcrypt-ossl.8 \
@@ -109,8 +126,6 @@ MAN8= amaddclient.8 amadmin.8 amaespipe.8 amcheck.8 \
OPTIONS+= PLOT "enable ploting, requires X11 libraries" off\
SAMBA "enable the use of smbclient" off \
- MTX "enable the use of mtx changer scripts" off \
- AESPIPE "enable encryption. Needed by amcrypt" off \
S3 "enable Amazon S3 device support" off
.if defined (WITH_PLOT)
@@ -131,16 +146,6 @@ RUN_DEPENDS+= smbclient:${PORTSDIR}/net/${SAMBA_PORT}
CONFIGURE_ARGS+= --with-smbclient=${PREFIX}/bin/smbclient
.endif
-.if defined (WITH_MTX)
-BUILD_DEPENDS+= mtx:${PORTSDIR}/misc/mtx
-RUN_DEPENDS+= mtx:${PORTSDIR}/misc/mtx
-.endif
-
-.if defined (WITH_AESPIPE)
-RUN_DEPENDS+= aespipe:${PORTSDIR}/security/aespipe
-.else
-.endif
-
# If configure founds libcurl, automatically enabled it (with plist change).
.if defined(WITH_S3)
LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
@@ -151,34 +156,35 @@ CONFIGURE_ARGS+= --disable-s3-device
PLIST_SUB+= S3DEVICE='@comment '
.endif
-.if defined (AMANDA_TAPE)
-CONFIGURE_ARGS+= --with-tape-device=${AMANDA_TAPE}
-.endif
+post-install:
+ ${CAT} ${PKGMESSAGE}
# amanda-client part
.else
+pre-everything::
+.if defined(AMANDA_CONFIG)
+ @${ECHO} "Use of \$AMANDA_CONFIG is deprecated. Specify it in amanda.conf."
+ exit 1
+.endif
+
pre-fetch:
@${ECHO} ""
@${ECHO} "You may use the following build options:"
@${ECHO} ""
@${ECHO} " AMANDA_SERVER=server to specify a server name"
@${ECHO} " The default is `uname -n`"
- @${ECHO} " AMANDA_CONFIG=config to specify the default configuation"
- @${ECHO} " The default is DailySet1"
@${ECHO} " AMANDA_GNUTAR_LISTDIR=dir to specify the directory that"
@${ECHO} " the gnutar index files should live in"
@${ECHO} " The default is ${PREFIX}/var/amanda/gnutar-lists"
@${ECHO} " AMANDA_USER=user to specify the default user"
- @${ECHO} " The default is operator"
+ @${ECHO} " The default is amanda"
@${ECHO} " AMANDA_GROUP=group to specify the default group"
- @${ECHO} " The default is operator"
+ @${ECHO} " The default is amanda"
@${ECHO} " AMANDA_DATES=path to client amandates file"
@${ECHO} ""
-OPTIONS+= ZFSCOMP "accurate estimation of compressed ZFS filesystems" off
-
-CONFLICTS= amanda-client-2.5.*
+CONFLICTS= amanda-client-2.5.* amanda-client-2.6.*
CONFIGURE_ARGS+=--without-server --with-amandates=${AMANDA_DATES}
MAN5= amanda-archive-format.5 \
@@ -186,43 +192,33 @@ MAN5= amanda-archive-format.5 \
amanda.conf.5
MAN7= amanda-applications.7 \
amanda-auth.7 \
+ amanda-match.7 \
amanda-scripts.7
MAN8= amanda.8 \
amarchiver.8 \
amgtar.8 \
+ ampgsql.8 \
+ amraw.8 \
amrecover.8 \
amsamba.8 \
amstar.8 \
+ amsuntar.8 \
amzfs-sendrecv.8 \
amzfs-snapshot.8 \
script-email.8
post-install:
-.ifndef(NOPORTDOCS)
- ${MKDIR} ${EXAMPLESDIR}
- ${CP} -R ${WRKSRC}/example/chg-multi.conf \
- ${WRKSRC}/example/chg-scsi.conf \
- ${WRKSRC}/example/disklist \
- ${EXAMPLESDIR}
-.endif
${MKDIR} ${AMANDA_GNUTAR_LISTDIR}
- ${CHOWN} ${AMANDA_USER}:${AMANDA_GROUP} ${AMANDA_GNUTAR_LISTDIR}
+ ${CHOWN} ${USERS}:${GROUPS} ${AMANDA_GNUTAR_LISTDIR}
${TOUCH} ${AMANDA_DATES}
- ${CHOWN} ${AMANDA_USER}:${AMANDA_GROUP} ${AMANDA_DATES}
-
-.endif
+ ${CHOWN} ${USERS}:${GROUPS} ${AMANDA_DATES}
+ ${CAT} ${PKGMESSAGE}
-.if defined(WITH_ZFSCOMP)
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-application-src::amzfs-sendrecv.pl
.endif
# MEMO:
# Prefix @WANT_SERVER_TRUE@ for server only files.
# Prefix @WANT_CLIENT_TRUE@ for client only files.
# For debugging: dbprintf(_("getcmd: %s\n"), line);
-# Maintainer TODO:
-# o amanda-server installs libexec/amanda/amandad, sbin/amarchiver
-# which should be handled by amanda-client only.
-# o pthread issue: http://wiki.zmanda.com/index.php/Installation/OS_Specific_Notes/Installing_Amanda_on_FreeBSD#Threading_and_-pthread
.include <bsd.port.post.mk>