aboutsummaryrefslogtreecommitdiffstats
path: root/misc/asbutton
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2007-05-27 04:39:02 +0800
committerkrion <krion@FreeBSD.org>2007-05-27 04:39:02 +0800
commit0e40ba3231e13ef1e427b82c75871827de7f1588 (patch)
tree9f20fbb6e29dc12f341589af88f3fbf6d18565fe /misc/asbutton
parent49eee82af863d42175907892f42be544e3a3ae64 (diff)
downloadfreebsd-ports-gnome-0e40ba3231e13ef1e427b82c75871827de7f1588.tar.gz
freebsd-ports-gnome-0e40ba3231e13ef1e427b82c75871827de7f1588.tar.zst
freebsd-ports-gnome-0e40ba3231e13ef1e427b82c75871827de7f1588.zip
Fix build with gcc4.2
Diffstat (limited to 'misc/asbutton')
-rw-r--r--misc/asbutton/Makefile4
-rw-r--r--misc/asbutton/files/patch-asbutton.c14
2 files changed, 14 insertions, 4 deletions
diff --git a/misc/asbutton/Makefile b/misc/asbutton/Makefile
index 4a3ce1370954..e528e6efcf17 100644
--- a/misc/asbutton/Makefile
+++ b/misc/asbutton/Makefile
@@ -23,10 +23,6 @@ MAKE_ARGS= INCLUDES="-I${X11BASE}/include/X11 -I${X11BASE}/include" \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's:gcc :${CC} :' ${WRKSRC}/Makefile
diff --git a/misc/asbutton/files/patch-asbutton.c b/misc/asbutton/files/patch-asbutton.c
new file mode 100644
index 000000000000..caeeb866c5c9
--- /dev/null
+++ b/misc/asbutton/files/patch-asbutton.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- asbutton.c.orig
++++ asbutton.c
+@@ -605,7 +605,7 @@
+ continue;
+ }
+ if ( !strncasecmp(line, "button", 6))
+- if (atoi(&(char)line[6]) == position)
++ if (atoi((char)line[6]) == position)
+ break;
+ }
+ } while (1);